Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
configure: error: cannot compute suffix of object files
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message

Joined: 24 Nov 2005
Posts: 179
Location: OKlahoma, USA

PostPosted: Tue Jun 26, 2012 10:33 pm    Post subject: configure: error: cannot compute suffix of object files Reply with quote

I guess this is a sparc problem. I was trying to build the Dark Star Final Fantasy XI private server. configure told me that I was missing some math functions and it couldn't continue. I did some searching on their forum and someone said that he had the same problem with his system and he solved it by installing g++-multilib. So I did some research, and I found . I've performed all the steps up to Code Listing 2.5. I ran into a problem there because no longer seems to exist. I can't install glibc because I don't have a binary with mutilib compiled in, and I can't install gcc to make a binary of glibc compiled in because every time I try I end up with "configure: error: cannot compute suffix of object files: cannot compile". As far as I can tell, no one has managed to find a single user-fits-all type solution for this problem. At this moment I'm installing a gentoo system onto a flash drive hooked into my personal desktop. It's creating binaries as it goes, and it's configured according to the multilib guide. I'm hoping that it will be able to create binaries of gcc and glibc (the same version installed on the my desired multilib system) that I can extract and rebuild everything with. The gcc build log file has funky text characters in it that did not display when I tried to build it in the terminal, or I would post it here. I still can if you need to see it in order to help me. I will post emerge --info here..
carter ~ # emerge --info =sys-devel/gcc-4.5.3-r2; emerge -pqv =sys-devel/gcc-4.5.3-r2
Portage (default/linux/sparc/experimental/multilib/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo i686)
System Settings
System uname: Linux-3.2.12-gentoo-i686-AMD_Athlon-tm-_7550_Dual-Core_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 26 Jun 2012 05:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash: 4.2_p20
dev-java/java-config: 2.1.12
dev-lang/python: 2.6.8, 2.7.3-r1, 3.1.5, 3.2.3
dev-util/cmake: 2.8.7-r5
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.10.3
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 4.3.4, 4.4.5, 4.5.3-r2
sys-devel/gcc-config: 1.5-r2
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc: 2.14.1-r3
Repositories: gentoo x11
CFLAGS="-O2 -pipe -ggdb"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ggdb"
EMERGE_DEFAULT_OPTS="--with-bdeps y --autounmask-write"
FEATURES="assume-digests binpkg-logs buildpkg distcc distlocks ebuild-locks fixlafiles news nostrip parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en es fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3networking X a52 aac acl alsa apache2 arts bash-completion berkdb bind-mysql branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dhcp doc dri dts dvd dvdr emboss encode examples exif exim fam firefox flac foomaticdb fortran gallium gdbm geoip gif gpm gstreamer gtk iconv imap imlib innodb ipv6 ithreads jadetex jpeg lcms ldap libclamav libg++ libnotify libwww lua mad mikmod mng mode-owner modules moonlight mp3 mp4 mpeg mpm-leader mudflap multilib mysql ncurses nls nptl nptlonly oav offensive ogg opengl openmp pam pango pcre pdf perl perlsuid php png policykit ppds pppd python qt qt3support readline ruby samba sdl search server session slp sparc spell ssl startup-notification static-libs svg syslog tcpd tetex threads tiff tk truetype udev udisks unicode upower usb virus-scan vorbis wxwidgets x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="pvrusb2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en es fr" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga r128 radeon sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Package Settings

sys-devel/gcc-4.5.3-r2 was built with the following:
USE="cxx doc fortran (gtk) mudflap nls nptl openmp (x86) (-altivec) -bootstrap -build (-fixed-point) -gcj -graphite (-hardened) (-libssp) -lto (-multilib) -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla"
CFLAGS="-O2 -march=i686 -pipe -ggdb"
CXXFLAGS="-O2 -march=i686 -pipe -ggdb"

[ebuild R ] sys-devel/gcc-4.5.3-r2 USE="cxx doc fortran mudflap (multilib*) nls nptl openmp (-altivec) -bootstrap -build (-fixed-point) -gcj -graphite (-gtk*) (-hardened) (-libssp) -lto -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla"
carter ~ #

Please help!
Back to top
View user's profile Send private message

Joined: 24 Nov 2005
Posts: 179
Location: OKlahoma, USA

PostPosted: Wed Jun 27, 2012 3:08 am    Post subject: Reply with quote

I think that instead of messing with this I'm going to install virtualbox and create a different Linux environment for this project
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 11 Oct 2003
Posts: 114

PostPosted: Sun Jul 01, 2012 3:07 am    Post subject: Reply with quote

It looks like you've solved your problem another way, but just to clarify-

"multilib" in general means installing libraries for multiple architectures on the same system. Usually these architectures are related - for example x86 and x86_64. x86_64 CPUs can easily run plain 32bit programs natively, as long as any required 32bit libraries are installed. Similarly, Sparc64 can also run 32 and 64bit (Sparc) software. However most Sparc64 machines only have 32bit code installed since it runs faster on this architecture. Those instructions you found were for installing 64bit libraries, and are apparently a bit dated :(.

Judging from your emerge --info, you have a plain old x86 machine, so multilib isn't applicable to you - in fact following those instructions could leave you with a broken system :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum