Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't WiFi after messing with wpa_passphrase
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 603
Location: Almeria, Spain

PostPosted: Wed Oct 21, 2020 10:10 pm    Post subject: [SOLVED] Can't WiFi after messing with wpa_passphrase Reply with quote

Hi!

To make a long story short, I had a perfectly working WiFi connection to the 5GHz SSID from my router until I tried to get wifi on after booting up but before loggin into KDE.

As far as I can recall, the only change I don't know how to revert is having issued a
Code:
/usr/bin/wpa_passphrase My_WiFi
command as root, getting this result:
Code:
# /usr/bin/wpa_passphrase My_WiFi
# reading passphrase from stdin
MyPassWord
network={
        ssid="My_WiFi"
        #psk="MyPassWord"
        psk=abbf7f7e762824f6badc64e7225d3a3e1a195310f5d55684f9af0c9670bc50f3
}
#


Now, I can't even log into My_WiFi from within KDE: the NetworkManager applet continuously asks me for the password, even though is it correctly configured and the password is correctly entered (both in the popping up dialog box and in the applet config).

However, I can still connect to the regular 2.4GHz SSID, the configuration of which I left untouched.

Is this some file permissions issue? Is it something else?

I'm completely clueless.


Last edited by urcindalo on Thu Oct 22, 2020 5:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3541

PostPosted: Thu Oct 22, 2020 6:15 am    Post subject: Reply with quote

psk in your /etc/wpa_supplicant/wpa_supplicant.conf needs to exactly match the psk set in your router.
Does it? And why not simply enter it in wpa_gui ?
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 603
Location: Almeria, Spain

PostPosted: Thu Oct 22, 2020 4:13 pm    Post subject: Reply with quote

charles17 wrote:
psk in your /etc/wpa_supplicant/wpa_supplicant.conf needs to exactly match the psk set in your router.
Does it? And why not simply enter it in wpa_gui ?


I'm so stupid you could cut my idiocy with a knife!

It turns out I was entering the wrong password. I like to customize the WiFi SSIDs and passwords, but my router needs at least a 15-character password for each WiFi. My regular password has 14, so I used my regular one but adding a # at the end for it to be accepted by the router. However, I'm so dumb I was entering the password without the final # :oops:

As a result of all this, I also solved my original problem: by adding the new WiFi config to /etc/wpa_supplicant/wpa_supplicant.conf, my box now gets connected before I log into KDE :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum