Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Autocompletion in Codelite From git, don't works [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Thu Oct 08, 2020 10:15 am    Post subject: Autocompletion in Codelite From git, don't works [Solved] Reply with quote

I asked in Codelite Forum before, but I haven't luck. Please if somebody here have experience with him...

I got the last version (14.04) from git.

The compilation procedure was make following the next steps: (taken from README.md)

Code:
  cd codelite
  mkdir build-release
  cd build-release
  cmake .. -DCMAKE_BUILD_TYPE=Release
  cmake --build . -j16
  sudo cmake --build . --target install


Under settings-> Code Completion-> search paths, I have set


Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/x86_64-pc-linux-gnu
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/backward
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include-fixed
/usr/include
/usr/include/linux/


But simply (after save || restart codelite) don't works, and I have not Idea why.

Please, someone so kind to help me?
Thanks in advance


Last edited by Yczo on Fri Oct 09, 2020 10:27 am; edited 1 time in total
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Thu Oct 08, 2020 10:34 am    Post subject: Reply with quote

Well, at this point of time, things changed a little, you maybe surprise... I will let you see for yourself in 2 recent issues:
https://github.com/eranif/codelite/issues/2406
https://github.com/eranif/codelite/issues/2456

So, yes, you need one clangd LanguageServer, even if you are using gcc.
_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Thu Oct 08, 2020 10:39 am    Post subject: Reply with quote

Thank you very much!!

I'll take a look
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Thu Oct 08, 2020 10:59 am    Post subject: Reply with quote

Quote:
So, yes, you need one clangd LanguageServer, even if you are using gcc.


Excuse my ignorance. Doesn't gentoo have a clangd ebuild? All I saw was the clang compiler, but isn't that different from the clangd server?
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Thu Oct 08, 2020 11:01 am    Post subject: Reply with quote

Yczo wrote:
Quote:
So, yes, you need one clangd LanguageServer, even if you are using gcc.


Excuse my ignorance. Doesn't gentoo have a clangd ebuild? All I saw was the clang compiler, but isn't that different from the clangd server?

Don't worry! Everything is on the sys-devel/clang package.
_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Thu Oct 08, 2020 11:06 am    Post subject: Reply with quote

After the installation of clang, you can try:
From CodeLite's menu bar, go to: Plugins -> Language Server -> Settings and click Scan button

By the way, just for info, there is no "clangd" executable on the Ubuntu clang-tools package also:
https://packages.ubuntu.com/focal/amd64/clang-tools/filelist:
Code:
/usr/bin/c-index-test
/usr/bin/clang-apply-replacements
/usr/bin/clang-check
/usr/bin/clang-query
/usr/bin/sancov
/usr/bin/scan-build
/usr/bin/scan-view
/usr/share/doc/clang-tools/NEWS.Debian.gz
/usr/share/doc/clang-tools/changelog.gz
/usr/share/doc/clang-tools/copyright
/usr/share/man/man1/clang-apply-replacements.1.gz
/usr/share/man/man1/clang-check.1.gz
/usr/share/man/man1/clang-query.1.gz
/usr/share/man/man1/sancov.1.gz
/usr/share/man/man1/scan-build.1.gz
/usr/share/man/man1/scan-view.1.gz

_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Thu Oct 08, 2020 11:06 am    Post subject: Reply with quote

Thank you!
I have it installed, then misconfigured, i did not use the clang global use variable. I'll see the wiki

Thank you very much
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Thu Oct 08, 2020 9:38 pm    Post subject: Reply with quote

Unfortunately does not work :-(

I adjusted the "clang" use variable in make.conf, then I updated the enviroment with emerge -a --update --deep --newuse @world, then i compiled the codelite again.

I had not the clang binaries in /usr/bin, then I did make symbolic links with ln -sr /usr/lib/llvm/10/bin/* /usr/bin; I did plugins->language Server-> scan and configure Settings->code completion to:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/x86_64-pc-linux-gnu
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/backward
/usr/lib/clang/10.0.1/include
/usr/include


but doesn't work

Any Idea will be welcomed.

Thanks in advance
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Thu Oct 08, 2020 9:57 pm    Post subject: Reply with quote

Yczo wrote:
Unfortunately does not work :-(

I adjusted the "clang" use variable in make.conf, then I updated the enviroment with emerge -a --update --deep --newuse @world, then i compiled the codelite again.

I had not the clang binaries in /usr/bin, then I did make symbolic links with ln -sr /usr/lib/llvm/10/bin/* /usr/bin; I did plugins->language Server-> scan and configure Settings->code completion to:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/x86_64-pc-linux-gnu
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/backward
/usr/lib/clang/10.0.1/include
/usr/include


but doesn't work

Any Idea will be welcomed.

Thanks in advance

Well, I don't use codelite, so the best I can say is that if the official instructions in:
https://wiki.codelite.org/pmwiki.php/Main/LanguageServer
don't work, then you have one issue here, and should report at:
https://github.com/eranif/codelite/issues
so it can be fixed to everyone.
_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Fri Oct 09, 2020 10:03 am    Post subject: Reply with quote

In any case, I am very grateful to you and I will keep trying,

Greetings!!
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Fri Oct 09, 2020 10:14 am    Post subject: Reply with quote

Yczo wrote:
In any case, I am very grateful to you and I will keep trying,

Greetings!!

As in the other related issues (in https://github.com/eranif/codelite/issues), there was no further answer, I assumed that everyone managed to solve the problem, but that may not be the case.
So I intend to keep following there too, after you post the issue.
_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
Yczo
Apprentice
Apprentice


Joined: 09 Jul 2011
Posts: 209

PostPosted: Fri Oct 09, 2020 10:27 am    Post subject: Reply with quote

Did Work!!!!


In Plugins->Language Server, -> settings =>(scan) it configures the next line

Code:
/home/myUser/.codelite/lsp/clang-tools/clangd -limit-results=500 -header-insertion-decorators=0


I changed it for my clangd link location:
Code:
/usr/bin/clangd -limit-results=500 -header-insertion-decorators=0


So, it's a small issue in scan.

Thank you again!!
Back to top
View user's profile Send private message
ff11
l33t
l33t


Joined: 10 Mar 2014
Posts: 657

PostPosted: Fri Oct 09, 2020 10:31 am    Post subject: Reply with quote

Yczo wrote:
Did Work!!!!


In Plugins->Language Server, -> settings =>(scan) it configures the next line

Code:
/home/myUser/.codelite/lsp/clang-tools/clangd -limit-results=500 -header-insertion-decorators=0


I changed it for my clangd link location:
Code:
/usr/bin/clangd -limit-results=500 -header-insertion-decorators=0


So, it's a small issue in scan.

Thank you again!!

Oh! Very good.
You can still post it at https://github.com/eranif/codelite/issues
so you don't need to do this again in future releases (^_^)/
_________________
| Proverbs 26:12 |
| There is more hope for a fool than for a wise man that are wise in his own eyes. |
* AlphaGo - The Movie - Full Documentary
"I want to apologize for being so powerless" - Lee
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum