Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Boutons tactiles
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Thu Oct 01, 2020 8:25 am    Post subject: Boutons tactiles Reply with quote

Bonjour,

J'ai installé Gentoo/Xfce sur un HP Pavilion Entertainment PC (Core2 T6400, Nvidia 9300M) et dans l'ensemble, après quelques réglages, tout semble foncitonner plutôt bien.

En revanche, j'ai un souci avec les boutons de volume (boutons tactiles lumineux au-dessus du clavier). La coupure de son et l'aumentation de niveau fonctionnent bien après les avoir définis dans les préférences Clavier. En revanche, je suis obligé de supprimer le raccourci pour baisser le volume, car quand défini, si je l'utilise il "reste enfoncé". Le volume descend jusqu'à muter le son et le clavier devient inutilisable.

Je pense à un problème hardware (auquel cas je ne pense pas être en mesure de réparer), mais pensez-vous qu'il ppuisse y avoir une solution soft pour régler le problème ?

Merci pour votre aide.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1729
Location: 127.0.0.1

PostPosted: Thu Oct 01, 2020 10:53 am    Post subject: Reply with quote

Salut,

Quote:

Le volume descend jusqu'à muter le son et le clavier devient inutilisable.

Je pense à un problème hardware (auquel cas je ne pense pas être en mesure de réparer), mais pensez-vous qu'il ppuisse y avoir une solution soft pour régler le problème ?


Qu'est ce que tu appelles un « bouton tactile » ? çà ressemble à çà ?
Soit un problème hardware, ou alors bouton qui semble rester coincé pour cause de saleté/poussière qui s'accumule entre la touche et le capteur en dessous (déjà vu).
Dans ce cas, démontage du cache/clavier et nettoyage. Avec un peu de chance, avec un compresseur ou une bombe d'air comprimé la saleté en question peut bouger sans démontage.
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Thu Oct 01, 2020 11:40 am    Post subject: Reply with quote

Merci. Oui c'est exactement celui-ci :)

Nettoyer l'ordi, je viens de le faire (ave remplacement de la pâte thermique qui m'a fait gagner dans les 20°C !! Dire que j'étais sur le point d'accuser Gentoo de mal gérer la température CPU... :lol: )
Peut-être que je n'ai pas assez insisté sur ce contact. D'un côté je ne vois pas concrètement ce que je peux faire puisque ce n'est pas un bouton "mécanique"... J'ai peur qu'une panne matérielle sur ce genre de capteur soit irréparable :?
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1729
Location: 127.0.0.1

PostPosted: Thu Oct 01, 2020 12:43 pm    Post subject: Reply with quote

Essaye d'utiliser xev pour voir les évènements produits par le clavier
lorsque la touche en question est pressée.

Par exemple, lorsque je presse (et relâche) une fois la touche media
correspondant à XF86AudioStop, j'obtiens ceci (un keypress, un keyrelease) :

Code:

KeyPress event, serial 38, synthetic NO, window 0x6600001,
    root 0x1dd, subw 0x0, time 18392813, (105,-16), root:(1125,123),
    state 0x10, keycode 174 (keysym 0x1008ff15, XF86AudioStop), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 38, synthetic NO, window 0x6600001,
    root 0x1dd, subw 0x0, time 18392813, (105,-16), root:(1125,123),
    state 0x10, keycode 174 (keysym 0x1008ff15, XF86AudioStop), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Thu Oct 01, 2020 5:23 pm    Post subject: Reply with quote

Merci.

Donc ça semble bien être ça, l'appui sur Volume+ est un peu aléatoire mais il fonctionne. En revanche, l'appui sur Volume- déclenche des séries de "KeyPress" "KeyRelease" et le timer continue de défiler (sur les 2 évènements) même quand j'ai relâché. Parfois en réappuyant, j'arrive à arrêter le timer (bouton considéré comme relâché définitivement je pense).

:(

Je crois qu'à part régler le problème niveau hardware, je ne pourrais pas faire grand chose. En tout cas, j'aimerais comprendre concrètement comment fonctionne ce type de contacteurs pour mieux cibler mes recherches si je re-démonte le PC
J'aimerais bien tester un live Xubuntu quand même pour voir si la gestion des contacteurs tactiles est moins aléatoire ou si je retrouve exactement les mêmes soucis.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce


Last edited by Anard on Thu Oct 01, 2020 7:34 pm; edited 4 times in total
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Thu Oct 01, 2020 6:48 pm    Post subject: Reply with quote

Peut-être un peu un autre sujet,

Mais sur ce PC, j'ai également une télécommande (logée au-dessus du lecteur SD/MMC) et qui réunit les mêmes fonctions que les boutons tactiles qui me posent problème.
Cependant, avec mon install de base, pour le moment, la télécommande n'est pas reconnue du tout.

Auriez-vous quelques conseils pour tenter de faire fonctionner cet artifice ? En l'occurrence, ça pourrait me permettre de me soustraire à ce faux-contact si la télécommande fonctionnait.
Cases à cocher lors de la "génération" du kernel (genkernel --menuconfig), quelques logiciels à installer... ou tout simplement un super lien qui traite de ce sujet précis ???

Merci beaucoup.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1729
Location: 127.0.0.1

PostPosted: Fri Oct 02, 2020 6:40 am    Post subject: Reply with quote

Salut,

Pour la télécommande, je pense que tu dois activer/configurer tout le framework IR/LIRC (InfraRed). Regarde ici la section télécommande. Tu devras probablement activer dans le kernel l'option CONFIG_LIRC (et peut-être d'autres), et installer/configurer app-misc/lirc.
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 9:27 am    Post subject: Reply with quote

Merci.
Concrètement je ne sais plus trop ce que j'ai activé/désactivé dans le kernel, je me suis basé sur le fait qu'il est noté "RC6" sur la télécommande puis j'ai installé lirc.
Niveau configuration, c'était assez simple puisque je n'ai rien fait pour la faire fonctionnner (hormis remettre une pile neuve :P)

Ca fonctionne à merveille, il suffit de configurer les boutons dans les préférrences clavier d'Xfce comme pour une touche normale.
8)

Je pense que c'est la meilleure solution puisqu'apperemment, les autres touches tactiles déconnent aussi aléatoirement (restent "enfoncées"). Au moins la télécommande utilise des touches mécaniques et fiables.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum