Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with emerging dev-qt/qt-creator. Slot conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
gent00chan
n00b
n00b


Joined: 14 Sep 2020
Posts: 3

PostPosted: Tue Sep 22, 2020 10:16 am    Post subject: Problems with emerging dev-qt/qt-creator. Slot conflict Reply with quote

When I try to emerge --ask dev-qt/qt-creator it gives me this output:
I'm new to Gentoo and I have no idea how to analyze this output to resolve this issue.
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-devel/clang-common-10.0.1
[ebuild  N     ] sys-devel/clang-10.0.1  USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -default-lld -doc -test" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8 (-python3_9)"
[ebuild     U ~] dev-qt/qtcore-5.15.1 [5.14.2]
[ebuild     U ~] dev-qt/qttest-5.15.1 [5.14.2]
[ebuild     U ~] dev-qt/qtnetwork-5.15.1 [5.14.2-r1] USE="-libressl%"
[ebuild     U ~] dev-qt/qtdbus-5.15.1 [5.14.2]
[ebuild  N     ] sys-devel/gdb-9.2  USE="client nls python server xml -lzma -multitarget -source-highlight -test -vanilla -xxhash" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8"
[ebuild     U ~] dev-qt/qtgui-5.15.1 [5.14.2-r1]
[ebuild  N     ] sys-libs/compiler-rt-10.0.1  USE="clang -test"
[ebuild  N     ] sys-libs/compiler-rt-sanitizers-10.0.1  USE="clang libfuzzer profile sanitize xray -test"
[ebuild  N     ] sys-libs/libomp-10.0.1  USE="(-cuda) -hwloc -offload -ompt -test" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-devel/clang-runtime-10.0.1  USE="compiler-rt openmp sanitize -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] sys-devel/llvm-10.0.0 [10.0.1]
[ebuild  N     ] dev-cpp/yaml-cpp-0.6.3-r3  USE="-test" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qthelp-5.14.2  USE="-debug -test"
[ebuild     U ~] dev-qt/qtwidgets-5.15.1 [5.14.2]
[ebuild     U ~] dev-qt/qtdeclarative-5.15.1 [5.14.2-r4]
[ebuild  N    ~] dev-libs/libclangformat-ide-10.0.0  USE="-debug"
[ebuild  N    ~] dev-qt/qtquicktimeline-5.15.1  USE="-debug -test"
[ebuild  N    ~] dev-qt/qt-creator-4.12.3  USE="autotest clang designer git help qmldesigner webengine -android -baremetal -beautifier -boot2qt -clearcase -cmake -cppcheck -ctfvisualizer -cvs -doc -glsl -ios -lsp -mcu -mercurial -modeling -nim -perforce -perfprofiler -python -qbs -qmlprofiler -qnx -remotelinux -scxml -serialterminal -silversearcher -subversion -systemd -test -valgrind -webassembly -winrt" L10N="-cs -da -de -fr -ja -pl -ru -sl -uk -zh-CN -zh-TW"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.14.2:5/5.14.2::gentoo, installed) USE="icu -debug -old-kernel -systemd -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.14.2:5= required by (dev-qt/qtbluetooth-5.14.2-r1:5/5.14::gentoo, installed) USE="qml -debug -test" ABI_X86="(64)"
    ^              ^^^^^^^^^                                                                                                                                                                                                                                                                 
    >=dev-qt/qtcore-5.12.3:5/5.14.2= required by (kde-frameworks/kxmlgui-5.70.0:5/5.70::gentoo, installed) USE="-debug -designer -doc -test" ABI_X86="(64)"
                          ^^^^^^^^^^                                                                                                                                                                                                                                                         
    (and 47 more with the same problems)

  (dev-qt/qtcore-5.15.1:5/5.15.1::gentoo, ebuild scheduled for merge) USE="icu -debug -old-kernel -systemd -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.15.1 required by (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   
    (and 6 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.14.2-r4:5/5.14::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
    >=dev-qt/qtdeclarative-5.12.3:5/5.14= required by (kde-frameworks/qqc2-desktop-style-5.70.0:5/5.70::gentoo, installed) USE="-debug -test" ABI_X86="(64)"
                                 ^^^^^^^^                                                                                                                                                                                                               
    ~dev-qt/qtdeclarative-5.14.2 required by (dev-qt/qtsensors-5.14.2:5/5.14::gentoo, installed) USE="qml -debug -test" ABI_X86="(64)"
    ^                     ^^^^^^                                                                                                                                                                                                                                         
    (and 14 more with the same problems)

  (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdeclarative-5.15.1 required by (dev-qt/qtquicktimeline-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)"
    ^                     ^^^^^^                                                                                                                                                                                                                                         

dev-qt/qtgui:5

  (dev-qt/qtgui-5.14.2-r1:5/5.14.2::gentoo, installed) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.14.2[gles2-only=,png=,X?] required by (dev-qt/qtwidgets-5.14.2:5/5.14::gentoo, installed) USE="X gtk png -debug -gles2-only -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                                                                                         
    >=dev-qt/qtgui-5.12.3:5/5.14.2=[jpeg] required by (kde-plasma/plasma-workspace-5.18.5-r1:5/5::gentoo, installed) USE="calendar handbook semantic-desktop -appstream -debug -geolocation -gps -qalculate -qrcode -systemd -telemetry -test" ABI_X86="(64)"
                         ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    (and 28 more with the same problems)

  (dev-qt/qtgui-5.15.1:5/5.15.1::gentoo, ebuild scheduled for merge) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.15.1[gles2-only=,png=,X?] required by (dev-qt/qtwidgets-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="X gtk png -debug -gles2-only -test" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                                                                                                         
    (and 2 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.14.2-r1:5/5.14::gentoo, installed) USE="ssl -bindist -connman -debug -gssapi -libproxy -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.14.2 required by (dev-qt/qtxmlpatterns-5.14.2:5/5.14::gentoo, installed) USE="qml -debug -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                             
    >=dev-qt/qtnetwork-5.12.3:5/5.14=[ssl] required by (kde-frameworks/kio-5.70.1-r1:5/5.70::gentoo, installed) USE="X acl handbook kwallet -debug -designer -doc -kerberos -test" ABI_X86="(64)"
                             ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                             
    (and 7 more with the same problems)

  (dev-qt/qtnetwork-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="ssl -bindist -connman -debug -gssapi -libproxy -libressl -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.15.1 required by (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.14.2:5/5.14::gentoo, installed) USE="X gtk png -debug -gles2-only -test" ABI_X86="(64)" pulled in by
    >=dev-qt/qtwidgets-5.12.3:5/5.14= required by (kde-plasma/breeze-5.18.5:5/5::gentoo, installed) USE="X -debug -wayland" ABI_X86="(64)"
                             ^^^^^^^^                                                                                                                                                                                                                     
    ~dev-qt/qtwidgets-5.14.2[gles2-only=] required by (dev-qt/qtprintsupport-5.14.2:5/5.14::gentoo, installed) USE="cups -debug -gles2-only -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                           
    (and 15 more with the same problems)

  (dev-qt/qtwidgets-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="X gtk png -debug -gles2-only -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.15.1[gles2-only=] required by (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                 

sys-devel/llvm:10

  (sys-devel/llvm-10.0.1:10/10::gentoo, installed) USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar -z3" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" pulled in by
    ~sys-devel/llvm-10.0.1:10=[debug=,llvm_targets_AArch64?,llvm_targets_AMDGPU?,llvm_targets_ARM?,llvm_targets_BPF?,llvm_targets_Hexagon?,llvm_targets_Lanai?,llvm_targets_Mips?,llvm_targets_MSP430?,llvm_targets_NVPTX?,llvm_targets_PowerPC?,llvm_targets_RISCV?,llvm_targets_Sparc?,llvm_targets_SystemZ?,llvm_targets_WebAssembly?,llvm_targets_X86?,llvm_targets_XCore?,llvm_targets_ARC?,llvm_targets_AVR?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/clang-10.0.1:10/10::gentoo, ebuild scheduled for merge) USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -default-lld -doc -test" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8 (-python3_9)"
    ^               ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             

  (sys-devel/llvm-10.0.0:10/10::gentoo, ebuild scheduled for merge) USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar -z3" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARC -ARM -AVR -Hexagon -Lanai -MSP430 -Mips -PowerPC -RISCV -Sparc -SystemZ -WebAssembly -XCore" pulled in by
    ~sys-devel/llvm-10.0.0:10=[debug=] required by (dev-libs/libclangformat-ide-10.0.0:10/10::gentoo, ebuild scheduled for merge) USE="-debug" ABI_X86="(64)"
    ^               ^^^^^^^^^^                                                                                                                                                                                                                                               

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.15.1 required by (dev-qt/qtgui-5.15.1:5/5.15.1::gentoo, ebuild scheduled for merge) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtdbus-5.14.2:5/5.14::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.14.2 required by (dev-qt/qtgui-5.14.2-r1:5/5.14.2::gentoo, installed) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    (and 3 more with the same problem)

dev-qt/qttest:5

  (dev-qt/qttest-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qttest-5.15.1 required by (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qttest-5.14.2:5/5.14::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qttest-5.14.2 required by (dev-qt/qtdeclarative-5.14.2-r4:5/5.14::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                     

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


What is causing this?
And what do I have to do to solve this problem?
Back to top
View user's profile Send private message
alamahant
Guru
Guru


Joined: 23 Mar 2019
Posts: 555

PostPosted: Tue Sep 22, 2020 11:15 am    Post subject: Reply with quote

Hi did you do a full update before emerging qt-creator?
Try
Code:

emerge -uDNav @world
emerge -uDUav --keep-going --with-bdeps=y @world
emerge -a --depclean

Then do try to emerge qt-creator.
This might clear all other conflicts and leave only the llvm one.
Are using ~amd64?
If you are unable to install via emerge or even preferably to avoid emerging all the myriad packages yourself you can use this Qt installer which install Qt and Qtcreator in a subdirectory in your home dir.
http://download.qt.io/official_releases/qt/5.12/5.12.9/qt-opensource-linux-x64-5.12.9.run
:D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum