Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nVidia PowerMizer issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Illiander
Apprentice
Apprentice


Joined: 22 Feb 2011
Posts: 213

PostPosted: Sun Sep 20, 2020 4:57 am    Post subject: nVidia PowerMizer issues Reply with quote

I have a modern nVidia card, running the proprietary drivers.

nVidia PowerMizer works normally on boot up for a while, then gets stuck on performance level 2 of 5, which makes some graphics intensive things completely unusable.

Changing the mode to "prefer max performance" does nothing.

It seems like it has lost the ability to change the performance level.

How do I make my graphics card not be broken/lazy?

I'd be quite happy to have it stuck on max performance if that's the only option.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16011

PostPosted: Sun Sep 20, 2020 4:01 pm    Post subject: Reply with quote

What model graphics card is this? What kernel version are you running? What version of the nVidia proprietary drivers did you install? What is the version of the power management tool? Are there any interesting kernel messages logged, either when it first gets stuck or when you unsuccessfully tell it to switch to a higher performance level?
Back to top
View user's profile Send private message
Illiander
Apprentice
Apprentice


Joined: 22 Feb 2011
Posts: 213

PostPosted: Sun Sep 20, 2020 8:56 pm    Post subject: Reply with quote

Card: GeForce RTX 2080 Ti

Kernel: linus-5.4.48-gentoo

nVidia driver: 450.57-r1

Power Management tool: nVidia proprietary that came with the driver.

Logs: I don't have an ability to directly set the performance level, only the way it chooses which performance level. Setting how it chooses seems to work, but it doesn't ever change its choice.

---

Ok, this is *really* wierd. When I ran dmesg it unstuck.

dmesg gives lots and lots of this: (but I'm guessing that this is just my DVD drive coping with a commercial DVD)

Code:
[54467.370936] sr 9:0:0:0: [sr0] tag#9 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[54467.370939] sr 9:0:0:0: [sr0] tag#9 Sense Key : Illegal Request [current]
[54467.370941] sr 9:0:0:0: [sr0] tag#9 Add. Sense: Read of scrambled sector without authentication
[54467.370942] sr 9:0:0:0: [sr0] tag#9 CDB: Read(10) 28 00 00 32 ed 80 00 00 02 00
[54467.370945] blk_update_request: I/O error, dev sr0, sector 13350400 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[54467.370947] Buffer I/O error on dev sr0, logical block 1668800, async page read
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum