Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo hangs on login, screen looks pixely
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lieywe
n00b
n00b


Joined: 16 Sep 2020
Posts: 2

PostPosted: Wed Sep 16, 2020 5:41 pm    Post subject: gentoo hangs on login, screen looks pixely Reply with quote

Hi,
I've installed gentoo a couple of times by now.
This time, my screen looks weird and the system hangs (ssh to it doesn't work either)

Here is a link to a picture of my screen
https://ibb.co/y0zsGx0

Thanks in advance!

EDIT: this Happens after
fb0: switching to nouveaufb from EFI VGA
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2414
Location: Frankfurt, Germany

PostPosted: Thu Sep 17, 2020 5:23 pm    Post subject: Reply with quote

Hi lieywe,

welcome to the Gentoo forums!

It's difficult to guess what went wrong. It could be the graphics driver, it could be something else.

I would try to boot in text mode (VGA 80x25). If it works, you will know that something is wrong with the graphics mode. It it doesn't work, you will hopefully see more messages.

Do you know how to temporarily boot in text mode? You can change the kernel command line parameters for the next boot in the GRUB boot menu: press "E". Scroll down to the line with the kernel command line parameters. Usually it starts with "linux /vmlinuz-X-Y-Z root=...". ADD the parameters below:
Code:
nomodeset i915.modeset=0 nouveau.modeset=0

Then press "F10" to boot your machine.
Back to top
View user's profile Send private message
lieywe
n00b
n00b


Joined: 16 Sep 2020
Posts: 2

PostPosted: Sun Sep 20, 2020 1:40 pm    Post subject: Reply with quote

Thanks!

It worked. With your instructions I managed to get into the terminal again.
After that, I rebuilt the kernel and installed nvidia's drivers.
Now I can use my desktop again :)

If using nouveau's framebuffer, the problem persists though.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46279
Location: 56N 3W

PostPosted: Sun Sep 20, 2020 7:33 pm    Post subject: Reply with quote

lieywe,

Its a visual artifact probably caused what whatever in drawing into the pixel buffer having a different idea of the pixel buffer boundaries to the thing reading the pixel buffer to the display.

Passing an EDID file to the kernel may fix it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum