Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202007-34 ] Apache Ant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Tue Jul 28, 2020 8:26 am    Post subject: [ GLSA 202007-34 ] Apache Ant Reply with quote

Gentoo Linux Security Advisory

Title: Apache Ant: Multiple vulnerabilities (GLSA 202007-34)
Severity: normal
Exploitable: local
Date: 2020-07-27
Bug(s): #723086
ID: 202007-34

Synopsis

Apache Ant uses various insecure temporary files possibly allowing
local code execution.


Background

Ant is a Java-based build tool similar to ‘make’ that uses XML
configuration files.


Affected Packages

Package: dev-java/ant
Vulnerable: < 1.10.8
Unaffected: >= 1.10.8
Architectures: All supported architectures


Description

Apache Ant was found to be using multiple insecure temporary files which
may disclose sensitive information or execute code from an unsafe local
location.


Impact

A local attacker could possibly execute arbitrary code with the
privileges of the process, or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Apache Ant users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-java/ant-1.10.8"
   


References

CVE-2020-1945
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum