Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202007-29 ] rssh
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Tue Jul 28, 2020 3:26 am    Post subject: [ GLSA 202007-29 ] rssh Reply with quote

Gentoo Linux Security Advisory

Title: rssh: Multiple vulnerabilities (GLSA 202007-29)
Severity: normal
Exploitable: remote
Date: 2020-07-27
Bug(s): #699842
ID: 202007-29

Synopsis

Multiple vulnerabilities have been found in rssh, the worst of
which could result in the arbitrary execution of code.


Background

rssh is a restricted shell, allowing only a few commands like scp or
sftp. It is often used as a complement to OpenSSH to provide limited
access to users.


Affected Packages

Package: app-shells/rssh
Vulnerable: <= 2.3.4_p3
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in rssh. Please review the
CVE identifiers referenced below for details.


Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

Gentoo has discontinued support for rssh. We recommend that users
unmerge rssh:
Code:
# emerge --unmerge "app-shells/rssh"
   
NOTE: The Gentoo developer(s) maintaining rssh have discontinued support
at this time. It may be possible that a new Gentoo developer will update
rssh at a later date. OpenSSH (net-misc/openssh) may be able to provide
similar functionality using its extensive configuration.


References


CVE-2019-1000018

CVE-2019-3463
CVE-2019-3464
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum