Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Manifest verification failed
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 08 Feb 2004
Posts: 1162

PostPosted: Wed Jul 01, 2020 6:21 pm    Post subject: Manifest verification failed Reply with quote

Hi All,

When I get an error similar to this, changing the mirror, or sync'ing later on fixes it. Not this time:

# eix-sync && emerge -uaNDv --with-bdeps=y world
 * Running emerge --sync
>>> Syncing repository 'gentoo' into '/var/db/repos/gentoo'...
 * Using keys from /usr/share/openpgp-keys/gentoo-release.asc
 * Refreshing keys via WKD ...                                                              [ ok ]
>>> Starting rsync with rsync://[2a01:4f8:173:2c8b::2]/gentoo-portage...
>>> Checking server timestamp ...
I-Node Gentoo rsync service
Contact: rsyncadm (swirly thing)

Total rsync traffic yesterday: 2172.00 Mb
Number of rsync connections  : 668

receiving incremental file list
deleting gentoo-20200630.tar.xz.md5sum
deleting gentoo-20200630.tar.xz.gpgsig
[snip ...]


Number of files: 152,793 (reg: 126,342, dir: 26,451)
Number of created files: 46 (reg: 46)
Number of deleted files: 31 (reg: 30, dir: 1)
Number of regular files transferred: 139
Total file size: 211.27M bytes
Total transferred file size: 2.81M bytes
Literal data: 2.81M bytes
Matched data: 0 bytes
File list size: 3.28M
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 35.79K
Total bytes received: 6.36M

sent 35.79K bytes  received 6.36M bytes  311.97K bytes/sec
total size is 211.27M  speedup is 33.04
 * Manifest timestamp: 2020-07-01 09:38:26 UTC
 * Valid OpenPGP signature found:
 * - primary key: DCD05B71EAB94199527F44ACDB6B8C1F96D8BF6D
 * - subkey: E1D6ABB63BFCFB4BA02FDF1CEC590EEAC9189250
 * - timestamp: 2020-07-01 09:38:26 UTC
 * Verifying /var/db/repos/gentoo/.tmp-unverified-download-quarantine ...!!! Manifest verification failed:
Manifest mismatch for x11-base/Manifest.gz
  BLAKE2B: expected: ca47f42cb20979d6b64be86202fe40f04a802ee733081945d9b13a907bd46230ddfb7a40f566dc415a3bcdbfbe18bb264e85aa77fb568a093fc71500d68dd4da, have: b4bf63fc79cddeb16e6d6630d0c33171061fc8411c8c23ab7c17882bea2c5f1bf9c8bf653eadefbedc153a2cb6c5e6136ba46874574b1edab6a67724ec74b001
  SHA512: expected: 62402638660f280e66b0ce23b78a0a6f8ce42a7ecfe14986aba1512b3366144208d66870c6e4cc157412e90094956ef84fbe0ee35542e34a2313daf8a4ff8d36, have: 8313baa9e5bbc86ccf572b567472421dd3ae01382645f74f5eed4a966f33a243ae15576eb86ec67fdefa21370eb6225a335f7ed2a6d8e183b7fb3c92cbb0ebf7

I initially sync'ed against a local mirror on the LAN. Neither the local mirror nor other PCs had any problem with their portage tree verification. So, I left it for 10 hours and tried again, resync'ing the local mirror first and then the rest of the PCs. The same PC came up with the same error as above. So I changed to a different remote mirror, twice, the same error. :-/

Finally I deleted /var/db/repos/gentoo/.tmp-unverified-download-quarantine on the offending PC and tried again, same error.

Any idea why this is happening on one PC only and how to overcome it?
Back to top
View user's profile Send private message

Joined: 08 Feb 2004
Posts: 1162

PostPosted: Wed Jul 01, 2020 9:52 pm    Post subject: Reply with quote

I just compared an older machine where /usr/portage is owned by portage:portage and the problematic PC, where I noticed the /var/db/repos/gentoo/ is owned by root:root throughout. I'm not sure why this is so - I don't recall setting it up as root:root, although I did run emerge-webrsync once on it trying to fix it.

Is this related?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum