Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
opencv-4.1.2-r3 can't apply flag contribdnn [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jms.gentoo
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2009
Posts: 82

PostPosted: Sun Jun 28, 2020 12:04 am    Post subject: opencv-4.1.2-r3 can't apply flag contribdnn [solved] Reply with quote

Hi
I have opencv-4.1.2-r3 installed
Code:

eix -I opencv
[I] media-libs/opencv
     Available versions:  4.1.2-r3(0/4.1.2) {contrib contribcvv contribdnn contribhdf contribsfm contribxfeatures2d cuda debug dnnsamples -download +eigen examples +features2d ffmpeg gdal gflags glog gphoto2 gstreamer gtk3 ieee1394 java jpeg jpeg2k lapack opencl opencvapps openexr opengl openmp pch png +python qt5 tesseract testprograms threads tiff v4l vaapi vtk webp xine ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="avx avx2 fma3 popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="FreeBSD" PYTHON_TARGETS="python3_6 python3_7"}
     Installed versions:  4.1.2-r3(0/4.1.2)(20:11:18 22/06/2020)(eigen features2d ffmpeg jpeg opengl openmp png python qt5 threads tiff v4l vaapi -contrib -contribcvv -contribdnn -contribhdf -contribsfm -contribxfeatures2d -cuda -debug -dnnsamples -download -examples -gdal -gflags -glog -gphoto2 -gstreamer -gtk3 -ieee1394 -java -jpeg2k -lapack -opencl -opencvapps -openexr -pch -tesseract -testprograms -vtk -webp -xine ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="32 64 -x32" CPU_FLAGS_X86="avx avx2 fma3 popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="-FreeBSD" PYTHON_TARGETS="python3_7 -python3_6")


I want to set contribdnn id did try to set it in
in /etc/portage/package.use/media-libs
Code:

#>media-libs/opencv-4.1.0 contrib contribdnn
=media-libs/opencv-4.1.2-r3  contrib contribdnn


also

Code:

USE="contribdnn" emerge -pv1 media-libs/opencv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/opencv-4.1.2-r3:0/4.1.2::gentoo  USE="eigen features2d ffmpeg jpeg opengl openmp png python qt5 threads tiff v4l vaapi (-contrib) (-contribcvv) (-contribdnn) (-contribhdf) (-contribsfm) (-contribxfeatures2d) (-cuda) -debug -dnnsamples -download -examples -gdal (-gflags) (-glog) -gphoto2 -gstreamer -gtk3 -ieee1394 -java -jpeg2k -lapack -opencl -opencvapps -openexr -pch (-tesseract) -testprograms (-vtk) -webp -xine" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="avx avx2 fma3 popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" PYTHON_TARGETS="python3_7 -python3_6" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


but emerge won't set it why?

Thanks in advance for any help


Last edited by jms.gentoo on Sun Jun 28, 2020 1:49 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15623

PostPosted: Sun Jun 28, 2020 12:36 am    Post subject: Reply with quote

According to man emerge, that output means the flag is forced, masked, or removed. Looking at mask files, some architectures block it entirely, and others block it for users on stable. Based on the comments in the mask files, on x86/amd64, it is masked for stable because it is considered experimental. On the arm family, it is masked because it depends on non-keyworded supporting packages.
Back to top
View user's profile Send private message
GDH-gentoo
Guru
Guru


Joined: 20 Jul 2019
Posts: 434
Location: South America

PostPosted: Sun Jun 28, 2020 12:39 am    Post subject: Re: opencv-4.1.2-r3 can't apply contribdnn flag Why? Reply with quote

If you are on stable amd64 branch and you really want to set the USE flags, put media-libs/opencv in /etc/portage/package.accept_keywords, in addition to package.use. Specify =media-libs/opencv-4.1.2-r3 if you want to do this only for this version and revision of the package.

The former has the effect of unmasking the USE flags, the latter actually sets them.
Back to top
View user's profile Send private message
jms.gentoo
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2009
Posts: 82

PostPosted: Sun Jun 28, 2020 1:48 am    Post subject: Reply with quote

Thanks both Hu && GDH-gentoo , for your time

I have been running a base stable with some unstable and I don't remember coming across this problem.
Didn't realize you could have stable package with masked flag.

seems obvious now ..

Even more when RTFM
Code:
The following symbols are affixed to USE flags in order to indicate their status:

              Symbol   Location    Meaning
              ──────────────────────────────────────────────────────────────

              -        prefix      not enabled (either disabled or removed)
              *        suffix      transition to or from the enabled state
              %        suffix      newly added or removed
              ()       circumfix   forced, masked, or removed
              {}       circumfix   state is bound to FEATURES settings

Again thanks for your time!
jm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum