Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[dbus] Dbus se cae al precionar la tecla '¿' (Solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Fri Jul 31, 2020 7:35 pm    Post subject: [dbus] Dbus se cae al precionar la tecla '¿' (Solucionado) Reply with quote

Dbus se cae cada vez que presiono la tecla '¿', y eso cierra todos los programas que dependen de este (firefox, thunderbird, dolphin, etc), no importa en que programa este escribiendo, siempre se cae si presiono esa tecla, SOLO esa tecla.

Lo he ejecutado en terminal pero no lanza ningún error, tengo el problema desde hace un tiempo y las actualizaciones no lo corrigen.

Tengo:
La localizacion C.UTF-8,es_CL.UTF-8
KDE Frameworks 5.70.0
Qt 5.14.2
Controlador de Nvidia 390.138 (para GT610)
OpenRC
Nucleo 5.4.48-gentoo

Tengo el motor de renderizado XRender porque OpenGL(2.0 y 3.1) me da error y desactiva el compositor, al principio funcionaba pero ahora no.


Last edited by Carlos227 on Wed Aug 12, 2020 1:14 am; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Sat Aug 01, 2020 6:25 pm    Post subject: Reply with quote

Quizá tengas alguna configuración especial del teclado para xorg. ¿Qué dice
Code:
setxkbmap -print -verbose 10
?
¿Como sabes que es dbus quien se cae?
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Sun Aug 09, 2020 4:23 am    Post subject: Reply with quote

quilosaq wrote:
Quizá tengas alguna configuración especial del teclado para xorg. ¿Qué dice
Code:
setxkbmap -print -verbose 10
?
¿Como sabes que es dbus quien se cae?


El comando me muestra esto:
Code:
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     es
variant:    ,qwerty
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+es+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+es+inet(evdev)"     };
        xkb_geometry  { include "pc(pc105)"     };
};


Supongo que es dbus porque al intentar a abrir un programa como dolphin me muestra esto:

Code:
kf5.kio.core: "No se puede listar la URL\ntags:/"
kf5.kio.core: "No se puede listar la URL\ntags:/"
kf5.kio.core: "No se puede listar la URL\ntags:/"
"Session bus not found\nTo circumvent this problem try the following command (with Linux and bash)\nexport $(dbus-launch)"

y cuando dolphin no se cierra y cambio de carpeta muesta esto:
Imposible crear esclavo de E/S. No se puede dialogar con klauncher: Not connected to D-Bus server
Tambien pude ver en el monitor del sistema que el proceso dbus-launch se cierra.

Desde que publique la pregunta han cambiado algunas cosas,
Ahora no se cierra firefox, se queda abierto incluso cuando se cierra plasmashell
La tecla '¿' sigue causando el problema pero en silencio, hasta que abro el menú de aplicaciones, selecciono la opción salir y se cae todo (queda la pantalla negra).
si tengo suerte y tengo un terminal abierto puedo volver a ejecutarlo con

Code:
exec dbus-launch plasmashell
kwin_x11


Cuando lo vuelvo a ejecutar ya no se vuelve a cerrar y no aparece el proceso de nuevo en el monitor del sistema, pero ya no puedo apagar ni reiniciar desde el menú, solo aparece la opción de cerrar sesión y bloquear pantalla.
Mi archivo .xinitrc contiene:
Code:
#!/bin/sh

exec dbus-launch --exit-with-session startplasma-x11


Perdón por no responder antes, pero no me notifico de la respuesta.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Sun Aug 09, 2020 12:11 pm    Post subject: Reply with quote

En el tema del teclado para xorg supongo que estás usando un archivo de configuración quizá en
Quote:
/etc/X11/xorg.conf.d/
. Prueba a eliminar la línea
Quote:
Option "XkbVariant"
.
Para lo demás, suponiendo que estás iniciando xorg con startx, comprueba que el servicio elogind está configurado para arrancar en la fase boot.
Como prueba haz que dbus sea arrancado también en la fase boot a ver si cambia la situación.
Si sigues con problemas pon tu
Code:
emerge --info
.
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Sun Aug 09, 2020 3:44 pm    Post subject: Reply with quote

Hice todos los cambios y el problema continua, me di cuenta que primero se cierra el proceso dbus-daemon de mi usuario y después se cierra dbus-launch, queda un proceso dbus-daemon abierto pero es del usuario messagebus
Xorg se ejecuta automáticamente con

Code:
/etc/inittab
c1:12345:respawn:/sbin/agetty --autologin carlos 38400 tty1 linux
supongo que sera lo mismo pero automatico.

El teclado ahora contiene:
Code:
/etc/X11/xorg.conf.d/30-keyboard.conf
Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "es"
        Option "XkbRules" "xorg"
EndSection


Esta es la configuracion de portage

Code:
Portage 2.3.103 (python 3.7.8-final-0, default/linux/amd64/17.1/no-multilib, gcc-9.3.0, glibc-2.30-r8, 5.4.48-gentoo_version-1 x86_64)
=================================================================
System uname: Linux-5.4.48-gentoo_version-1-x86_64-AMD_Athlon-tm-_II_X3_450_Processor-with-gentoo-2.6
KiB Mem:     6095620 total,   4434248 free
KiB Swap:   19568636 total,  19568636 free
Timestamp of repository gentoo: Fri, 07 Aug 2020 17:30:01 +0000
Head commit of repository gentoo: f032d8abb2e1e00fb45e5caa591d354b8bb662b6
sh bash 5.0_p17
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
app-shells/bash:          5.0_p17::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r1::gentoo, 3.6.11-r2::gentoo, 3.7.8-r2::gentoo, 3.8.4-r1::gentoo
dev-util/cmake:           3.16.5::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts:
    sync-rsync-verify-jobs: 1

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -mtune=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -mtune=native -O2 -pipe"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo ftp://ftp.ussg.iu.edu/pub/linux/gentoo"
LANG="es_CL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl alsa amd64 berkdb bzip2 cli crypt dri elogind encode eudev experimental ffmpeg flac fortran gdbm iconv libtirpc live mp3 ncurses nls nptl openmp pam pcre readline seccomp split-usr ssl taglib tcpd theora unicode usb vorbis x264 x265 xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="es es-CL es-ES" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby25" SANE_BACKENDS="pixma epson2" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Y estos son los servicios configurados en openrc

Code:

Runlevel: sysinit
 sysfs                             [  started  ]
 devfs                             [  started  ]
 kmod-static-nodes                 [  started  ]
 opentmpfiles-dev                  [  started  ]
 cgroups                           [  started  ]
 udev                              [  started  ]
 dmesg                             [  started  ]
 udev-trigger                      [  started  ]
Runlevel: shutdown
 killprocs                         [  stopped  ]
 savecache                         [  stopped  ]
 mount-ro                          [  stopped  ]
Runlevel: boot
 termencoding                      [  started  ]
 hwclock                           [  started  ]
 modules                           [  started  ]
 fsck                              [  started  ]
 root                              [  started  ]
 mtab                              [  started  ]
 swap                              [  started  ]
 localmount                        [  started  ]
 sysctl                            [  started  ]
 bootmisc                          [  started  ]
 keymaps                           [  started  ]
 dbus                              [  started  ]
 hostname                          [  started  ]
 procfs                            [  started  ]
 binfmt                            [  started  ]
 opentmpfiles-setup                [  started  ]
 loopback                          [  started  ]
 save-termencoding                 [  started  ]
 urandom                           [  started  ]
 elogind                           [  started  ]
 save-keymaps                      [  started  ]
Runlevel: nonetwork
 local                             [  started  ]
Runlevel: default
 NetworkManager                    [  started  ]
 sysklogd                          [  started  ]
 cupsd                             [  started  ]
 minidlna                          [  started  ]
 postgresql-12                     [  started  ]
 netmount                          [  started  ]
 local                             [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
Dynamic Runlevel: manual
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Sun Aug 09, 2020 11:47 pm    Post subject: Reply with quote

Carlos227 wrote:
...
Xorg se ejecuta automáticamente con

Code:
/etc/inittab
c1:12345:respawn:/sbin/agetty --autologin carlos 38400 tty1 linux
supongo que sera lo mismo pero automatico.
...

Prueba a eliminar ese automatismo y arrancar con startx desde una consola tty.
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 3:29 am    Post subject: Realizando las pruebas Reply with quote

Tengo configurado estos tres archivos para que arranque automatico

Este inicia sesion sin pedir contraseña en el tty1, para las pruebas deje este desactivado
Code:
/etc/inittab
c1:12345:respawn:/sbin/agetty --autologin carlos 38400 tty1 linux

Este ejecuta startx, si lo desactivo, tengo que ejecutar manualmente el comando startx pero esta vez dbus-daemon no se cae pero dbus-launch se queda "detenido", no puedo cerrar sesion, apagar ni reiniciar.
Code:
/home/carlos/.bash_profile
if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]]; then exec startx; fi


Este inicia kde, si lo desactivo solo me queda la ventana negra con tres ventanas de XTerm, puedo ejecutar manualmente el comando del archivo .xinitrc dbus-daemon y dbus-launch no se cae y funciona todo, al cerrar sesion vuelvo a la ventana negra de xorg, tambien puedo reiniciar y apagar.
Code:
/home/carlos/.xinitrc
#!/bin/sh
exec dbus-launch --exit-with-session startplasma-x11

al parecer el problema se produce al usar el archivo .xinitrc, incluso dejando todos los demás activos, el problema es que me queda un XTerm abierta que no puedo cerrar, que comportamiento tan extraño, se supone que debería ser lo miso todo.
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2186
Location: Barcelona

PostPosted: Mon Aug 10, 2020 6:39 am    Post subject: Reply with quote

Intenta un par de cosas:

1- Hacer, como root, un revdep-rebuild por si hubiera alguna dependencia rota.

2- Con el sistema recién iniciado, abre una consola y ejecuta la orden dmesg para ver los mensajes del sistema. Pulsa la tecla maldita y luego haz otro dmesg para ver si hay algún mensaje nuevo con algún error.
_________________
pcmaster
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 1:20 pm    Post subject: Reply with quote

El primer comando, todo bien
Code:
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency

Your system is consistent


El segundo, no cambia nada entre antes y después, solo voy a pegar lo que aparece en rojo porque es muy largo y no se si pegarlo todo.

Code:
[    3.417692] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f0, key code 177): Invalid argument
[    3.417698] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f1, key code 178): Invalid argument
[    3.417703] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f2, key code 159): Invalid argument
[    3.417707] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f3, key code 158): Invalid argument
[    3.417711] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f4, key code 425): Invalid argument
[    3.417715] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f5, key code 421): Invalid argument
[    3.417719] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f6, key code 423): Invalid argument
[    3.417723] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f7, key code 216): Invalid argument
[    3.417728] udevd[634]: Error calling EVIOCSKEYCODE on device node '/dev/input/event4' (scan code 0x900f8, key code 206): Invalid argument


---

[    7.204456] r8169 0000:04:00.0: Unable to load firmware rtl_nic/rtl8168e-2.fw (-2)
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2186
Location: Barcelona

PostPosted: Mon Aug 10, 2020 2:03 pm    Post subject: Reply with quote

Hola,

La última línea se refiere a que no ha podido cargar el firmware de la tarjeta WiFi Realtek.

Las demás parecen errores del teclado, pero con teclas (scancodes) diferentes. Para comprobar de qué dispositivo se trata, debes comprobar a cuál corresponde /dev/input/event4 mirando en el archivo /proc/input/devices

Dicho archivo contiene varias secciones, una por dispositivo, una detrás de otra, con un espacio entre ellas. En ellas hay una línea que enpieza por H y te muestra a qué input corresponde. Por ejemplo en el caso de un teclado puede poner

H: Handlers=kbd event12
_________________
pcmaster
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 4:35 pm    Post subject: Reply with quote

Hola
No tengo una tarjeta wifi, tengo una tarjeta de red pci que funciona y otra de la placa madre que deshabilite en la bios, no se que puede ser.

El archivo
Code:
/proc/input/devices
no existe, pero hay uno en
Code:
/proc/devices
que contiene

Code:
Character devices:
  1 mem
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  7 vcs
 10 misc
 13 input
 29 fb
 86 ch
116 alsa
128 ptm
136 pts
180 usb
189 usb_device
195 nvidia-frontend
202 cpu/msr
203 cpu/cpuid
226 drm
248 nvidia-nvlink
249 hidraw
250 usbmon
251 bsg
252 ptp
253 pps
254 rtc

Block devices:
  7 loop
  8 sd
 11 sr
 65 sd
 66 sd
 67 sd
 68 sd
 69 sd
 70 sd
 71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd
259 blkext


Quizás sea el teclado, tiene 7 teclas extras que no funcionan.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Mon Aug 10, 2020 4:43 pm    Post subject: Reply with quote

Mira si existe
Quote:
/proc/bus/input/devices
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 6:45 pm    Post subject: Reply with quote

Si, esto sale en event4, al parecer si es el teclado
Code:
I: Bus=0003 Vendor=0458 Product=0708 Version=0110
N: Name="Chicony Multimedia Keyboard"
P: Phys=usb-0000:00:02.0-3.1/input0
S: Sysfs=/devices/pci0000:00/0000:00:02.0/usb2/2-3/2-3.1/2-3.1:1.0/0003:0458:0708.0001/input/input7
U: Uniq=
H: Handlers=sysrq kbd leds event4
B: PROP=0
B: EV=120013
B: KEY=1000000000007 ff9f207ac14057ff febeffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Mon Aug 10, 2020 7:05 pm    Post subject: Re: Realizando las pruebas Reply with quote

Carlos227 wrote:
...
Code:
/home/carlos/.xinitrc
#!/bin/sh
exec dbus-launch --exit-with-session startplasma-x11
...

¿Qué pasa si usas
Code:
/home/carlos/.xinitrc
#!/bin/sh
exec startplasma-x11
?

¿O simplemente
Code:
/home/carlos/.xinitrc
#!/bin/sh
startplasma-x11
?
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 8:42 pm    Post subject: Reply with quote

Con las dos opciones se queda en negro si nada mas.
probé también quitando el
Code:
--exit-with-session
que nunca encontré que hace pero salia en el manual y ahora funciona, eso era el problema, ahora dbus-launch no aparece en el monitor del sistema.

Me queda el problema del motor de renderizado pero eso es otro tema.

Gracias.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Mon Aug 10, 2020 8:47 pm    Post subject: Reply with quote

Comprueba que tu usuario pertenezca al grupo video.
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Mon Aug 10, 2020 9:01 pm    Post subject: Reply with quote

Si pertenece
Code:
video::27:root,carlos
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2186
Location: Barcelona

PostPosted: Tue Aug 11, 2020 5:41 am    Post subject: Reply with quote

Carlos227 wrote:
Hola
No tengo una tarjeta wifi, tengo una tarjeta de red pci que funciona y otra de la placa madre que deshabilite en la bios, no se que puede ser.


Cierto, es una Gigabit Ethernet. Supuse que era Wifi por lo de la carga del firmware.

Para que encuentre el firmware, asegúrate de tener instalado el paquete sys-kernel/linux-firmware
_________________
pcmaster
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Tue Aug 11, 2020 1:29 pm    Post subject: Reply with quote

Si era eso gracias, instale el programa y ahora no sale ese error, recuerdo no haberlo instalado a propósito porque me funcionaba el internet y pensé que era solo para el Wifi que no tenia. ¿que ventaja me da el firmware ahora? ya tenia la máxima velocidad antes 1GBits/s
Back to top
View user's profile Send private message
Carlos227
n00b
n00b


Joined: 31 Jul 2020
Posts: 17

PostPosted: Thu Aug 13, 2020 2:52 am    Post subject: Reply with quote

Encontré la solución al otro fallo que tenia, el de no poder usar OpenGL en el motor de renderizado de kde.
En el terminal me aparecía la linea
kf5.kconfig.core: Use of KConfigWatcher without DBus support. You will not receive updates
otra vez problemas con dbus, pero era que no configure el USE correctamente, me faltaba incluirlo, así que modifique el archivo
Code:
/etc/portage/make.conf
...
USE="dbus ........"
...


Luego solo unas horas en aplicar los cambios y listo
Code:
emerge --ask --changed-use --deep @world


Ahora me funciona OpenGL 2.0 y 3.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum