Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Suddenly can't connect to Steam
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
statikregimen
Apprentice
Apprentice


Joined: 16 Jul 2011
Posts: 173
Location: USA/Michigan

PostPosted: Thu Jun 18, 2020 3:06 am    Post subject: [SOLVED] Suddenly can't connect to Steam Reply with quote

Hello,

Hope I'm not missing something embarassing here, but a few weeks ago from this post, I noticed Steam stopped being able to auto-update itself (it kept popping up over and over to install the same update until I would eventually give up and cancel, but Steam still worked otherwise).

Then a few days ago, Steam just failed to ever log me in at all (usually hanging at the "Connecting Steam account" window). The system hadn't been updated in a while, so figured that's probably the issue.

Finally, on the night of this post, I was able to complete a deep update (incl. kernel & all layman overlays, rebuilt nvidia-drivers & rebooted, etc), with minor fuss. However, afterward, steam continues to fail to ever log me in. It starts, tries to self-update (no indication if it succeeds or fails), but eventually hangs again at the "Connecting Steam account" window (or sometimes the "Updating Steam Information" window, which shows a progress bar at 100%). If I let it sit long enough (like over night...? more than a couple hours, anyway), it does often throw a generic "couldn't connect" error/popup.

So then I decided to reinstall Steam from scratch (installed via steam-overlay) - unmerged it (plus depclean) and deleted my ~/.steam directory... Also emptied my iptables rules, to ensure I didn't change something there. Symptoms persist. My Steam account is fine, as I can log into steampowered.com normally.

I'm lost.

Here's the output when I run Steam from a terminal:

https://meaninglessinfo.com/steam.txt

Also, here's a log I thought might be interesting, but other than some apparent IPv6 issues, I don't see anything (from ~/.steam/steam/logs/):

https://meaninglessinfo.com/connection_log.txt

Not sure what else to share or look at, but there are a lot of logs in the same directory I'm happy to post if needed.

Thanks in advance for any help!

UPDATE:
I just realized that ~/.steam has symlinks (I think I knew that before but just didn't make the connection). That lead to a new reinstall attempt, after also deleting ~/.local/share/Steam....Now I'm getting an emerge error that steam-launcher is masked by ~amd64 keyword, which really doesn't make any sense at this time.

SOLVED:
Once I was finally able to reinstall Steam properly, everything seems to be working normally again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum