Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202006-22 ] OpenJDK, IcedTea
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Tue Jun 16, 2020 1:26 am    Post subject: [ GLSA 202006-22 ] OpenJDK, IcedTea Reply with quote

Gentoo Linux Security Advisory

Title: OpenJDK, IcedTea: Multiple vulnerabilities (GLSA 202006-22)
Severity: normal
Exploitable: remote
Date: 2020-06-15
Bug(s): #718720, #720690
ID: 202006-22

Synopsis

Multiple vulnerabilities have been found in OpenJDK and IcedTea,
the worst of which could result in the arbitrary execution of code.


Background

OpenJDK is a free and open-source implementation of the Java Platform,
Standard Edition.
IcedTea’s aim is to provide OpenJDK in a form suitable for easy
configuration, compilation and distribution with the primary goal of
allowing inclusion in GNU/Linux distributions.


Affected Packages

Package: dev-java/openjdk-bin
Vulnerable: < 8.252_p09
Unaffected: >= 8.252_p09
Architectures: All supported architectures

Package: dev-java/openjdk-jre-bin
Vulnerable: < 8.252_p09
Unaffected: >= 8.252_p09
Architectures: All supported architectures

Package: dev-java/icedtea-bin
Vulnerable: < 3.16.0
Unaffected: >= 3.16.0
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in OpenJDK and IcedTea.
Please review the CVE identifiers referenced below for details.


Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All OpenJDK binary users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-java/openjdk-bin-8.252_p09"
   
All OpenJDK JRE binary users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=dev-java/openjdk-jre-bin-8.252_p09"
   
All IcedTea binary users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-java/icedtea-bin-3.16.0"
   


References

CVE-2020-2585
CVE-2020-2585
CVE-2020-2755
CVE-2020-2755
CVE-2020-2756
CVE-2020-2756
CVE-2020-2757
CVE-2020-2757
CVE-2020-2773
CVE-2020-2773
CVE-2020-2781
CVE-2020-2781
CVE-2020-2800
CVE-2020-2800
CVE-2020-2803
CVE-2020-2803
CVE-2020-2805
CVE-2020-2805
CVE-2020-2830
CVE-2020-2830
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum