Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
aacraid not rebuilding raid 6 array
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jpsollie
Tux's lil' helper
Tux's lil' helper


Joined: 17 Aug 2013
Posts: 107

PostPosted: Sat Jun 13, 2020 5:57 am    Post subject: aacraid not rebuilding raid 6 array Reply with quote

the log will be pretty much self-explaining:


Code:

linuxserver # arcconf getconfig 1 ad
Controllers found: 1
----------------------------------------------------------------------
Controller information
----------------------------------------------------------------------
   Controller Status                          : Optimal
   Controller Mode                            : RAID (Expose RAW)
   Channel description                        : SAS/SATA
   Controller Model                           : Adaptec ASR72405
   Controller Serial Number                   : 3A10130C55B
   Controller World Wide Name                 : 50000D11064A6180
   Controller Alarm                           : Disabled
   Temperature                                : 73 C/ 163 F (Normal)
   Installed memory                           : 1024 MB
   Host bus type                              : PCIe
   Host bus speed                             : 8000 MHz
   Host bus link width                        : 4 bit(s)/link(s)
   Global task priority                       : High
   Performance Mode                           : Default/Dynamic
   PCI Device ID                              : 652
   Stayawake period                           : Disabled
   Spinup limit internal drives               : 5
   Spinup limit external drives               : 5
   Defunct disk drive count                   : 1
   NCQ status                                 : Enabled
   Statistics data collection mode            : Disabled
   Monitor Log Severity Level                 : Informational
   --------------------------------------------------------
   Cache Properties
   --------------------------------------------------------
   Controller Cache Preservation              : Enabled
   Global Physical Device Write Cache Policy  : Enabled
   --------------------------------------------------------
   RAID Properties
   --------------------------------------------------------
   Logical devices/Failed/Degraded            : 4/0/1
   Copyback                                   : Disabled
   Automatic Failover                         : Disabled
   Background consistency check               : Disabled
   Background consistency check period        : 30
   --------------------------------------------------------
   Controller BIOS Setting Information
   --------------------------------------------------------
   Runtime BIOS                               : Enabled
   Array BBS Support                          : Enabled
   Physical Drives Displayed during POST      : Disabled
   Backplane Mode                             : IBPI
   BIOS Halt on Missing Drive Count           : 255
   --------------------------------------------------------
   Controller Version Information
   --------------------------------------------------------
   BIOS                                       : 7.5-0 (32118)
   Firmware                                   : 7.5-0 (32118)
   Driver                                     : 1.2-1 (58012)
   Boot Flash                                 : 7.5-0 (32118)
   CPLD (Load version/ Flash version)         : 10/ 10
   SEEPROM (Load version/ Flash version)      : 1/ 1

   --------------------------------------------------------
   Controller Cache Backup Unit Information
   --------------------------------------------------------

    Overall Backup Unit Status                : Not Present
   --------------------------------------------------------
   Connector information
...

arcconf getconfig 1 ld Controllers found: 1
----------------------------------------------------------------------
Logical device information
----------------------------------------------------------------------
Logical Device number 0
Logical Device name : LARGE
Block Size of member drives : 512 Bytes
RAID level : 6
Unique Identifier : 7BDC56B5
Status of Logical Device : Suboptimal, Fault Tolerant
Additional details : Initialized with Build/Clear
Size : 22886390 MB
Parity space : 7628800 MB
Stripe-unit size : 256 KB
Interface Type : SAS/SATA
Device Type : HDD
Read-cache setting : Enabled
Read-cache status : On
Write-cache setting : Enabled
Write-cache status : On
Partitioned : No
Protected by Hot-Spare : Yes
Dedicated Hot-Spare : 0,53
Dedicated Hot-Spare : 0,60
Bootable : Yes
Failed stripes : No
Power settings : Enabled
Slow down after(Minutes) : 5m
Power off after(Minutes) : 10m
Verify after(Hours) : never
Power State : Active
--------------------------------------------------------
Logical Device segment information
--------------------------------------------------------
Segment 0 : Present (3815447MB, SATA, HDD, Connector:5, Device:0) WD-WCC4E7LPEUXP
Segment 1 : Present (3815447MB, SATA, HDD, Connector:5, Device:1) WD-WCC4E7LPE6Y2
Segment 2 : Present (3815447MB, SATA, HDD, Connector:5, Device:2) WD-WCC4E7LPEYK2
Segment 3 : Present (3815447MB, SATA, HDD, Connector:5, Device:3) WD-WCC4E7SY303R
Segment 4 : Missing
Segment 5 : Present (3815447MB, SAS, HDD, Enclosure:1, Slot:0) Z1Z0L27F
Segment 6 : Present (3815447MB, SAS, HDD, Enclosure:1, Slot:0) Z1Z0PZPG
Segment 7 : Present (3815447MB, SAS, HDD, Enclosure:1, Slot:0) Z1Z0SVKH
....
Code:


So, as you can see, the adapter does not start rebuilding the raid 6 array, even though 2 dedicated hot spares are present.
Both hot spares have been uninitialized & initialized again before adding them as a dedicated HSP drive to logicaldrive 0.
also tried sd_reset --host /dev/sda & cold rebooting the device.
Any idea what might cause this?

If neccessary, I can rebuild the array, but removing this amount of data and putting it back onto the drive ... don't know, I'd prefer a more elegant solution.

_________________
I am using gentoo for over 10 years now. yet seen its possibilities, I still feel like a n00b...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8539
Location: ~Brussels - Belgique

PostPosted: Sat Jun 13, 2020 7:30 am    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum