Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
protage 2.33.99 / 2.33.100 update failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Thu Jun 11, 2020 2:04 pm    Post subject: protage 2.33.99 / 2.33.100 update failing Reply with quote

Hi there,

I am trying to revive my gentoo, but i already fail at updating portage from 2.3.76 with slot conflicts and unclear unmasking, keywording, use-flag-demands.
Code:
# emerge --ask --verbose --oneshot sys-apps/portage --verbose-conflicts
essentially results in
Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-portage/gemato-14.3::gentoo
# required by sys-apps/portage-2.3.99-r2::gentoo[rsync-verify,-build]
# required by @selected
# required by @world (argument)
=dev-python/setuptools-46.4.0-r1 ~amd64

Putting dev-python/setuptools in /etc/portage/package.keywords/setuptools (without versioning) demands
Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sys-devel/crossdev-20190712::gentoo
# required by @selected
# required by @world (argument)
=sys-apps/portage-2.3.100-r1 ~amd64

Putting sys-apps/portage in /etc/portage/package.keywords/portage (without versioning) demands
Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sys-devel/crossdev-20190712::gentoo
# required by @selected
# required by @world (argument)
=sys-apps/portage-9999 **

Adding the entry =sys-apps/portage-9999 ** to /etc/portage/package.keywords/portage demands
Code:
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by app-portage/gemato-14.3::gentoo
# required by sys-apps/portage-9999::gentoo[-build,rsync-verify]
# required by sys-apps/portage (argument)
# /usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (2020-01-16)
# The new version loses Python 2 support but does not introduce any real
# changes.  Let's mask it to reduce the noise, and hopefully try to get
# python2_7 out of default PYTHON_TARGETS first.
=dev-python/setuptools-47.1.1

As PYTHON_TARGETS is empty
Code:
# echo $PYTHON_TARGETS


i umasked setuptools-47.1.1, next demand:
Code:
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/setuptools-47.1.1::gentoo
# required by app-portage/gemato-14.3::gentoo
# required by sys-apps/portage-9999::gentoo[-build,rsync-verify]
# required by sys-apps/portage (argument)
>=dev-python/certifi-2020.4.5.1 -python_targets_python2_7

Added >=dev-python/certifi-2020.4.5.1 -python_targets_python2_7 to /etc/portage/package.use/certifi
And ended up in no further demands but slot conflicts i don't get:
Code:
These are the packages that would be merged, in order:

Calculating dependencies                           ... done!         
[ebuild  N     ] app-arch/zstd-1.4.4-r4:0/1::gentoo  USE="threads -lz4 -static-libs" ABI_X86="(64) -32 (-x32)" 1,917 KiB
[ebuild  N     ] virtual/libcrypt-1-r1:0/1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  NS    ] dev-lang/python-3.7.7-r2:3.7/3.7m::gentoo [2.7.16:2.7::gentoo, 3.6.9:3.6/3.6m::gentoo] USE="gdbm ncurses readline sqlite ssl xml -bluetooth -build -examples -hardened -ipv6 -libressl -test -tk -wininst (-threads%*)" 16,879 KiB
[ebuild     U #] dev-python/setuptools-47.1.1::gentoo [40.6.3::gentoo] USE="-test" PYTHON_TARGETS="python3_7* -pypy3 -python3_6* -python3_8% -python3_9% (-pypy%) (-python2_7%*) (-python3_5%)" 850 KiB
[ebuild     U  ] dev-python/certifi-2020.4.5.1::gentoo [2019.6.16::gentoo] PYTHON_TARGETS="python3_7* (-pypy3) -python2_7* -python3_6* (-python3_8) (-python3_9) (-pypy%) (-python3_5%)" 155 KiB
[ebuild     U  ] app-portage/gemato-14.3::gentoo [14.1::gentoo] USE="gpg -test -tools (-blake2%*) (-bzip2%*) (-lzma%) (-sha3%)" PYTHON_TARGETS="python3_7* (-pypy3) -python3_6* (-python3_8) (-pypy%) (-python2_7%*) (-python3_5%)" 70 KiB
[ebuild     U *] sys-apps/portage-9999::gentoo [2.3.76::gentoo] USE="(ipc) native-extensions rsync-verify xattr -apidoc% -build -doc -gentoo-dev (-selinux) (-epydoc%)" PYTHON_TARGETS="python3_7* -pypy3% -python3_6* -python3_8% -python3_9% (-pypy%) (-python2_7%*) (-python3_5%)" 0 KiB

Total: 7 packages (4 upgrades, 2 new, 1 in new slot), Size of downloads: 19,869 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.3.76:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-portage/layman-2.4.2-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                     
    >=sys-apps/portage-2.3.62[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/elicense-1.0.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                   
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed)
                                                                                                                                                                                                                                                                                                         
    sys-apps/portage[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gentoolkit-0.4.6:0/0::gentoo, installed)
                                                                                                                                                                                                                                       

app-portage/gemato:0

  (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-portage/gemato-14[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (sys-apps/portage-9999:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (app-portage/gemato-14.1:0/0::gentoo, installed) pulled in by
    >=app-portage/gemato-14[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (sys-apps/portage-2.3.76:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                           

dev-python/setuptools:0

  (dev-python/setuptools-47.1.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (app-portage/gemato-14.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-python/setuptools-40.6.3:0/0::gentoo, installed) pulled in by
    >=dev-python/setuptools-39.2.0[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pip-19.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gemato-14.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pygments-2.3.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/cryptography-2.6.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/Babel-2.6.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python3_6(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-util/meson-0.51.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pytz-2018.9:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/certifi-2019.6.16:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                             
    >=dev-python/setuptools-34[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gemato-14.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (media-gfx/scour-0.36:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                     
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/jinja-2.10.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/namespace-sphinxcontrib-1.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyxattr-0.6.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/chardet-3.0.4:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

dev-python/certifi:0

  (dev-python/certifi-2020.4.5.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-47.1.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-python/certifi-2019.6.16:0/0::gentoo, installed) pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/setuptools-40.6.3:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/certifi-2017.4.17[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/requests-2.21.0-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/certifi[python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,python_targets_python3_8(-)?,-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/urllib3-1.24.2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


So this didn't get me anywhere and i don't get this slot conflict. I reverted all the changes and started writing this question. Can someone point me in the right direction?
I understood that python2.7 is finally dropped from more and more packages, but i don't see what i have to do to successfully update the system with that in mind.

My current emerge info:
Code:
Portage 2.3.76 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop, gcc-8.3.0, glibc-2.29-r2, 4.19.72-gentoo x86_64)
=================================================================
System uname: Linux-4.19.72-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770_CPU_@_3.40GHz-with-gentoo-2.6
KiB Mem:    16347488 total,   9280244 free
KiB Swap:   16383996 total,  15818516 free
Timestamp of repository gentoo: Thu, 11 Jun 2020 12:35:18 +0000
Head commit of repository gentoo: 02bffcef91fc2995a3401a5ad0c633fb272cdad7

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

crossdev
    location: /usr/local/portage-crossdev
    masters: gentoo
    priority: 10

awesome
    location: /var/lib/layman/awesome
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core-avx2 -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core-avx2 -O3 -pipe -finline-functions"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j8"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gentoo.mirror.web4u.cz/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avahi berkdb branding bzip2 cairo cdda cdr cjk cli consolekit crypt cups dbus dri dts dvd dvdr elogind emboss encode exif fbcon ffmpeg fftw flac fortran ftp gdbm gif git gnutls gphoto2 gpm gtk iconv icu inotify ios ipod jpeg jpeg2k latex lcms ldap libtirpc mad matroska mmx mng mp3 mp4 mpd mpeg mtp ncurses nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf pm-utils png policykit ppds qt5 raw readline sdl seccomp smp spell split-usr sse sse2 sse3 sse4_1 ssl ssse3 startup-notification subversion svg syslog tcpd threads thunar tiff truetype udev udisks unicode upower usb vcd vdpau videos vorbis wxwidgets x264 xattr xcb xft xml xv xvid zeroconf zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


My make.conf:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.

CFLAGS="-march=core-avx2 -O3 -pipe"
CXXFLAGS="${CFLAGS} -finline-functions"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

MAKEOPTS="-j9"

# gentoo mirrors; lookup is performed from left to right through the list
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gentoo.mirror.web4u.cz/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"

# european sync-server (is this important?)
#SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X -gnome -kde a52 aac acpi avahi alsa -bindist -bluetooth cdr cjk consolekit cups dbus -doc dvd dvdr fbcon ffmpeg fftw ftp -geolocation gif git gtk gnutls gphoto2 -hal icu inotify ios ipod -ipv6 jpeg jpeg2k latex ldap -libnotify -llvm matroska mmx mp3 mp4 mpeg mpd mtp -multilib nvidia ogg openal opengl pam pdf -plasma pm-utils png policykit -python -qt4 raw -rupy smp sse sse2 sse3 ssse3 sse4_1 ssl -static -static-libs svg subversion syslog -systemd threads thunar tiff truetype udev unicode usb vcd vdpau videos vorbis -wifi x264 xft -xosd xvid zeroconf"

CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

INPUT_DEVICES="evdev"
VIDEO_CARDS="nvidia"
ALSA_CARDS="hda-intel"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

FEATURES="candy"

EMERGE_DEFAULT_OPTS="-j8"

# languages for libreoffice and co.
LINGUAS="en de"
L10N="en en-US de"

# necessary entry for cross compiling avr shit
PORTDIR_OVERLAY="/usr/local/portage"

GRUB_PLATFORMS="efi-64"

#PYTHON_TARGETS="python2_7 python3_6"
#PYTHON_SINGLE_TARGET="python3_6"
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1169
Location: Italy

PostPosted: Thu Jun 11, 2020 3:25 pm    Post subject: Reply with quote

What's the content of files under the /etc/portage/package.accept_keywords and /etc/portage/package.keywords directories?
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2264
Location: Frankfurt, Germany

PostPosted: Thu Jun 11, 2020 4:17 pm    Post subject: Reply with quote

Off-topic: don't use "-O3" as a general optimization level in make.conf:
Code:
CFLAGS="-march=core-avx2 -O3 -pipe"

https://wiki.gentoo.org/wiki/GCC_optimization says:
Quote:
-O3: the highest level of optimization possible. It enables optimizations that are expensive in terms of compile time and memory usage. Compiling with -O3 is not a guaranteed way to improve performance, and in fact, in many cases, can slow down a system due to larger binaries and increased memory usage. -O3 is also known to break several packages. Using -O3 is not recommended. However, it also enables -ftree-vectorize so that loops in the code get vectorized and will use AVX YMM registers.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Sat Jun 13, 2020 7:23 pm    Post subject: Reply with quote

accept_keywords does not exist, only files in package.keywords dir:
Code:
$ cat /etc/portage/package.keywords/*
www-plugins/adobe-flash
sys-libs/binutils-libs
media-video/bluray_info
dev-libs/botan
dev-tex/cjk-latex
cross-avr/binutils * ~* -amd64 -~amd64
cross-avr/gcc * ~* -amd64 -~amd64
cross-avr/avr-libc * ~* -amd64 -~amd64
cross-avr/gdb * ~* -amd64 -~amd64
dev-python/cycler
media-gfx/inkscape
media-libs/jpeg:8
dev-python/jupyter_core
dev-python/jupyter_client
dev-python/entrypoints
dev-libs/mathjax
dev-python/ipyparallel
dev-python/widgetsnbextension
dev-python/jupyter
dev-python/qtconsole
dev-python/jupyter_console
dev-python/ipykernel
dev-python/notebook
dev-python/nbformat
dev-python/nbconvert
dev-python/ipywidgets
dev-python/ipython
dev-python/mistune
dev-python/testpath
dev-python/pandocfilters
dev-python/backcall
dev-python/prompt_toolkit
=dev-python/kiwisolver-1.0.1
gnome-extra/libgda
dev-python/m2crypto
media-video/makemkv
sci-misc/mendeleydesktop
net-misc/nextcloud-client
dev-util/nvidia-cuda-toolkit

=dev-libs/openssl-1.1.0j-r1
app-misc/prog-express
dev-python/pyzmq
media-libs/qhull
games-fps/quake3-data
games-fps/quake3
games-fps/quake3-defrag
games-fps/quake3-osp
sys-apps/razercfg
net-im/skypeforlinux
dev-python/subprocess32
media-sound/teamspeak-client
net-misc/teamviewer
dev-python/terminado
dev-python/versioneer


Think i should start versioning them, as up to now i don't know any way of throughing out keyword-accepted packages i only accepted to get a successful system update.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Tue Jun 16, 2020 6:58 pm    Post subject: Reply with quote

No one? :?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3857
Location: Illinois, USA

PostPosted: Tue Jun 16, 2020 7:18 pm    Post subject: Reply with quote

Too big a leap.

Try:
Code:
emerge --ask --verbose --oneshot =sys-apps/portage-2.3.99-r2 --verbose-conflicts

That shouldn't ask for mask changes because it is latest stable and should only have stable dependencies.

You are obviously updating an old install. You might have to install an old snapshot and re-build in stages.
If you follow the forum, you have seen NeddySeagoon guide many people through this process.
I think there is a wiki page called "Updating an old install" or something like that.

How old is your gcc? Might be prident to update your toolchain first. Then there are the horrible perl and python updates. If you rn kde as it seems a plurality do, it has it's own set of qt nightmares, but gtk2 to gtk3 was not without problems also.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3857
Location: Illinois, USA

PostPosted: Tue Jun 16, 2020 7:19 pm    Post subject: Reply with quote

DZoom wrote:
accept_keywords does not exist, only files in package.keywords dir:


The name changed many years ago.
I didn't like it either.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Sat Jun 27, 2020 6:31 pm    Post subject: Reply with quote

Tony0945 wrote:
Too big a leap.

Try:
Code:
emerge --ask --verbose --oneshot =sys-apps/portage-2.3.99-r2 --verbose-conflicts

That shouldn't ask for mask changes because it is latest stable and should only have stable dependencies.

No it doesn't, i.e., there's still slot conflicts.


You are obviously updating an old install. You might have to install an old snapshot and re-build in stages.
If you follow the forum, you have seen NeddySeagoon guide many people through this process.
I think there is a wiki page called "Updating an old install" or something like that.

Tony0945 wrote:

How old is your gcc? Might be prident to update your toolchain first. Then there are the horrible perl and python updates. If you rn kde as it seems a plurality do, it has it's own set of qt nightmares, but gtk2 to gtk3 was not without problems also.


GCC is 8.3.0-r1. I remember the gtk2 to gtk3 transition, it was a hassle. Anyway i think i found the sources for upgrading old systems [1,2]. Thanks for the hint!

[1] https://wiki.gentoo.org/wiki/Upgrading_Gentoo#Upgrading_from_.28too.29_old_systems
[2] https://wiki.gentoo.org/wiki/Upgrading_Gentoo#Updating_old_systems
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3857
Location: Illinois, USA

PostPosted: Sat Jun 27, 2020 11:09 pm    Post subject: Reply with quote

DZoom wrote:
Anyway i think i found the sources for upgrading old systems [1,2]. Thanks for the hint!

[1] https://wiki.gentoo.org/wiki/Upgrading_Gentoo#Upgrading_from_.28too.29_old_systems
[2] https://wiki.gentoo.org/wiki/Upgrading_Gentoo#Updating_old_systems

Keep in touch and let us know your progress!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum