Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't load installed plugin in xfce4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
amxyz
n00b
n00b


Joined: 13 May 2020
Posts: 17

PostPosted: Sat May 23, 2020 2:36 pm    Post subject: Can't load installed plugin in xfce4 Reply with quote

Hi,

I'm using a RPI4 and I installed some plugins which I downloaded from https://docs.xfce.org/xfce/xfce4-panel/start. The plugins were compiled correctly and placed in
Code:
/usr/lib/xfce4/panel/plugins


these are the libs of the plugins:
Code:
libpulseaudio-plugin.la  libpulseaudio-plugin.so  libweather.la  libweather.so


The .desktop-files were placed in this folder:
Code:
/usr/share/xfce4/panel/plugins


The file weather.desktop looks like this:

Code:
[Xfce Panel]
Type=X-XFCE-PanelPlugin
Name=Weather Update
Icon=xfce4-weather
X-XFCE-Internal=FALSE
X-XFCE-Module=weather
X-XFCE-API=2.0
X-XFCE-Exec=/usr/lib/xfce4/panel/plugins/



The file pulseaudio.desktop looks like this:

Code:
[Xfce Panel]
Type=X-XFCE-PanelPlugin
Encoding=UTF-8
Name=PulseAudio Plugin
Icon=xfce4-pulseaudio-plugin
X-XFCE-Module=pulseaudio-plugin
X-XFCE-Internal=FALSE
X-XFCE-API=2.0
X-XFCE-Exec=/usr/lib/xfce4/panel/plugins/


When I rightclick on panel > Panel > Add new items neither the weather plugin nor the pulseaudio plugin appear there. How do I tell xfce4 that I have installed some plugins so that I can add them on the panel?

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
amxyz
n00b
n00b


Joined: 13 May 2020
Posts: 17

PostPosted: Mon May 25, 2020 9:04 pm    Post subject: <solved> Can't load installed plugin in xfce4 Reply with quote

I just figured it out by myself. The external plugins are now loaded by the panel.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15833

PostPosted: Tue May 26, 2020 12:58 am    Post subject: Reply with quote

What was the cause of the error, and how did you fix it? Someone else may one day find this thread and benefit from your solution.
Back to top
View user's profile Send private message
amxyz
n00b
n00b


Joined: 13 May 2020
Posts: 17

PostPosted: Mon Jun 01, 2020 11:02 pm    Post subject: Reply with quote

I found out that the libraries of the plugins are installed in:

Quote:
/usr/lib/xfce4/panel/plugins/


Since I'm running gentoo on a 64 bit system I moved the libraries into the folder:

Quote:
/usr/lib64/xfce4/panel/plugins/


I also had to edit one *.desktop-file so it looks like this now:

Quote:
[Xfce Panel]
Type=X-XFCE-PanelPlugin
Name=Weather Update
Icon=xfce4-weather
X-XFCE-Internal=FALSE
X-XFCE-Module=weather
X-XFCE-API=2.0


API= 2.0 means that it is for gtk3 whereas API=1.0 is only for gtk2.

And then I restarted the panel by entering:

Code:
> xfce4-panel -r


Then I was finally able to load the plugins.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum