Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Màj]Conflit avec sys-libs/readline et app-shells/bash[réso]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 9:07 am    Post subject: [Màj]Conflit avec sys-libs/readline et app-shells/bash[réso] Reply with quote

Bonjour,

En voulant faire une màj, je rencontre actuellement un conflit :

Quote:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/readline-8.0_p4:0/8::gentoo [7.0_p5-r1:0/7::gentoo] USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" 2912 KiB
[ebuild U ] app-shells/bash-5.0_p17::gentoo [4.4_p23-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" 9948 KiB

Total: 2 packages (2 upgrades), Size of downloads: 12860 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

(sys-libs/readline-7.0_p5-r1:0/7::gentoo, installed) USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" pulled in by
>=sys-libs/readline-4.1:0/7= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed) USE="readline -libedit -static" ABI_X86="(64)"
^^^^^
(and 41 more with the same problem)

(sys-libs/readline-8.0_p4:0/8::gentoo, ebuild scheduled for merge) USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" pulled in by
>=sys-libs/readline-8.0:0= required by (app-shells/bash-5.0_p17:0/0::gentoo, ebuild scheduled for merge) USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" ABI_X86="(64)"
^^ ^^^^^^


Quote:

Portage 2.3.99 (python 3.6.10-final-0, default/linux/amd64/17.0/systemd, gcc-9.3.0, glibc-2.30-r8, 5.6.7-gentoo x86_64)
=================================================================
System uname: Linux-5.6.7-gentoo-x86_64-Intel-R-_Core-TM-_i5-7200U_CPU_@_2.50GHz-with-gentoo-2.6
KiB Mem: 8021736 total, 3631248 free
KiB Swap: 8388604 total, 8388604 free
Timestamp of repository gentoo: Tue, 05 May 2020 08:00:01 +0000
Head commit of repository gentoo: 2c01bfa6b141cbdbc366ee2851e0c2084d222a93
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
app-shells/bash: 4.4_p23-r1::gentoo
dev-java/java-config: 2.2.0-r4::gentoo
dev-lang/perl: 5.30.1::gentoo
dev-lang/python: 2.7.18::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.2-r2::gentoo
dev-util/cmake: 3.16.5::gentoo
dev-util/pkgconfig: 0.29.2::gentoo
sys-apps/baselayout: 2.6-r1::gentoo
sys-apps/openrc: 0.42.1::gentoo
sys-apps/sandbox: 2.13::gentoo
sys-devel/autoconf: 2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake: 1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils: 2.33.1-r1::gentoo
sys-devel/gcc: 9.3.0::gentoo
sys-devel/gcc-config: 2.2.1::gentoo
sys-devel/libtool: 2.4.6-r6::gentoo
sys-devel/make: 4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc: 2.30-r8::gentoo
Repositories:
gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.gentoo.org/gentoo-portage
priority: -1000
sync-rsync-verify-jobs: 1
sync-rsync-verify-metamanifest: yes
sync-rsync-verify-max-age: 24
sync-rsync-extra-opts:

mozilla
location: /var/lib/layman/mozilla
masters: gentoo
priority: 50

pentoo
location: /var/lib/layman/pentoo
masters: gentoo
priority: 50

local
location: /usr/local/portage
masters: gentoo
priority: 99999

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@EULA @FREE unRAR android free-noncomm"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fforce-addr -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/davmail-4.8.0/conf /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -fforce-addr -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=4.0 --keep-going=y --with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-
features-warn unmerge-logs unmerge-orphans unprivileged userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl amd64 berkdb bzip2 cli crypt cryptsetup dri ffmpeg fortran gdbm gnutls iconv ipv6 jpg libtirpc logrotate mmx modplug multilib ncurses nls nptl openmp pam pcre perl png pulseaudio python readline seccomp secure_delete split-usr sse sse2 ssl systemd tcpd udev unicode wavpack webrsync-gpg xattr xml zlib" ABI_X
86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn
_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite
setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="load memory syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom o
ceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" O
FFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" QEMU_SOFTMMU_TARGETS="alpha arm i386 mips mips64 mips64el mipsel ppc ppc64 s390x sh4 sh4eb sparc sparc64 x86_64" QEMU_USER_TARGETS="alpha arm
armeb i386 mips mipsel ppc ppc64 ppc64abi32 s390x sh4 sh4eb sparc sparc32plus sparc64 x86_64" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude cha
os account"
Unset: CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Last edited by y351 on Tue May 05, 2020 4:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1718
Location: 127.0.0.1

PostPosted: Tue May 05, 2020 10:48 am    Post subject: Reply with quote

Salut,

Quelle commande utilises-tu pour effectuer ta MAJ ?
Back to top
View user's profile Send private message
sdauth
Apprentice
Apprentice


Joined: 19 Sep 2018
Posts: 190
Location: Ásgarðr

PostPosted: Tue May 05, 2020 10:58 am    Post subject: Reply with quote

netfab wrote:
Salut,

Quelle commande utilises-tu pour effectuer ta MAJ ?


+1, par ailleurs, la màj récente de readline a entrainé un paquet de rebuild.

Un petit : emerge -DavquN --with-bdeps=y @world

devrait régler le soucis. :wink:
Back to top
View user's profile Send private message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 12:28 pm    Post subject: Reply with quote

netfab wrote:

Quelle commande utilises-tu pour effectuer ta MAJ ?

Code:
emerge -uDNav @world


sdauth wrote:

Un petit : emerge -DavquN --with-bdeps=y @world


Même résultat.
Quote:

[ebuild U ] sys-libs/readline-8.0_p4 [7.0_p5-r1] USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)"
[ebuild U ] app-shells/bash-5.0_p17 [4.4_p23-r1] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

(sys-libs/readline-7.0_p5-r1:0/7::gentoo, installed) USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" pulled in by
>=sys-libs/readline-4.1:0/7= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed) USE="readline -libedit -static" ABI_X86="(64)"
^^^^^
(and 41 more with the same problem)

(sys-libs/readline-8.0_p4:0/8::gentoo, ebuild scheduled for merge) USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" pulled in by
>=sys-libs/readline-8.0:0= required by (app-shells/bash-5.0_p17:0/0::gentoo, ebuild scheduled for merge) USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" ABI_X86="(64)"
^^ ^^^^^^


NOTE: Use the '--verbose-conflicts' option to display parents omitted above
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1718
Location: 127.0.0.1

PostPosted: Tue May 05, 2020 2:05 pm    Post subject: Reply with quote

Peux-tu coller ici (entre balises code) la sortie de la commande suivante :
Code:

 # emerge -avuDN --backtrack=100 --verbose-conflicts --ignore-built-slot-operator-deps=y @world
Back to top
View user's profile Send private message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 2:12 pm    Post subject: Reply with quote

Code:
emerge -avuDN --backtrack=100 --verbose-conflicts --ignore-built-slot-operator-deps=y @world

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/readline-8.0_p4:0/8::gentoo [7.0_p5-r1:0/7::gentoo] USE="(split-usr) unicode -static-libs -utils" ABI_X86="(64) -32 (-x32)" 2912 KiB
[ebuild     U  ] app-shells/bash-5.0_p17::gentoo [4.4_p23-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins" 9948 KiB

Total: 2 packages (2 upgrades), Size of downloads: 12860 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/pygments:0

  (dev-python/pygments-2.6.1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 python3_7 (-pypy3) (-python3_8)" conflicts with
    dev-python/pygments[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (dev-python/docutils-0.16:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 (-pypy3) (-python3_8)"
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1718
Location: 127.0.0.1

PostPosted: Tue May 05, 2020 2:16 pm    Post subject: Reply with quote

Et emerge te demande confirmation pour valider la commande ?
Back to top
View user's profile Send private message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 2:16 pm    Post subject: Reply with quote

Ça a contourné le conflit.
Cela nécesste :
Code:
emerge @preserved-rebuild
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1718
Location: 127.0.0.1

PostPosted: Tue May 05, 2020 2:18 pm    Post subject: Reply with quote

Oui.
Back to top
View user's profile Send private message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 2:18 pm    Post subject: Reply with quote

Cela mérite une petite explication. :-)
Back to top
View user's profile Send private message
y351
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2017
Posts: 103

PostPosted: Tue May 05, 2020 2:20 pm    Post subject: Reply with quote

Cela a entrainé la re-compilation des packages suivantes :
Code:


Calculating dependencies... done!
[ebuild   R    ] sys-apps/usermode-utilities-20070815-r3::gentoo  USE="-fuse" 49 KiB
[ebuild   R    ] dev-db/unixODBC-2.3.7::gentoo  USE="minimal unicode -odbcmanual -static-libs" ABI_X86="(64) -32 (-x32)" 1631 KiB
[ebuild   R    ] sys-devel/bc-1.06.95-r2::gentoo  USE="readline -libedit -static" 284 KiB
[ebuild   R    ] net-ftp/ftp-0.17.23.0.2.1::gentoo  USE="ipv6 readline ssl -libressl" 104 KiB
[ebuild   R    ] sys-apps/gawk-4.2.1-r1::gentoo  USE="nls readline -mpfr" 2916 KiB
[ebuild   R    ] dev-libs/libpcre2-10.34::gentoo  USE="bzip2 jit pcre16 readline recursion-limit (split-usr) unicode zlib -libedit -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] dev-libs/libpcre-8.43:3::gentoo  USE="bzip2 cxx jit pcre16 readline recursion-limit (split-usr) static-libs (unicode) zlib -libedit -pcre32" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] media-sound/jack-audio-connection-kit-0.125.0::gentoo  USE="pam -alsa (-altivec) (-coreaudio) -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse -3dnow" 1190 KiB
[ebuild   R    ] net-ftp/tftp-hpa-5.2-r1::gentoo  USE="ipv6 readline tcpd (-selinux)" 88 KiB
[ebuild   R    ] sys-libs/slang-2.3.2::gentoo  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)" 1550 KiB
[ebuild   R    ] app-crypt/gnupg-2.2.19::gentoo  USE="bzip2 nls readline smartcard ssl -doc -ldap (-selinux) -tofu -tools -usb -user-socket -wks-server" 6597 KiB
[ebuild   R    ] net-ftp/gftp-2.0.19-r3::gentoo  USE="gtk ssl -libressl" 1648 KiB
[ebuild   R    ] sys-libs/gdbm-1.13-r2:0/1.13::gentoo  USE="berkdb nls readline -exporter -static-libs" ABI_X86="(64) -32 (-x32)" 872 KiB
[ebuild   R    ] dev-db/sqlite-3.31.1:3::gentoo  USE="readline -debug -doc -icu -secure-delete -static-libs -tcl -test -tools" ABI_X86="(64) -32 (-x32)" 2820 KiB
[ebuild   R    ] net-wireless/bluez-5.54:0/3::gentoo  USE="mesh obex readline systemd udev -btpclient -cups -debug -deprecated -doc -experimental -extra-tools -midi (-selinux) -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_6 -python3_7 (-python3_8)" 1957 KiB
[ebuild   R    ] dev-scheme/guile-2.2.4:12/2.2-1::gentoo  USE="deprecated networking nls regex threads -debug -debug-malloc" 17671 KiB
[ebuild   R    ] app-text/hunspell-1.7.0-r1:0/1.7::gentoo  USE="ncurses nls readline -static-libs" L10N="-af -bg -ca -cs -cy -da -de -de-1901 -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -is -it -kk -km -ku -lt -lv -mi -mk -ms -nb -nl -nn -pl -pt -pt-BR -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu" 471 KiB
[ebuild   R    ] dev-lang/lua-5.1.5-r4::gentoo  USE="deprecated readline -emacs -static" ABI_X86="(64) -32 (-x32)" 217 KiB
[ebuild   R    ] net-ftp/lftp-4.8.4-r1::gentoo  USE="gnutls ipv6 nls socks5 ssl -convert-mozilla-cookies -idn -libressl -verify-file" 1596 KiB
[ebuild   R    ] net-misc/socat-1.7.3.2::gentoo  USE="ipv6 readline ssl tcpd -bindist -libressl" 482 KiB
[ebuild   R    ] sys-block/parted-3.2-r1::gentoo  USE="debug nls readline -device-mapper (-selinux) -static-libs" 1617 KiB
[ebuild   R    ] dev-lang/python-2.7.18:2.7::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -bluetooth -build -examples -hardened -libressl -tk -wininst" 0 KiB
[ebuild   R    ] dev-lang/spidermonkey-60.5.2_p0-r4:60::gentoo  USE="jit system-icu -custom-cflags -custom-optimization -debug -minimal -test" 0 KiB
[ebuild   R    ] dev-lang/ruby-2.4.10:2.4::gentoo  USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -static-libs -tk -xemacs" 9864 KiB
[ebuild   R    ] dev-lang/ruby-2.5.8:2.5::gentoo  USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -static-libs -tk -xemacs" 11034 KiB
[ebuild   R    ] sys-fs/lvm2-2.02.187-r2::gentoo  USE="readline systemd thin udev -device-mapper-only -lvm2create_initrd -sanlock (-selinux) (-static) (-static-libs)" 0 KiB
[ebuild   R    ] sys-fs/multipath-tools-0.8.3-r2::gentoo  USE="systemd -rbd" 0 KiB
[ebuild   R    ] app-admin/keepassxc-2.5.3::gentoo  USE="network -autotype -browser -ccache -debug -keeshare -test -yubikey" 6679 KiB
[ebuild   R    ] net-wireless/wpa_supplicant-2.9-r2::gentoo  USE="dbus fils hs2-0 mbo mesh readline -ap -bindist -broadcom-sta -eap-sim -eapol-test -fasteap -libressl -macsec -p2p -privsep (-ps3) -qt5 (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps" 3157 KiB
[ebuild   R    ] net-misc/connman-1.38::gentoo  USE="bluetooth debug doc ethernet examples iptables openconnect tools vpnc wifi -iwd -l2tp -networkmanager -nftables -ofono -openvpn -policykit -pptp -wireguard -wispr" 0 KiB
[ebuild   R    ] dev-lang/python-3.6.10-r2:3.6/3.6m::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) tk xml -bluetooth -build -examples -hardened -libressl -test -wininst" 0 KiB
[ebuild   R    ] net-mail/mailutils-3.8::gentoo  USE="berkdb clients gdbm ipv6 nls pam python (split-usr) ssl tcpd threads -bidi -emacs -guile -kerberos -kyotocabinet -ldap -mysql -postgres -sasl -servers -static-libs -tokyocabinet" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_7" 2929 KiB
[ebuild   R    ] app-office/abiword-3.0.4:2::gentoo  USE="goffice introspection plugins readline -calendar -collab -cups -debug -eds -grammar -latex -map -math -ots -redland -spell -thesaurus -wmf -wordperfect" 10814 KiB
[ebuild   R    ] net-fs/samba-4.11.6-r2::gentoo  USE="acl pam python system-mitkrb5 systemd -addc -addns -ads -ceph -client -cluster -cups -debug (-dmapi) (-fam) -gpg -iprint -json -ldap -profiling-data -quota (-selinux) -syslog (-system-heimdal) (-test) -winbind -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARG
ET="python3_6 -python3_7 (-python3_8)" 18107 KiB
[ebuild   R    ] sys-apps/util-linux-2.33.2::gentoo  USE="caps cramfs ncurses nls pam python readline (split-usr) suid systemd udev unicode -build -fdformat -kill (-selinux) -slang -static-libs -test -tty-helpers" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_6 python3_7" 0 KiB
[ebuild   R    ] dev-lang/python-3.7.7-r2:3.7/3.7m::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl tk xml -bluetooth -build -examples -hardened -libressl -test -wininst" 0 KiB
[ebuild   R    ] dev-libs/libxml2-2.9.9-r3:2::gentoo  USE="icu ipv6 python readline -debug -examples -lzma -static-libs -test" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 python3_7 (-python3_8)" 0 KiB
[ebuild   R    ] dev-lang/python-3.8.2-r2:3.8::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl tk xml -bluetooth -build -examples -hardened -libressl -test -wininst" 16 KiB
[ebuild   R    ] app-emulation/libvirt-6.0.0-r3:0/6.0.0::gentoo  USE="caps dbus libvirtd macvtap nls qemu udev vepa virt-network -apparmor -audit -dtrace -firewalld -fuse -glusterfs -iscsi -iscsi-direct -libssh -lvm -lxc -nfs -numa (-openvz) -parted -pcap -phyp -policykit -rbd -sasl (-selinux) -virtualbox -wireshark-p
lugins -xen -zfs" 8483 KiB
[ebuild   R    ] dev-db/postgresql-12.2:12::gentoo  USE="nls pam perl python readline server ssl systemd xml zlib -debug -doc -icu -kerberos -ldap -libressl -llvm (-selinux) -static-libs -tcl -threads -uuid" PYTHON_SINGLE_TARGET="python3_6 -python3_7" 19887 KiB
[ebuild   R    ] dev-lang/php-7.4.5:7.4::gentoo  USE="acl berkdb bzip2 cli ctype curl fileinfo filter flatfile gdbm iconv ipv6 json ldap nls opcache phar posix readline session simplexml ssl systemd tokenizer unicode xml xmlwriter zlib -apache2 -argon2 -bcmath -calendar -cdb -cgi -cjk (-coverage) -debug -embed -enchan
t -exif -ffi (-firebird) -fpm -ftp -gd -gmp -imap -inifile -intl -iodbc -kerberos -ldap-sasl -libedit -libressl -lmdb -mhash -mssql -mysql -mysqli -oci8-instant-client -odbc -pcntl -pdo -phpdbg -postgres -qdbm (-selinux) -session-mm -sharedmem -snmp -soap -sockets -sodium -spell -sqlite -sysvipc -test -threads -tidy -
tokyocabinet -truetype -webp -xmlreader -xmlrpc -xpm -xslt -zip" 0 KiB
[ebuild   R    ] media-gfx/fontforge-20200314::gentoo  USE="X png python readline unicode -doc -gif -gtk -jpeg -svg -test -tiff -truetype-debugger -woff2" PYTHON_SINGLE_TARGET="python3_6 -python3_7 (-python3_8)" 0 KiB
[ebuild   R    ] net-dns/bind-tools-9.14.8::gentoo  USE="caps ipv6 readline xml -doc -gssapi -idn -libedit -libressl" 6254 KiB

Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1718
Location: 127.0.0.1

PostPosted: Tue May 05, 2020 3:02 pm    Post subject: Reply with quote

y351 wrote:
Cela mérite une petite explication. :-)

N'ayant pas le système sous la main cela sera pour moi difficile, d'autant que tu as déjà effectué une partie des MAJ et que le problème a déjà probablement été résolu.
Il aurait peut-être fallu, avant d'effectuer la MAJ, afficher les conflits avec --verbose-conflicts mais sans utliser --ignore-built-slot-operator-deps=y.
AMHA le conflit qui bloquait le processus n'était simplement pas ce que emerge t'affichait avec readline et ses built slot operator deps : https://bugs.gentoo.org/598503
Mais tout ceci dépend exclusivement de la spécificité de ton système et des paquets qui y sont installés.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum