Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Aggiornamento sistema
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 10:13 am    Post subject: [RISOLTO] Aggiornamento sistema Reply with quote

Buongiorno a tutti,
dopo aver fatto il webrsync, leggendo "eselect news read" ho fatto come dicono di fare relativamente a python, ovvero ho messo nel mio file package.use i seguenti parametri:

Quote:
*/* PYTHON_TARGETS: python3_6 python3_7
*/* PYTHON_SINGLE_TARGET: -* python3_6


Dopo aver dato il comando per aggiornare:

Code:
emerge --ask --update --deep --with-bdeps=y --newuse @world


Mi da questo messaggio:

Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=kde-apps/kross-interpreters-19.12.3:5" has unmet requirements.
- kde-apps/kross-interpreters-19.12.3::gentoo USE="python -debug -ruby" ABI_X86="(64)" PYTHON_SINGLE_TARGET="-python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python? ( python_single_target_python2_7 )

The above constraints are a subset of the following complete expression:
any-of ( python ruby ) python? ( exactly-one-of ( python_single_target_python2_7 ) )

(dependency required by "kde-apps/kdesdk-meta-19.12.3::gentoo" [installed])
(dependency required by "kde-apps/kde-apps-meta-19.12.3::gentoo[sdk]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Solo che non capisco cosa bisogna fare.

Code:
eselect python list


mi da:

Quote:
Available Python interpreters, in order of preference:
[1] python3.6
[2] python3.7
[3] python2.7



Grazie a tutti per l'aiuto.


Last edited by Maxxx on Sun Apr 26, 2020 5:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1165
Location: Italy

PostPosted: Sun Apr 26, 2020 11:14 am    Post subject: Reply with quote

Prova ad aggiungere la seguente riga a /etc/portage/package.use
Code:
=kde-apps/kross-interpreters-19.12.3 python_single_target_python2_7

In alternativa è sufficiente disattivare il supporto a Python:
Code:
=kde-apps/kross-interpreters-19.12.3 -python
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 11:48 am    Post subject: Re: Aggiornamento sistema Reply with quote

Maxxx wrote:
dopo aver fatto il webrsync, leggendo "eselect news read" ho fatto come dicono di fare relativamente a python, ovvero ho messo nel mio file package.use i seguenti parametri:

Quote:
*/* PYTHON_TARGETS: python3_6 python3_7
*/* PYTHON_SINGLE_TARGET: -* python3_6

Per essere chiari non devi farlo per forza ma solo se vuoi cambiare subito a python3_7 al posto di python3_6.
Questi cambiamenti avverranno in automatico nelle prossime settimane quindi puoi attendere.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 12:31 pm    Post subject: Reply with quote

Ok grazie ragazzi, allora per adesso ho tolto quelle opzioni da package.use se tanto il cambiamento avverrà in automatico.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 12:37 pm    Post subject: Reply with quote

Dopo aver eliminato quelle opzioni da package.use e aver ridato emerge @world comunque ottengo questo messaggio:

Quote:
...
...
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

app-text/poppler:0

(app-text/poppler-0.85.0:0/95::gentoo, ebuild scheduled for merge) USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" ABI_X86="(64)" conflicts with
>=app-text/poppler-0.26.0:0/92=[cairo] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed) USE="cdr dbus exif jpeg lcms nls openmp spell -dia -gnome -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
...
...
Would you like to merge these packages? [Yes/No]


Anche se mi fa emergere è giusto che non aggiorni "app-text/poppler"?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 1:04 pm    Post subject: Reply with quote

Puoi postare tutto l'output di emerge senza troncarlo, comunque no non e' corretto.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 1:29 pm    Post subject: Reply with quote

Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] acct-group/openvpn-0
[ebuild U ] dev-util/re2c-1.3-r1 [1.3]
[ebuild N ] acct-user/openvpn-0
[ebuild U ] app-emulation/virtualbox-additions-5.2.40 [5.2.36]
[ebuild U ] dev-libs/vala-common-0.46.7 [0.44.11]
[ebuild U ] sys-apps/debianutils-4.9.1 [4.8.3] USE="installkernel%*"
[ebuild N ] sys-kernel/installkernel-gentoo-2
[ebuild U ] x11-base/xorg-drivers-1.20-r2 [1.20-r1]
[ebuild U ] dev-libs/gobject-introspection-common-1.62.0 [1.60.2]
[ebuild U ] dev-util/glib-utils-2.62.6 [2.60.7] PYTHON_SINGLE_TARGET="(-python3_8)"
[ebuild U ] dev-util/gdbus-codegen-2.62.6 [2.60.7] PYTHON_SINGLE_TARGET="(-python3_8)"
[ebuild U ] sys-apps/portage-2.3.89-r3 [2.3.89-r2]
[ebuild U ] dev-libs/fribidi-1.0.9 [1.0.8]
[ebuild U ] dev-util/gtk-doc-am-1.32 [1.25-r1]
[ebuild U ] app-portage/gentoolkit-0.4.8 [0.4.6] PYTHON_TARGETS="(-pypy3) (-python3_8)"
[ebuild U ] net-misc/dhcpcd-8.1.9 [7.2.3]
[ebuild U ] net-vpn/openvpn-2.4.9 [2.4.7-r1]
[ebuild U ] sys-kernel/genkernel-4.0.7-r1 [4.0.5]
[ebuild U ] dev-libs/libbytesize-2.2 [1.4] USE="-python% -tools%" PYTHON_TARGETS="(-python3_8)"
[ebuild U ] dev-db/mariadb-10.4.12 [10.2.29]
[ebuild U ] sys-fs/lvm2-2.02.187-r2 [2.02.184-r5]
[ebuild U ] dev-libs/glib-2.62.6 [2.60.7-r2]
[ebuild U ] dev-libs/gobject-introspection-1.62.0 [1.60.2-r1] USE="-gtk-doc%"
[blocks b ] <dev-libs/gobject-introspection-1.62.0 ("<dev-libs/gobject-introspection-1.62.0" is blocking dev-libs/gobject-introspection-common-1.62.0)
[ebuild U ] dev-libs/atk-2.34.1 [2.32.0]
[ebuild U ] app-accessibility/at-spi2-core-2.34.0 [2.32.1]
[ebuild U ] app-accessibility/at-spi2-atk-2.34.2 [2.32.0]
[ebuild U ] gnome-base/gsettings-desktop-schemas-3.34.0 [3.32.0]
[ebuild NS ] dev-lang/vala-0.46.7 [0.44.11]
[ebuild U ] net-libs/glib-networking-2.62.3 [2.60.4]
[ebuild U ] net-libs/libsoup-2.70.0 [2.66.4] USE="-brotli%"
[ebuild r U ] net-libs/gssdp-1.2.2 [1.0.3] USE="-gtk-doc% -vala%"
[ebuild r U ] net-libs/gupnp-1.2.2 [1.0.4] USE="-gtk-doc% -vala%" PYTHON_SINGLE_TARGET="(-python3_8)"
[ebuild r U ] net-libs/gupnp-igd-0.2.5-r10 [0.2.5]
[ebuild U ] dev-cpp/glibmm-2.62.0 [2.60.1]
[ebuild U ] sys-libs/libblockdev-2.23-r1 [2.20-r2] USE="tools%* -gtk-doc% -introspection%" PYTHON_SINGLE_TARGET="(-python3_8)"
[ebuild U ] gnome-base/dconf-0.34.0 [0.32.0-r2]
[ebuild U ] www-client/google-chrome-81.0.4044.122 [81.0.4044.113]
[ebuild rR ] net-libs/libnice-0.1.15
[ebuild U ] sys-power/upower-0.99.11 [0.99.9-r1]
[ebuild U ] app-text/gtkspell-2.0.16-r1 [2.0.16]
[ebuild U ] media-gfx/imagemagick-7.0.10.1 [7.0.10.0]
[ebuild U ] dev-cpp/pangomm-2.42.1 [2.42.0]
[ebuild U ] net-misc/freerdp-2.0.0-r1 [2.0.0_rc4] USE="ffmpeg*"
[ebuild U ] media-gfx/fontforge-20200314 [20190801] USE="-doc% -woff2%" PYTHON_SINGLE_TARGET="(-python3_8)"
[ebuild U ] dev-lang/spidermonkey-60.5.2_p0-r4 [60.5.2_p0-r2]
[ebuild U ] dev-python/pygobject-3.34.0 [3.32.1]
[ebuild NS ] dev-lang/python-3.8.2-r1 [2.7.17-r2, 3.6.10-r1, 3.7.7-r1]
[ebuild U ] sys-libs/glibc-2.30-r8 [2.29-r7] USE="(crypt%*) (static-libs%*) -custom-cflags%"
[ebuild U ] x11-drivers/nvidia-drivers-440.82 [440.64]
[ebuild U ] net-im/telepathy-mission-control-5.16.5 [5.16.4]

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

app-text/poppler:0

(app-text/poppler-0.85.0:0/95::gentoo, ebuild scheduled for merge) USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" ABI_X86="(64)" conflicts with
>=app-text/poppler-0.26.0:0/92=[cairo] required by (media-gfx/inkscape-0.92.4:0/0::gentoo, installed) USE="cdr dbus exif jpeg lcms nls openmp spell -dia -gnome -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
^^^^^^


The following packages are causing rebuilds:

(net-libs/gupnp-igd-0.2.5-r10:0/1.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
(net-libs/libnice-0.1.15:0/0::gentoo, ebuild scheduled for merge)
(net-libs/gssdp-1.2.2:0/1.2-0::gentoo, ebuild scheduled for merge) causes rebuilds for:
(net-libs/gupnp-1.2.2:0/1.2-0::gentoo, ebuild scheduled for merge)
(net-libs/gupnp-igd-0.2.5-r10:0/1.2::gentoo, ebuild scheduled for merge)
(net-libs/gupnp-1.2.2:0/1.2-0::gentoo, ebuild scheduled for merge) causes rebuilds for:
(net-libs/gupnp-igd-0.2.5-r10:0/1.2::gentoo, ebuild scheduled for merge)

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 1:52 pm    Post subject: Reply with quote

Prova a lanciare l'update e poi quando finito prova con
Code:
# emerge -1 =app-text/poppler-0.85.0 media-gfx/inkscape

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 1:53 pm    Post subject: Reply with quote

Ok, provo
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 2:49 pm    Post subject: Reply with quote

Allora, il comando:

Code:
emerge -1 =app-text/poppler-0.85.0 media-gfx/inkscape


ritorna:

Quote:
!!! One of the following masked packages is required to complete your request:
- media-gfx/inkscape-9999::gentoo (masked by: package.mask, missing keyword)
- media-gfx/inkscape-1.0_rc1::gentoo (masked by: package.mask, ~amd64 keyword)
- media-gfx/inkscape-0.92.4-r3::gentoo (masked by: package.mask, ~amd64 keyword)
- media-gfx/inkscape-0.92.4-r2::gentoo (masked by: package.mask)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Provo a smascherare inkscape?
Non mi ricordo perchè lo avevo mascherato.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 2:51 pm    Post subject: Reply with quote

In realta' la versione 0.92.4-r2 e' stabile non e' che l'hai mascherata tu in /etc/portage/package.mask?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 2:55 pm    Post subject: Reply with quote

L'ho smascherata e mi ricompila inkscape e poppler e altri 2 pacchetti.
Ora però mi da errore su inkscape... forse ecco xchè l'avevo mascherato. Era una delle prime righe su package.mask quindi risalte a molti mesi fa.
L'errore su inkscape è questo:

Code:
...
...
/usr/include/glib-2.0/glib/gtypes.h:549:26: note: declared here
 typedef struct _GTimeVal GTimeVal GLIB_DEPRECATED_TYPE_IN_2_62_FOR(GDateTime);
                          ^~~~~~~~
In file included from /usr/include/gtkmm-2.4/gtkmm/image.h:33,
                 from /usr/include/gtkmm-2.4/gtkmm/stock.h:27,
                 from verbs.cpp:40:
/usr/include/gdkmm-2.4/gdkmm/pixbufanimation.h:124:72: warning: 'GTimeVal' is deprecated [-Wdeprecated-declarations]
   Glib::RefPtr<PixbufAnimationIter> get_iter(const GTimeVal* start_time);
                                                                        ^
In file included from /usr/include/gtkmm-2.4/gtkmm/image.h:33,
                 from /usr/include/gtkmm-2.4/gtkmm/stock.h:27,
                 from extension/prefdialog.cpp:11:
/usr/include/gdkmm-2.4/gdkmm/pixbufanimation.h:124:72: warning: 'GTimeVal' is deprecated [-Wdeprecated-declarations]
   Glib::RefPtr<PixbufAnimationIter> get_iter(const GTimeVal* start_time);
                                                                        ^
extension/prefdialog.cpp: In member function 'void Inkscape::Extension::PrefDialog::preview_toggle()':
extension/prefdialog.cpp:204:16: warning: unused variable 'desktop' [-Wunused-variable]
     SPDesktop *desktop = SP_ACTIVE_DESKTOP;
                ^~~~~~~
make[3]: Leaving directory '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4/src'
make[2]: *** [Makefile:5976: all] Error 2
make[2]: Leaving directory '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4/src'
make[1]: *** [Makefile:1472: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4'
make: *** [Makefile:1128: all] Error 2
 * ERROR: media-gfx/inkscape-0.92.4-r2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-gfx/inkscape-0.92.4-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/inkscape-0.92.4-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4'
 * S: '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4'

>>> Failed to emerge media-gfx/inkscape-0.92.4-r2, Log file:

>>>  '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/build.log'

 * Messages for package media-gfx/inkscape-0.92.4-r2:

 * ERROR: media-gfx/inkscape-0.92.4-r2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-gfx/inkscape-0.92.4-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/inkscape-0.92.4-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4'
 * S: '/var/tmp/portage/media-gfx/inkscape-0.92.4-r2/work/inkscape-0.92.4'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: app-text/poppler-0.85.0
 *  - /usr/lib64/libpoppler.so.92
 *  - /usr/lib64/libpoppler.so.92.0.0
 *      used by /usr/bin/inkscape (media-gfx/inkscape-0.92.4)
 *      used by /usr/bin/inkview (media-gfx/inkscape-0.92.4)
 *      used by /usr/lib64/libKPimItinerary.so.5.13.3 (kde-apps/kitinerary-19.12.3)
Use emerge @preserved-rebuild to rebuild packages using these libraries
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 2:59 pm    Post subject: Reply with quote

Per favore posta tutto il build.log
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 3:01 pm    Post subject: Reply with quote

Non riesco con wgetpaste... do il comando:

Code:
wgetpaste /var/tmp/portage/media-gfx/inkscape-0.92.4-r2/temp/build.log


e dice:

Code:
Pasting > 25 kB often tend to fail with dpaste. Use --verbose or --debug to see the
error output from wget if it fails. Alternatively use another pastebin service.
Apparently nothing was received. Perhaps the connection failed. Enable --verbose or
--debug to get the output from wget that can help diagnose it correctly.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 3:11 pm    Post subject: Reply with quote

Ho fatto diversamente... ecco il log:

https://paste.drhack.net/?038ec66d2744aac4#CX2qWDBtwfNiMdNV7USatuPnRprEihd62AFLcf1s9Ebe
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 3:20 pm    Post subject: Reply with quote

Devi rifare il sync questo problema e' gia' stato risolto
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 3:24 pm    Post subject: Reply with quote

Scusa ma io stamattina ho dato:

Code:
emerge-webrsync


Che altro sync dovrei fare?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 3:25 pm    Post subject: Reply with quote

ah scusa... avendolo smascherato adessi mi riscarica la versione corretta, giusto?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 3:34 pm    Post subject: Reply with quote

Maxxx wrote:
ah scusa... avendolo smascherato adessi mi riscarica la versione corretta, giusto?

Cosa tornano i comandi emerge -pv inkscape e ls /var/db/repos/gentoo/media-gfx/inkscape/files?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 4:29 pm    Post subject: Reply with quote

Dopo aver rifatto il sync mi ha emerso inkscape senza nessun problema.
Comunque l'output dei comandi è il seguente:

Code:
ls /var/db/repos/gentoo/media-gfx/inkscape/files


Quote:
ls: impossibile accedere a '/var/db/repos/gentoo/media-gfx/inkscape/files': File o directory non esistente


e

Code:
emerge -pv inkscape



Quote:
[ebuild R ] media-gfx/inkscape-0.92.4-r2::gentoo USE="cdr dbus exif jpeg lcms nls openmp spell -dia -gnome -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_SINGLE_TARGET="python2_7" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Questo essendo ormai installato da R (Rebuild).

Grazie veramente per l'aiuto.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 4:36 pm    Post subject: Reply with quote

Maxxx wrote:
Dopo aver rifatto il sync mi ha emerso inkscape senza nessun problema.
Comunque l'output dei comandi è il seguente:

Code:
ls /var/db/repos/gentoo/media-gfx/inkscape/files


Quote:
ls: impossibile accedere a '/var/db/repos/gentoo/media-gfx/inkscape/files': File o directory non esistente

Ok devi mettere il path corretto dove sta il tuo tree o lancia il comando ls $(portageq get_repo_path / gentoo)/media-gfx/inkscape/files
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 5:06 pm    Post subject: Reply with quote

Code:
ls $(portageq get_repo_path / gentoo)/media-gfx/inkscape/files


Quote:
inkscape-0.48.4-epython.patch
inkscape-0.92.4-glibmm-2.62.patch
inkscape-0.91_pre3-cppflags.patch
inkscape-0.92.4-poppler-0.76.0.patch
inkscape-0.91_pre3-exif.patch
inkscape-0.92.4-poppler-0.82.0.patch
inkscape-0.91_pre3-sk-man.patch
inkscape-0.92.4-poppler-0.83.0.patch
inkscape-0.92.1-automagic.patch
inkscape-1.0_beta1-detect-imagemagick.patch
inkscape-0.92.1-desktop.patch
inkscape-1.0_beta1-do-not-compress-man.patch
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 6:06 pm    Post subject: Reply with quote

Era per vedere se c'era la patch inkscape-0.92.4-glibmm-2.62.patch, comunque hai risolto
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Apr 26, 2020 7:26 pm    Post subject: Reply with quote

Si, la patch c'è. Sicuramente dopo il nuovo sync.
Una cosa che non mi è mai successa è che quando ho fatto il primo webrsync non ha trovato i repository del 25 e del 24 aprile... ha caricato quelli del 23 aprile.
Chiedo, è possibile che non hanno aggiornato niente per 2 giorni?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24340
Location: here

PostPosted: Sun Apr 26, 2020 7:54 pm    Post subject: Reply with quote

No ci sono stati aggiornamenti, forse e' il tuo mirror rsync che non era ancora aggiornato con quello ufficiale.
Uso il sync con git ormai da qualche anno quindi non so bene come si comportano i server rsync
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum