Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
preserved libs [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Tue Apr 07, 2020 8:15 am    Post subject: preserved libs [solved] Reply with quote

Hello gentoo rpi people,

i did genup over the night,
no warnings at the end, system up to date.
Bringing up email client:
Code:
mali@pali ~ $ sylpheed
Segmentation fault
mali@pali ~ $ sudo emerge sylpheed

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.97, 0.34, 0.13
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/games/bin/factor (games-misc/bsd-games-2.17-r5)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by 3 other files
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $ sylpheed
Segmentation fault
mali@pali ~ $ sudo emerge @preserved-rebuild

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 3) app-crypt/johntheripper-jumbo-1.9.0::gentoo
>>> Emerging binary (2 of 3) games-misc/bsd-games-2.17-r5::gentoo
>>> Emerging binary (3 of 3) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (2 of 3) games-misc/bsd-games-2.17-r5::gentoo
>>> Installing (3 of 3) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 3) app-crypt/johntheripper-jumbo-1.9.0::gentoo
>>> Jobs: 3 of 3 complete                           Load avg: 1.15, 0.58, 0.25

 * Messages for package games-misc/bsd-games-2.17-r5:

 * Remember, in order to play games, you have to
 * be in the 'games' group.
 * Just run 'gpasswd -a <USER> games', then have <USER> re-login.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/games/bin/factor (games-misc/bsd-games-2.17-r5)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by 3 other files
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $ sylpheed
Segmentation fault

i don't know, something probably does not look right here, and it's probably me.
Thank you
_________________
Kind regards, Goran Mitic

alive
while true
kick ass


Last edited by while true on Thu Apr 09, 2020 7:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
Sakaki
Guru
Guru


Joined: 21 May 2014
Posts: 403

PostPosted: Tue Apr 07, 2020 11:13 pm    Post subject: Reply with quote

while true,

try running genup again, rebooting once done: I just recently undid the masks on dev-libs/openssl:0/1.1, and this can require two full genup runs to clear up all revdeps on some systems.
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Wed Apr 08, 2020 8:20 am    Post subject: Reply with quote

Hello Sakaki,

first, thank you for genpi64.
genup takes it's time, and i have some stuff to do during day,
but in the evening i'll run genup so i will report in the morning.

Thank you.
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Thu Apr 09, 2020 11:03 am    Post subject: Reply with quote

good afternoon gentoo people

genup had finished this morning, but still i can not open email client.
I even removed other packages causing problem,
I already genup 3 times this morning,
here is latest:
Code:
* All done - your system is now up-to-date!
mali@pali ~ $ sylpheed
Segmentation fault
mali@pali ~ $ sudo emerge sylpheed

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.75, 0.81, 0.97
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $ sylpheed
Segmentation fault
mali@pali ~ $

Thank you
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Thu Apr 09, 2020 11:10 am    Post subject: Re: preserved libs Reply with quote

while true wrote:
no warnings at the end, system up to date.

are you sure? :)
Code:

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/games/bin/factor (games-misc/bsd-games-2.17-r5)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by 3 other files
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries

I think it is a warning, and you should just do as it tells you

And when you have to deal with this, it's never a good idea to use binary package ;)
Code:
mali@pali ~ $ sudo emerge sylpheed
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Thu Apr 09, 2020 11:36 am    Post subject: Reply with quote

hello krinn,

so i did that first thing 2days ago, yesterday and today:
Code:
mali@pali ~ $ sudo emerge @preserved-rebuild

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.51, 0.34, 0.57
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $ sylpheed
Segmentation fault
mali@pali ~ $

also, during morning genups i noticed genup ran it

and I noticed, on genpi64, if i compile package (e.g. I change use flag) it compiles the package.
but if I compile same package again right away, it pulls compiled package, so binary version, it does not compile.
I do not know how to force recompilation,
(we bumped this problem couple of weeks ago
when I was getting help on setting up distcc.)

thank you

EDIT
I forgot to mention, I also rebooted rpi, just this morning couple of times, still segmentation fault.
and i was surpurised when i tried, out of some spark in wastness in beetween my ears,
emerge -uDNa @world, which reinstalled couple of packages...
I rebooted, but still no go.
I am giving genup another go now, well see...
_________________
Kind regards, Goran Mitic

alive
while true
kick ass


Last edited by while true on Thu Apr 09, 2020 11:56 am; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Thu Apr 09, 2020 11:53 am    Post subject: Reply with quote

emerge --usepkg=n ...
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Thu Apr 09, 2020 12:28 pm    Post subject: Reply with quote

just rebooted,
well i have startup script that brings up email client,
so i am right away updated that it did not work.
and to make sure
Code:
mali@pali ~ $ sylpheed
Segmentation fault

and
Code:
mali@pali ~ $ sudo emerge --usepkg=n sylpheed

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.86, 0.33, 0.12
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $ sudo emerge --usepkg=n @preserved-rebuild

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 1.00, 0.45, 0.18
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.1e
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/sylpheed (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/lib64/libsylph-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/libsylpheed-plugin-0.so.1.3.0 (mail-client/sylpheed-3.7.0)
 *      used by /usr/lib64/sylpheed/plugins/attachment_tool.so (mail-client/sylpheed-3.7.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
mali@pali ~ $


it used bins again...
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Thu Apr 09, 2020 1:43 pm    Post subject: Reply with quote

well, no idea what you do, it should not use pkg as per the option, you're using an emerge wrapper or something?
Back to top
View user's profile Send private message
Sakaki
Guru
Guru


Joined: 21 May 2014
Posts: 403

PostPosted: Thu Apr 09, 2020 5:07 pm    Post subject: Reply with quote

while true,

I think I see what's happening. The image has getbinpkg set in FEATURES, and this overrides the command line emerge setting. Try:
Code:
mali@pali ~ $ sudo FEATURES=-getbinpkg emerge --usepkg=n @preserved-rebuild
instead.

Actually genup should enforce FEATURES=-getbinpkg during its @preserved-rebuild step too; I'll fix that. Thanks for bringing it to my attention!
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 509
Location: Ljubljana, Slovenia

PostPosted: Thu Apr 09, 2020 7:48 pm    Post subject: Reply with quote

krinn, like i know what i am using, i admit, i do not know what wrapper is. is it like alias?

Sakaki, oh, it is compiling (!!!yes!!!)
Code:
mali@pali ~ $ sudo FEATURES=-getbinpkg emerge --usepkg=n @preserved-rebuild
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 0 of 1 complete, 1 running                Load avg: 0.69, 0.64, 0.68

at this point, i have a 8 core 4ghz amd proc on demand for distcc,
and still going nowhere, khehe, there must be something wrong with me,
and i still have time to notice that
Sakaki has joined this forum 4 years after me, but still managed to make genpi64,
while i... oh what a dumb ass i aha! it compiled!
Code:
>>> Installing (1 of 1) mail-client/sylpheed-3.7.0::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 0.63, 0.40, 0.38
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
mali@pali ~ $

lemme reboot
(1,2 and 3)
and sylpheed now works!!!
that FEATURES and getbinpkg thing must be it, for sure, i was saying that all along... ;)

Thank you all for your time and input.
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum