Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nVidia driver blocked
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Wed Apr 01, 2020 11:32 am    Post subject: nVidia driver blocked Reply with quote

Non riesco a installar nvidia driver...

ottengo un blocco.

ho visto qualche post in giro e qualcuno sembra abbia risolto, ma non ho capito come, non sono propio cose alla mia portata...

Code:
[ebuild  N     ] acct-group/video-0::gentoo  0 KiB
[ebuild  N     ] dev-libs/jansson-2.11::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] x11-libs/libvdpau-1.3::gentoo  USE="dri -doc -test" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] app-eselect/eselect-opencl-1.1.0-r4::gentoo  0 KiB
[ebuild  N     ] app-eselect/eselect-opengl-1.3.1-r4::gentoo  0 KiB
[ebuild   R    ] x11-base/xorg-drivers-1.20-r1::gentoo  INPUT_DEVICES="evdev -elographics -joystick -keyboard -libinput -mouse -synaptics -vmmouse -void -wacom" VIDEO_CARDS="nouveau nvidia* -amdgpu -ast -dummy -fbdev (-freedreno) (-geode) -glint -i915 -i965 -intel -mga -nv (-omap) -qxl -r128 -radeon -radeonsi -siliconmotion (-tegra) (-vc4) -vesa -via -virtualbox -vmware" 0 KiB
[ebuild  N     ] x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo  USE="X acpi driver kms multilib static-libs tools -compat -gtk3 -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] media-libs/nv-codec-headers-9.0.18.1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] media-video/ffmpeg-4.2.2:0/56.58.58::gentoo  USE="X alsa bzip2 encode gpl iconv lv2 mp3 network postproc pulseaudio threads truetype vorbis wavpack zlib (-altivec) -amr -amrenc (-appkit) -bluray -bs2b -cdio -chromaprint -chromium -codec2 -cpudetection (-cuda) -dav1d -debug -doc -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -hardcoded-tables -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libaom -libaribb24 -libass -libcaca -libdrm -libilbc -libressl -librtmp -libsoxr -libtesseract -libv4l -libxml2 -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug -openal -opencl -opengl -openh264 -openssl -opus -oss -pic -rubberband -samba -sdl -snappy -speex -srt -ssh -static-libs -svg -test -theora -twolame -v4l -vaapi -vdpau -vidstab -vpx -webp -x264 -x265 -xvid -zeromq -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="aes avx mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -avx2 -fma3 -fma4 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" VIDEO_CARDS="nvidia*" 0 KiB
[ebuild   R    ] xfce-extra/xfce4-sensors-plugin-1.3.0-r1::gentoo  USE="acpi -hddtemp -libnotify -lm-sensors" VIDEO_CARDS="nvidia*" 0 KiB
[blocks B      ] x11-drivers/nvidia-drivers[-libglvnd(-)] ("x11-drivers/nvidia-drivers[-libglvnd(-)]" is hard blocking x11-base/xorg-server-1.20.7)
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-19.3.5, x11-base/xorg-server-1.20.7)


un link che ho visto...ma non ho capito...

https://forums.gentoo.org/viewtopic-t-1109690.html[/quote]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Wed Apr 01, 2020 12:19 pm    Post subject: Reply with quote

Se hai un vecchio driver nvidia devi disabilitare la use flag libglvnd da x11-base/xorg-server e media-libs/mesa
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Wed Apr 01, 2020 1:47 pm    Post subject: Reply with quote

mhhh non va lo stesso

Code:
emerge --ask --changed-use --deep @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] acct-group/video-0::gentoo  0 KiB
[ebuild  N     ] dev-libs/jansson-2.11::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] x11-libs/libvdpau-1.3::gentoo  USE="dri -doc -test" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] app-eselect/eselect-opencl-1.1.0-r4::gentoo  0 KiB
[ebuild   R    ] x11-base/xorg-drivers-1.20-r1::gentoo  INPUT_DEVICES="evdev -elographics -joystick -keyboard -libinput -mouse -synaptics -vmmouse -void -wacom" VIDEO_CARDS="nouveau nvidia* -amdgpu -ast -dummy -fbdev (-freedreno) (-geode) -glint -i915 -i965 -intel -mga -nv (-omap) -qxl -r128 -radeon -radeonsi -siliconmotion (-tegra) (-vc4) -vesa -via -virtualbox -vmware" 0 KiB
[ebuild  N     ] app-eselect/eselect-opengl-1.3.1-r4::gentoo  0 KiB
[ebuild  N     ] x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo  USE="X acpi driver kms multilib static-libs tools -compat -gtk3 -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] media-libs/nv-codec-headers-9.0.18.1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] xfce-extra/xfce4-sensors-plugin-1.3.0-r1::gentoo  USE="acpi -hddtemp -libnotify -lm-sensors" VIDEO_CARDS="nvidia*" 0 KiB
[ebuild   R    ] media-video/ffmpeg-4.2.2:0/56.58.58::gentoo  USE="X alsa bzip2 encode gpl iconv lv2 mp3 network postproc pulseaudio threads truetype vorbis wavpack zlib (-altivec) -amr -amrenc (-appkit) -bluray -bs2b -cdio -chromaprint -chromium -codec2 -cpudetection (-cuda) -dav1d -debug -doc -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -hardcoded-tables -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libaom -libaribb24 -libass -libcaca -libdrm -libilbc -libressl -librtmp -libsoxr -libtesseract -libv4l -libxml2 -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug -openal -opencl -opengl -openh264 -openssl -opus -oss -pic -rubberband -samba -sdl -snappy -speex -srt -ssh -static-libs -svg -test -theora -twolame -v4l -vaapi -vdpau -vidstab -vpx -webp -x264 -x265 -xvid -zeromq -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="aes avx mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -avx2 -fma3 -fma4 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" VIDEO_CARDS="nvidia*" 0 KiB
[ebuild   R    ] media-libs/mesa-19.3.5::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm -d3d9 -debug -gles1 -libglvnd* -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -intel -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware" 0 KiB
[uninstall     ] media-libs/libglvnd-1.3.1::gentoo  USE="X -test" ABI_X86="(64) -32 (-x32)"
[blocks b      ] media-libs/mesa[-libglvnd(-)] ("media-libs/mesa[-libglvnd(-)]" is blocking media-libs/libglvnd-1.3.1)
[ebuild   R    ] x11-base/xorg-server-1.20.7:0/1.20.7::gentoo  USE="elogind ipv6 suid udev xorg -debug -dmx -doc -kdrive -libglvnd* -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" 0 KiB
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking x11-base/xorg-server-1.20.7, media-libs/mesa-19.3.5)
[blocks B      ] x11-drivers/nvidia-drivers[-libglvnd(-)] ("x11-drivers/nvidia-drivers[-libglvnd(-)]" is hard blocking x11-base/xorg-server-1.20.7)

Total: 12 packages (7 new, 5 reinstalls, 1 uninstall), Size of downloads: 0 KiB
Conflict: 3 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-opengl-1.3.0 required by (media-libs/mesa-19.3.5:0/0::gentoo, ebuild scheduled for merge) USE="X classic dri3 egl gallium gbm gles2 llvm -d3d9 -debug -gles1 -libglvnd -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -intel -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-base/xorg-server-1.20.7:0/1.20.7::gentoo, ebuild scheduled for merge) USE="elogind ipv6 suid udev xorg -debug -dmx -doc -kdrive -libglvnd -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)"
    >=app-eselect/eselect-opengl-1.0.9 required by (x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo, ebuild scheduled for merge) USE="X acpi driver kms multilib static-libs tools -compat -gtk3 -uvm -wayland" ABI_X86="32 (64) (-x32)"

  (x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-drivers/nvidia-drivers-390.25[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-drivers/nvidia-drivers-390.25[abi_x86_64(-)]) required by (media-libs/nv-codec-headers-9.0.18.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64) -32 (-x32)"
    x11-drivers/nvidia-drivers[tools,static-libs] required by (xfce-extra/xfce4-sensors-plugin-1.3.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="acpi -hddtemp -libnotify -lm-sensors" ABI_X86="(64)" VIDEO_CARDS="nvidia"
    x11-drivers/nvidia-drivers required by (x11-base/xorg-drivers-1.20-r1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" INPUT_DEVICES="evdev -elographics -joystick -keyboard -libinput -mouse -synaptics -vmmouse -void -wacom" VIDEO_CARDS="nouveau nvidia -amdgpu -ast -dummy -fbdev (-freedreno) (-geode) -glint -i915 -i965 -intel -mga -nv (-omap) -qxl -r128 -radeon -radeonsi -siliconmotion (-tegra) (-vc4) -vesa -via -virtualbox -vmware"


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Wed Apr 01, 2020 3:10 pm    Post subject: Reply with quote

Ho visto ora che nella versione x11-drivers/nvidia-drivers-390.132-r2 hanno aggiunto la use flag ma ha ancora qualche probelma https://bugs.gentoo.org/713546 (tienilo a mente per quando verra' stabilizzato che puoi tornare ad abilitare la use flag libglvnd).

E se provi a lanciare un
Code:
# emerge -1 xorg-server mesa
# emerge -1 nvidia-drivers

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Wed Apr 01, 2020 3:18 pm    Post subject: Reply with quote

Code:
emerge -1p xorg-server mesa

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-opengl-1.3.1-r4::gentoo  0 KiB
[ebuild   R    ] media-libs/mesa-19.3.5::gentoo  USE="X classic dri3 egl gallium gbm gles2 llvm -d3d9 -debug -gles1 -libglvnd* -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -intel -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware" 0 KiB
[uninstall     ] media-libs/libglvnd-1.3.1::gentoo  USE="X -test" ABI_X86="(64) -32 (-x32)"
[blocks b      ] media-libs/mesa[-libglvnd(-)] ("media-libs/mesa[-libglvnd(-)]" is blocking media-libs/libglvnd-1.3.1)
[ebuild   R    ] x11-base/xorg-server-1.20.7:0/1.20.7::gentoo  USE="elogind ipv6 suid udev xorg -debug -dmx -doc -kdrive -libglvnd* -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" 0 KiB
[blocks b      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking x11-base/xorg-server-1.20.7, media-libs/mesa-19.3.5)

Total: 3 packages (1 new, 2 reinstalls, 1 uninstall), Size of downloads: 0 KiB
Conflict: 2 blocks


Code:
emerge -1p nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] acct-group/video-0::gentoo  0 KiB
[ebuild  N     ] dev-libs/jansson-2.11::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] app-eselect/eselect-opencl-1.1.0-r4::gentoo  0 KiB
[ebuild  N     ] x11-libs/libvdpau-1.3::gentoo  USE="dri -doc -test" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] app-eselect/eselect-opengl-1.3.1-r4::gentoo  0 KiB
[uninstall     ] media-libs/mesa-19.3.5::gentoo  USE="X classic dri3 egl gallium gbm gles2 libglvnd llvm -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa -pax_kernel (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -intel -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[ebuild  N     ] x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo  USE="X acpi driver kms multilib static-libs tools -compat -gtk3 -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-19.3.5, x11-base/xorg-server-1.20.7)
[blocks B      ] x11-drivers/nvidia-drivers[-libglvnd(-)] ("x11-drivers/nvidia-drivers[-libglvnd(-)]" is hard blocking x11-base/xorg-server-1.20.7)

Total: 6 packages (6 new, 1 uninstall), Size of downloads: 0 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/nvidia-drivers-390.132-r1:0/390::gentoo, ebuild scheduled for merge) pulled in by
    nvidia-drivers


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages



forse mi conviene aspettare....e riprovare piú in la...?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Wed Apr 01, 2020 5:22 pm    Post subject: Reply with quote

Sembra funzionare prova a lanciare la compilazione del primo comando (li ci sono solo dei soft block che risolve portage) e in seguito quella dei driver nvidia
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Wed Apr 01, 2020 6:00 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Sembra funzionare prova a lanciare la compilazione del primo comando (li ci sono solo dei soft block che risolve portage) e in seguito quella dei driver nvidia


Grazie fedeliallaline,
sembra essere andato tutto bene.
adesso ho la avvio sia con nouveau che con nvidia, in base al kernel che avvio.

ho seguito questa guida

https://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching

comunque con i driver nvidia la grafica é migliore e si nota...


comunque ho questo risultato che non mi convince

Code:
glxinfo | grep direct
Error: couldn't find RGB GLX visual or fbconfig



domanda, ma adesso che ho compilato senza libglvnd, cosa comporta?

cosa abilita quell'use?

grazie
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Wed Apr 01, 2020 6:05 pm    Post subject: Reply with quote

antonellocaroli wrote:
fedeliallalinea wrote:
Sembra funzionare prova a lanciare la compilazione del primo comando (li ci sono solo dei soft block che risolve portage) e in seguito quella dei driver nvidia


Grazie fedeliallaline,
sembra essere andato tutto bene.
adesso ho la avvio sia con nouveau che con nvidia, in base al kernel che avvio.

ho seguito questa guida

https://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching

comunque con i driver nvidia la grafica é migliore e si nota...


comunque ho questo risultato che non mi convince

Code:
glxinfo | grep direct
Error: couldn't find RGB GLX visual or fbconfig





domanda, ma adesso che ho compilato senza libglvnd, cosa comporta?

cosa abilita quell'use?

grazie



con Nouveau ottengo invece

Code:
glxinfo | grep direct
direct rendering: Yes
    GL_AMD_gpu_shader_int64, GL_AMD_multi_draw_indirect,
    GL_ARB_depth_clamp, GL_ARB_derivative_control, GL_ARB_direct_state_access,
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect,
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
    GL_AMD_multi_draw_indirect, GL_AMD_performance_monitor,
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays,
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect,
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Wed Apr 01, 2020 7:42 pm    Post subject: Reply with quote

Cosa ritorna il comando eselect opengl list?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 2:00 am    Post subject: Reply with quote

fedeliallalinea wrote:
Cosa ritorna il comando eselect opengl list?


Code:
eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Thu Apr 02, 2020 5:50 am    Post subject: Reply with quote

Prova a settare nvidia anche se e' gia' settato, o passare a xorg-x11 e poi ancora ad nvidia
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 6:03 am    Post subject: Reply with quote

fedeliallalinea wrote:
Prova a settare nvidia anche se e' gia' settato, o passare a xorg-x11 e poi ancora ad nvidia

si avevo giá provato, non cambia il risultato.... :oops:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Thu Apr 02, 2020 6:07 am    Post subject: Reply with quote

Hai ancora i driver Nouveau attivati? Se si li devi rimuovere perche' vanno in conflitto con i driver proprietari
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 6:26 am    Post subject: Reply with quote

fedeliallalinea wrote:
Hai ancora i driver Nouveau attivati? Se si li devi rimuovere perche' vanno in conflitto con i driver proprietari


In che senso? come lo disattivo?

io ho usato questa guida per usare entrambi, in base a con quale kernel faccio il boot

https://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Thu Apr 02, 2020 6:36 am    Post subject: Reply with quote

Ok quindi li hai messi nel blacklist ma sei sicuro che il driver Nouveau sia settato come modulo nel kernel?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 7:45 am    Post subject: Reply with quote

fedeliallalinea wrote:
ma sei sicuro che il driver Nouveau sia settato come modulo nel kernel?


al 99% si, ma comunque stasera controllo....

ma non é che si tratta di questo?

Quote:
tazinblack wrote:
Hallo zusammen,

also bei mir hat er beim update von x11-libs/cairo immer mit nem Linkerfehler gegen libGL abgebrochen.
Den Block hat er aber selbststänfig aufgelöst.
Hab dann
Code:
eselect opengl set xorg-x11
oder so probiert, dann lief alles durch.

Und nvidia-drivers sieht jetzt so aus:

Code:
emerge -pv nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-drivers/nvidia-drivers-440.59:0/440::gentoo  USE="X acpi driver kms libglvnd multilib tools -compat -gtk3 -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)" 0 KiB


Und nach den Updates gibt es eselect opengl nicht mehr :?

Code:
eselect
Usage: eselect <global options> <module name> <module options>

Global options:
  --brief                   Make output shorter
  --colour=<yes|no|auto>    Enable or disable colour output (default 'auto')

Built-in modules:
  help                      Display a help message
  usage                     Display a usage message
  version                   Display version information

Extra modules:
  binutils                  Manage installed versions of sys-devel/binutils
  cdparanoia                Manage /usr/bin/cdparanoia implementation
  ecj                       Manage ECJ targets
  editor                    Manage the EDITOR environment variable
  env                       Manage environment variables set in /etc/env.d/
  fontconfig                Manage fontconfig /etc/fonts/conf.d/ symlinks
  gcc                       Manage installed versions of sys-devel/gcc
  java-vm                   Manage the Java system and user VM
  kernel                    Manage the /usr/src/linux symlink
  locale                    Manage the LANG environment variable
  maven                     Manage Maven targets
  modules                   Query eselect modules
  mpg123                    Manage /usr/bin/mpg123 implementation
  news                      Read Gentoo ("GLEP 42") news items
  notify-send               Manage /usr/bin/notify-send implementation
  opencl                    Manage the OpenCL implementation used by your system
  pager                     Manage the PAGER environment variable
  php                       Manage php installations
  pinentry                  Manage /usr/bin/pinentry implementation
  profile                   Manage the make.profile symlink
  python                    Manage Python interpreter preferences
  rc                        Manage /etc/init.d scripts in runlevels
  ruby                      Manage Ruby symlinks
  vi                        Manage /usr/bin/vi implementations
  visual                    Manage the VISUAL environment variable
  wxwidgets                 Manage the system default wxWidgets profile
  xvmc                      Manage the XvMC implementation used by your system


Gabs da irgendwelche Infos zu?
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 4:21 pm    Post subject: Reply with quote

Questo é normale?

Code:
eselect mesa list
!!! Error: Can't load module mesa
exiting
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Thu Apr 02, 2020 4:46 pm    Post subject: Reply with quote

Si perche' per selezionare mesa il comando e' eselect opengl set xorg-x11.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Thu Apr 02, 2020 5:06 pm    Post subject: Reply with quote

ho risolto togliendo queste opzioni nel kernel

Code:
Device Drivers --->
    Graphics support --->
        Frame buffer Devices --->
            <*> Support for frame buffer devices --->
            < >   nVidia Framebuffer Support
            < >   nVidia Riva support


Code:

glxinfo | grep direct
direct rendering: Yes
    GL_AMD_multi_draw_indirect, GL_ARB_ES2_compatibility,
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_half_float_vertex, GL_ARB_imaging, GL_ARB_indirect_parameters,
    GL_ARB_multi_draw_indirect, GL_ARB_multisample, GL_ARB_multitexture,
    GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    GL_NV_bindless_multi_draw_indirect,
    GL_NV_bindless_multi_draw_indirect_count, GL_NV_blend_equation_advanced,
    GL_AMD_multi_draw_indirect, GL_ARB_ES2_compatibility,
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_half_float_vertex, GL_ARB_imaging, GL_ARB_indirect_parameters,
    GL_ARB_multi_draw_indirect, GL_ARB_multisample, GL_ARB_multitexture,
    GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
    GL_NV_bindless_multi_draw_indirect,
    GL_NV_bindless_multi_draw_indirect_count, GL_NV_blend_equation_advanced,
    GL_EXT_multi_draw_indirect, GL_EXT_multisample_compatibility,


Ma adesso che ho compilato un altro kernel, devo reinstallare i driver Nvidia?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Thu Apr 02, 2020 6:21 pm    Post subject: Reply with quote

antonellocaroli wrote:
Ma adesso che ho compilato un altro kernel, devo reinstallare i driver Nvidia?

Certo se cambi versione del kernel devi sempre lanciare un emerge @module-rebuild a meno che non lo faccia automaticamente genkernel
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Sun Jun 28, 2020 3:56 am    Post subject: Reply with quote

Ieri ho notato che c'era un aggiornamento dei driver nvidia (x11-drivers/nvidia-drivers-390.138:0/390)

quindi ho rpovato a vedere se funzionava con libglvnd abilitato.

L'aggiornamento ha funzionato, a parte che mi ha tolto app-eselect/eselect-opengl e non é possibile reinstallarlo


Quote:
emerge -1p eselect-opengl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] app-eselect/eselect-opengl-1.3.1-r4::gentoo 0 KiB
[uninstall ] media-libs/mesa-20.0.8::gentoo USE="X classic dri3 egl gallium gbm gles2 libglvnd llvm zstd -d3d9 -debug -gles1 -lm-sensors -opencl -osmesa (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -vulkan-overlay -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="nouveau (-freedreno) -i915 -i965 -intel -iris (-lima) (-panfrost) -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[uninstall ] x11-drivers/nvidia-drivers-390.138:0/390::gentoo USE="X driver kms libglvnd multilib static-libs tools -compat -gtk3 -uvm -wayland" ABI_X86="32 (64) (-x32)"
[blocks B ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-20.0.8, x11-base/xorg-server-1.20.8, x11-drivers/nvidia-drivers-390.138)

Total: 1 package (1 new, 2 uninstalls), Size of downloads: 0 KiB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
eselect-opengl

(x11-base/xorg-server-1.20.8:0/1.20.8::gentoo, installed) pulled in by
x11-base/xorg-server required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.


Mi conviene ricompilare con -libglvnd ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Sun Jun 28, 2020 6:57 am    Post subject: Reply with quote

No semplicemnete visto che usi un driver che supporta libglvnd ti consiglio fi rimuover eapp-eselect/eselect-opengl che non serve piu' con libglvnd abilitato
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Sun Jun 28, 2020 7:02 am    Post subject: Reply with quote

fedeliallalinea wrote:
No semplicemnete visto che usi un driver che supporta libglvnd ti consiglio fi rimuover e app-eselect/eselect-opengl che non serve piu' con libglvnd abilitato


Grazie fedeliallalinea!!!

ok, eselect-opengl me lo ha rimosso automaticamente l'aggiornamento....
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 379

PostPosted: Mon Jun 29, 2020 4:51 am    Post subject: Reply with quote

Ho questo script all'avvio

Code:
#!/bin/bash

depend() {
   need localmount
   before xdm
}

if [[ $(uname -r) == *-nvidia ]] ; then
   modprobe -q nvidia
   if [[ $(eselect opengl show) != nvidia ]] ; then
      eselect opengl set nvidia &>/dev/null
   fi
cat > /etc/X11/xorg.conf.d/01-nvidia.conf << EOF
Section "Device"
  Identifier   "Device0"
  Driver       "nvidia"
  Option       "NoLogo" "True"
EndSection
EOF
else
   modprobe -q nouveau
   if [ -f /etc/X11/xorg.conf.d/01-nvidia.conf ] ; then
      rm /etc/X11/xorg.conf.d/01-nvidia.conf
   fi
   if [[ $(eselect opengl show) != xorg-x11 ]] ; then
      eselect opengl set xorg-x11 &>/dev/null
   fi
fi


che adesso dovrei cambiare? visto che eselect opengl non c'é più?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24678
Location: here

PostPosted: Mon Jun 29, 2020 6:19 am    Post subject: Reply with quote

Non ne sono sicuro, non ho fatto nessuna prova, ma penso che ti basti rimuovere i blocchi if dove fa partire il comando eselect opengl.
libglvnd dovrebbe settare automaticamente quello corretto.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum