Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bloqueo de opengl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Mon Mar 09, 2020 5:15 am    Post subject: Bloqueo de opengl Reply with quote

Hola a todos...

Estuve un tiempo fuera de mi ciudad por cuestiones de trabajo y dejé la compu en casa. Volví a casa después de un poco más de un mes y lo primero que hice fue actualizar el sistema pero me encuentro con un bloqueo en opengl y un conflicto que dice:

Code:
[blocks B      ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking x11-drivers/nvidia-drivers-440.59, x11-base/xorg-server-1.20.7, media-libs/mesa-20.0.1)

Total: 98 packages (79 upgrades, 1 downgrade, 3 new, 15 reinstalls), Size of downloads: 1.219 KiB
Conflict: 2 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libcdio:0

  (dev-libs/libcdio-2.1.0-r1:0/19::gentoo, installed) USE="cddb cxx -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    >=dev-libs/libcdio-0.94:0/19=[abi_x86_64(-)] required by (dev-libs/libcdio-paranoia-0.94_p2-r2:0/0::gentoo, installed) USE="cxx -static-libs -test" ABI_X86="(64) -32 (-x32)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                     
    (and 3 more with the same problem)

  (dev-libs/libcdio-2.0.0-r1:0/18::gentoo, ebuild scheduled for merge) USE="cddb cxx -minimal -static-libs -test" ABI_X86="(64) -32 (-x32)" pulled in by
    dev-libs/libcdio:0/18= required by (media-sound/clementine-1.3.1_p20190127:0/0::gentoo, installed) USE="box cdda dbus dropbox googledrive lastfm mms moodbar mtp projectm pulseaudio skydrive udisks -debug -ipod -seafile -test -wiimote" ABI_X86="(64)"
                    ^^^^^^                 


He estado tratando de resolver el problema desde hace dos días (casi recién volví a casa) y lo que pude observar es "la activación" de la USE libglvnd tanto en el paquete mesa como en el paquete nvida (cabe mencionar que estoy usando el driver propietario). Pese a que los quité del use igual me sigue el bloqueo (incluso se me dañó el servidor X pero lo pude solucionar pero sigo en el bloqueo)

Estoy estancando y no sé cómo avanzar. Espero me puedan ayudar por favor
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1420

PostPosted: Mon Mar 09, 2020 11:19 pm    Post subject: Reply with quote

Prueba a decirle a emerge que no incluya eselect-opengl en la actualización:
Code:
--exclude app-eselect/eselect-opengl
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1248
Location: La Plata, Argentina

PostPosted: Tue Mar 10, 2020 1:21 pm    Post subject: Reply with quote

equery -d eselect-opengl

yo tuve un bloqueo hace unos dias por la flag libglvnd
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
diaztoro
n00b
n00b


Joined: 17 Mar 2020
Posts: 1

PostPosted: Tue Mar 17, 2020 5:59 pm    Post subject: Reply with quote

pelelademadera wrote:
equery -d eselect-opengl

yo tuve un bloqueo hace unos dias por la flag libglvnd


Buenos días, podría por favor compartir el procedimiento para salir del bloqueo? Muchas gracias de antemano.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1248
Location: La Plata, Argentina

PostPosted: Fri Mar 20, 2020 1:12 am    Post subject: Reply with quote

quita la flag libglvnd
en el make.conf por ejemplo:

Quote:
....
USE=".... -libglvnd"
....

y
Code:
emerge -DuNav world

al menos en mi caso era esa flag el bloqueo.

chequea en /etc/portage/package.use/***.conf que no tengas la flag activa para algun paquete.
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum