Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(risolto) chromium failed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Feb 21, 2020 9:04 pm    Post subject: (risolto) chromium failed Reply with quote

Salve, come non detto già il terzo post in soli 2 giorni... comunque ho tentato 2 volte di installarmi Chromium ma mi da questo errore dopo circa 2 ore di compilazione

Code:
 * Messages for package www-client/chromium-80.0.3987.100:

 * ERROR: www-client/chromium-80.0.3987.100::gentoo failed (compile phase):
 *   ninja -v -j5 -l0 -C out/Release v8_context_snapshot_generator failed
 *
 * Call stack:
 *     ebuild.sh, line  125:  Called src_compile
 *   environment, line 4264:  Called eninja '-C' 'out/Release' 'v8_context_snapshot_generator'
 *   environment, line 1775:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 *
 * If you need support, post the output of `emerge --info '=www-client/chromium-80.0.3987.100::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/chromium-80.0.3987.100::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/www-client/chromium-80.0.3987.100/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/chromium-80.0.3987.100/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/chromium-80.0.3987.100/work/chromium-80.0.3987.100'
 * S: '/var/tmp/portage/www-client/chromium-80.0.3987.100/work/chromium-80.0.3987.100'

 * GNU info directory index is up-to-date.


cosa potrebbe consistere questo errore?


Last edited by darkfor.del on Sun Feb 23, 2020 11:25 am; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 794

PostPosted: Sat Feb 22, 2020 12:54 pm    Post subject: Reply with quote

Se puoi postare il tuo make.conf e l'errore completo sarebbe più utile e anche
Code:
 # emerge --info =www-client/chromium-80.0.3987.100


Chromium se non ricordo male dovrebbe richiedere più di 4GB di spazio su disco , e , nel caso compili su RAM dovresti assicurarti di avere RAM sufficiente o far compilare chromium su una cache nel disco

https://wiki.gentoo.org/wiki/Portage_TMPDIR_on_tmpfs
_________________
BOINC ed il calcolo distribuito

My LRecoverySystem Repo
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 22, 2020 1:55 pm    Post subject: Reply with quote

sabayonino wrote:
Se puoi postare il tuo make.conf e l'errore completo sarebbe più utile e anche
Code:
 # emerge --info =www-client/chromium-80.0.3987.100


Chromium se non ricordo male dovrebbe richiedere più di 4GB di spazio su disco , e , nel caso compili su RAM dovresti assicurarti di avere RAM sufficiente o far compilare chromium su una cache nel disco

https://wiki.gentoo.org/wiki/Portage_TMPDIR_on_tmpfs


(errore chromium)

Code:
http://dpaste.com/18QMGBE


(make.conf)

Code:
http://dpaste.com/0TM7Y2A


Il computer ha una CPU da 4 core AMD e 8 GB di RAM ma con una scheda video integrata che mi riduce la RAM a 5,70 circa

Ma la cosa strana è che è la terza volta che cerco di installare chromium ma la altre volte (prima volta come adesso con KDE e la seconda volta con XFCE) ma perché le prime 2 volte ci sono riuscito senza problemi ma adesso mi da questi errori (tra l'altro ho cercato di compilarmi pure thunderbird ma mi ha fallita la compilazione (lo so che c'è la versione binaria ma ho notato che è difficile inserire altri dizionari e preferisco compilarlo per evitare questi problemi)
GRAZIE!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Sat Feb 22, 2020 2:48 pm    Post subject: Reply with quote

Probabilmente hai avuto un Out of memory error, puoi controllare con il comando dmesg.
Per evitare questo dovresti provare a compilare chromium com MAKEOPTS="-j2" cosi' da diminuire la quantita' di ram richiesta per la compilazione parallela
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 22, 2020 3:09 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Probabilmente hai avuto un Out of memory error, puoi controllare con il comando dmesg.
Per evitare questo dovresti provare a compilare chromium com MAKEOPTS="-j2" cosi' da diminuire la quantita' di ram richiesta per la compilazione parallela


il fatto che ieri avevo fatto la compilazione normale a "-j5" ma questa mattina (queste scritte che ho pubblicate) ho fatto un tentativo scrivendo makeopts="-j2" emerge --ask www-client/chromium ma mi ha fallito lo stesso ma farò un'altro tentativo questa sera diminuendo direttamente su make.conf
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 22, 2020 3:13 pm    Post subject: Reply with quote

ho appena guardate con dmesg e mi da questi errori in rosso

Code:
[   13.109579] kfd kfd: error getting iommu info. is the iommu enabled?
[   13.109580] kfd kfd: Error initializing iommuv2

[   13.109664] kfd kfd: device 1002:15dd NOT added due to errors
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sun Feb 23, 2020 11:25 am    Post subject: Reply with quote

fedeliallalinea wrote:
Probabilmente hai avuto un Out of memory error, puoi controllare con il comando dmesg.
Per evitare questo dovresti provare a compilare chromium com MAKEOPTS="-j2" cosi' da diminuire la quantita' di ram richiesta per la compilazione parallela


Come non detto, avevi ragione! Ho abbassato il volere da "-j5" a "-j2" direttamente a make.conf e mi ha compilato e poi installato Chromium.

Grazie!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum