Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aggiornamento a Python 3.7
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 353

PostPosted: Wed Dec 25, 2019 7:09 pm    Post subject: Aggiornamento a Python 3.7 Reply with quote

Stavo provando a fare l'aggiornamento a python-3.7

seguendo il wiki

https://wiki.gentoo.org/wiki/Python

Ma arrivato al punto di

Code:
emerge --ask --changed-use --deep @world



ottengo una serie di problemi di questo tipo:

Code:

emerge --ask --changed-use --deep @world

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "dev-util/glib-utils" has unmet requirements.
- dev-util/glib-utils-2.60.7::gentoo USE="" PYTHON_SINGLE_TARGET="-python3_5 -python3_6 (-python3_7)" PYTHON_TARGETS="-python3_5 -python3_6 (-python3_7)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_5 python_single_target_python3_6 python_single_target_python3_7 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_5 python_single_target_python3_6 python_single_target_python3_7 ) python_single_target_python3_5? ( python_targets_python3_5 ) python_single_target_python3_6? ( python_targets_python3_6 ) python_single_target_python3_7? ( python_targets_python3_7 )

(dependency required by "net-dns/avahi-0.7-r2::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


c' é una soluzione/ un motivo?
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 163
Location: Osimo(AN)

PostPosted: Wed Dec 25, 2019 9:30 pm    Post subject: Reply with quote

hai provato a cambiare le use flag a paython 3.7 come ti viene suggerito?

nel wiki che hai linkato c'è scritto questo
Quote:
You may be asked to update any remaining python_targets_python3_4 USE flags as well.

Note that many popular packages such as Docker still require PYTHON_SINGLE_TARGET variable to be set to python2_7 due to various dependencies such as app-text/asciidoc which do not support Python 3.x.

_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Fri Dec 27, 2019 6:03 am    Post subject: Reply with quote

Code:
- dev-util/glib-utils-2.60.7::gentoo USE="" PYTHON_SINGLE_TARGET="-python3_5 -python3_6 (-python3_7)" PYTHON_TARGETS="-python3_5 -python3_6 (-python3_7)"

Quando le use flags sono tra parentesi significa che quella specifica use flag e' mascherata quindi non ancora pronta per l'utilizzo (in questo caso credo tu sia in un sistema stabile).
Puoi sempre smascherare queste use flag con package.use.mask o use.mask ma potresti incontrare altri errori
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 353

PostPosted: Fri Dec 27, 2019 8:15 am    Post subject: Reply with quote

si, infatti, ne nascono altri. Si sto su un sistema stable.
e a quanto pare python 3.7 ancora non é pienamente compatibile.

La cosa era nata che su arm andava tutto bene, ma in effetti su arm non sto in stable....ed é questa la differenza. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum