Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
games-puzzle/gweled-0.9.1-r2 segfaults on startup?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7587
Location: almost Mile High in the USA

PostPosted: Thu Sep 05, 2019 6:46 pm    Post subject: games-puzzle/gweled-0.9.1-r2 segfaults on startup? Reply with quote

After getting the [JewelCraft] toy and the Nazjatar runestone world quests in one of the stickied games in this forum, anyone have game-puzzle/gweled-0.9.1-r2 working?

It just segfaults on me, perhaps this package needs to be lastrited?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24693
Location: here

PostPosted: Thu Sep 05, 2019 7:41 pm    Post subject: Reply with quote

https://bugs.launchpad.net/gweled/+bug/1741664
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7587
Location: almost Mile High in the USA

PostPosted: Thu Sep 05, 2019 10:51 pm    Post subject: Reply with quote

Yep, it's that bug, confirmed.

Should the patch be part of portage is the question...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4891
Location: Dallas area

PostPosted: Fri Aug 21, 2020 10:33 pm    Post subject: Reply with quote

I was just playing with this package. Using the patch from the link by fedeliallalinea, it compiles and runs.

Though there was a problem with starting the program, the default conf if you don't have one, has sound turned on, and I had a program already using alsa, so gweled just segfaulted :roll: , so stopped program using alsa, start gweled turn off sound in settings, save, now works even if something else has alsa.

IMO, the patch should be put in gentoo and applied normally, the game won't run without it.

Edit to add: also fixed the ebuild as it complains about icon cache.
Code:
$ diff /usr/portage/games-puzzle/gweled/gweled-0.9.1-r2.ebuild /usr/local/portage/games-puzzle/gweled/
5c5
< inherit autotools flag-o-matic
---
> inherit autotools flag-o-matic xdg-utils
37a38,47
>
>
> pkg_postinst() {
>     xdg_icon_cache_update
> }
>
> pkg_postrm() {
>     xdg_icon_cache_update
> }
>

_________________
PRIME x570-pro, 3700x, RX 550 - 5.8 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 (no-pie & modified) amd64-no-multilib, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7587
Location: almost Mile High in the USA

PostPosted: Sat Sep 19, 2020 7:44 pm    Post subject: Reply with quote

Looks like the Gentoo devs aren't sure what to do with the bug after the new librsvg still doesn't fix the problem...

https://bugs.gentoo.org/show_bug.cgi?id=697514

Seems like the patch is necessary, upstream needs to change, or the package should be lastrited...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum