Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Systemd-libvirt dependency hell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sat Aug 17, 2019 8:31 am    Post subject: [SOLVED]Systemd-libvirt dependency hell Reply with quote

Hi Guys,
Today I encountered my first dependency hell in my otherwise fabulous ~amd64 install.
This is portage output:
Code:

 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

[ebuild  N    ] acct-group/lp-0
[ebuild     U ] sys-kernel/linux-firmware-20190815 [20190726-r2]
[ebuild     U ] sys-devel/patch-2.7.6-r4 [2.7.6-r3]
[ebuild     U ] dev-db/sqlite-3.29.0 [3.28.0]
[ebuild  r  U ] app-arch/lz4-1.9.1 [1.8.3]
[ebuild     U ] net-wireless/wpa_supplicant-2.9 [2.8-r1]
[ebuild  rR   ] sys-apps/systemd-243_rc1-r2
[ebuild     U ] sys-fs/cryptsetup-2.2.0 [2.1.0]
[ebuild     U ] net-print/cups-2.2.12 [2.2.11]
[ebuild     U ] net-print/cups-filters-1.25.2 [1.25.1]
[ebuild   R   ] dev-vcs/git-2.22.1
[blocks B     ] sys-apps/systemd[-cgroup-hybrid(+)] ("sys-apps/systemd[-cgroup-hybrid(+)]" is blocking app-emulation/libvirt-5.6.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-243_rc1-r2:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd:0= required by (net-fs/samba-4.10.6:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0/2= required by (gnome-base/gnome-session-3.30.1-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.30.3-r1:2/2::gentoo, installed)
    sys-apps/systemd:0/2=[policykit] required by (sys-auth/polkit-0.116-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.50-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0/2= required by (sys-fs/lvm2-2.02.185:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (x11-misc/colord-1.3.5:0/2::gentoo, installed)
    sys-apps/systemd:= required by (net-nds/rpcbind-1.2.5:0/0::gentoo, installed)
    >=sys-apps/systemd-217:0 required by (virtual/udev-217:0/0::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-fs/udisks-2.8.4:2/2::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.18.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-nds/rpcbind-1.2.5:0/0::gentoo, installed)
    >=sys-apps/systemd-31:0= required by (gnome-extra/cinnamon-screensaver-4.0.1:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-block/open-iscsi-2.0.877:0/0.2::gentoo, installed)
    sys-apps/systemd:0 required by @__auto_slot_operator_replace_installed__
    sys-apps/systemd required by (virtual/service-manager-0:0/0::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.30.2-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-apps/util-linux-2.34-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.50-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-fs/libostree-2019.1:0/0::flatpak-overlay, installed)
    sys-apps/systemd:0=[policykit] required by (sys-auth/polkit-0.116-r1:0/0::gentoo, installed)
    sys-apps/systemd[sysv-utils] required by (sys-kernel/dracut-049-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0= required by (sys-fs/lvm2-2.02.185:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-base/xorg-server-1.20.5:0/1.20.5::gentoo, installed)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0/2= required by (gnome-base/gvfs-1.40.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_64(-)] required by (media-sound/pulseaudio-12.2-r2:0/0::gentoo, installed)
    sys-apps/systemd required by (net-print/cups-2.2.12:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-extra/cinnamon-control-center-4.0.0:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-fs/samba-4.10.6:0/0::gentoo, installed)
    sys-apps/systemd required by (sys-process/procps-3.3.15-r1:0/6::gentoo, installed)
    >=sys-apps/systemd-31:0/2= required by (gnome-extra/cinnamon-screensaver-4.0.1:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0= required by (gnome-base/gvfs-1.40.2:0/0::gentoo, installed)
    sys-apps/systemd required by (net-wireless/bluez-5.50-r3:0/3::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.3.5:0/2::gentoo, installed)
    sys-apps/systemd:0/2= required by (gnome-extra/cinnamon-settings-daemon-4.0.2:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)
    sys-apps/systemd[pam] required by (sys-auth/pambase-20190402:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.18.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.12.16:0/0::gentoo, installed)
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-apps/systemd:0=[abi_x86_64(-)]) required by (media-sound/pulseaudio-12.2-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-209 required by (net-misc/modemmanager-1.10.0:0/1::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, installed)
    >=sys-apps/systemd-183 required by (gnome-extra/cinnamon-session-4.0.0-r1:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (gnome-extra/cinnamon-settings-daemon-4.0.2:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.30.1-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209 required by (x11-apps/xdm-1.1.12:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.12.16:0/0::gentoo, installed)

  (app-emulation/libvirt-5.6.0:0/5.6.0::gentoo, installed) pulled in by
    app-emulation/libvirt:0/5.6.0 required by (dev-python/libvirt-python-5.6.0:0/0::gentoo, installed)
    >=app-emulation/libvirt-1.2.6:= required by (app-emulation/libvirt-glib-2.0.0:0/0::gentoo, installed)
    >=app-emulation/libvirt-1.2.6:0/5.6.0= required by (app-emulation/libvirt-glib-2.0.0:0/0::gentoo, installed)
    app-emulation/libvirt required by @selected


The following packages are causing rebuilds:

  (app-arch/lz4-1.9.1:0/r132::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (sys-apps/systemd-243_rc1-r2:0/2::gentoo, ebuild scheduled for merge)


So it seems that this particular update of systemd is blocking my libvirt which I ABSOLUTELY need.
If I mask this particular version of systemd OR use an exclude= clause in emerge then I can update the system with no problems.
What would the best course of action then be?
Mask it and hope that some next update will be more agreeable?
Delete libvirt?(I prefer I didnt).
Or maybe something else that I am ignorant of?
Also what does this rather cryptic line mean?
Code:

[blocks B     ] sys-apps/systemd[-cgroup-hybrid(+)] ("sys-apps/systemd[-cgroup-hybrid(+)]" is blocking app-emulation/libvirt-5.6.0)


Thanks a lot friends
:)


Last edited by alamahant on Sat Aug 17, 2019 1:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 26456
Location: here

PostPosted: Sat Aug 17, 2019 12:16 pm    Post subject: Reply with quote

It's seems you should enable cgroup-hybrid use flag on systemd
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2865
Location: Frankfurt, Germany

PostPosted: Sat Aug 17, 2019 1:03 pm    Post subject: Reply with quote

fedeliallalinea wrote:
It's seems you should enable cgroup-hybrid use flag on systemd

Exactly. There's no dependency hell, just a missing USE flag.

See:
Back to top
View user's profile Send private message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sat Aug 17, 2019 1:39 pm    Post subject: Reply with quote

Thank you Guys.
It Worked!
I normally expected a portage notice that such and such USE changes are needed to proceed but the notice I got was I dont know ...of different kind.
Furthermore this happened at an update not an initial install of libvirt.
As usual I remain grateful for your kindness.
Thanks Again
:D
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2865
Location: Frankfurt, Germany

PostPosted: Sat Aug 17, 2019 2:24 pm    Post subject: Reply with quote

alamahant wrote:
I normally expected a portage notice that such and such USE changes are needed to proceed but the notice I got was I dont know ...of different kind.

But the notice is there:
Code:
sys-apps/systemd[-cgroup-hybrid(+)] ("sys-apps/systemd[-cgroup-hybrid(+)]" is blocking app-emulation/libvirt-5.6.0)
Back to top
View user's profile Send private message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sat Aug 17, 2019 5:55 pm    Post subject: Reply with quote

I dont know if i am crazy but the USE flags notices if my memory serves me right is something in the lines of:
Code:

####needed by this package
######more comments
package/name    <some USE flags>
Do you want to apply these changes .....something something....

Whereas the one I got now is of different kind...
Or am I going mad?

It would be nice to have some info of emerge's common errors/notices and how to rectify them.
Is there any such link?
Back to top
View user's profile Send private message
Phoenix591
Guru
Guru


Joined: 17 Sep 2007
Posts: 361

PostPosted: Sun Aug 18, 2019 4:10 am    Post subject: Reply with quote

not sure why it turned it into a block message instead of a useflag needed message like you said (apparently complicated portage reasons), but the syntax here
Quote:
("sys-apps/systemd[-cgroup-hybrid(+)]" is blocking app-emulation/libvirt-5.6.0)

translates as app-emulation/libvirt needs systemd with the cgroup-hybrid useflag enabled, and it treats versions of systemd that don't have the cgroup-hybrid useflag as the useflag being enabled.

(read the bug linked above for more in depth explanation, but basically systemd changed its default behavior and libvirt and some other apps that use cgroups haven't caught up yet)
Back to top
View user's profile Send private message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sun Aug 18, 2019 3:46 pm    Post subject: Reply with quote

g2g591
Thanks for the clarity...
I feel much better now
Thanks
:D
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 17283

PostPosted: Sun Aug 18, 2019 3:52 pm    Post subject: Reply with quote

g2g591 wrote:
Quote:
("sys-apps/systemd[-cgroup-hybrid(+)]" is blocking app-emulation/libvirt-5.6.0)

translates as app-emulation/libvirt needs systemd with the cgroup-hybrid useflag enabled, and it treats versions of systemd that don't have the cgroup-hybrid useflag as the useflag being enabled.
I agree, except for one point. As I read that dependency, it wants the flag to be disabled (the - after [ and before cgroup-hybrid), not enabled as you said. I agree that the trailing (+) means "if undefined, assume enabled."

[Edit: see my next message. I focused on how to match, ignoring that matching triggers a block. The quoted post is correct: you need the flag enabled if you want to avoid the blocker. You need the flag disabled if you want to be blocked.]


Last edited by Hu on Sun Aug 18, 2019 7:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
GDH-gentoo
l33t
l33t


Joined: 20 Jul 2019
Posts: 767
Location: South America

PostPosted: Sun Aug 18, 2019 3:57 pm    Post subject: Reply with quote

g2g591 wrote:
not sure why it turned it into a block message instead of a useflag needed message like you said (apparently complicated portage reasons)

The package maintainer wrote the condition as a blocker.

Code:
RDEPEND="
   ...
   !sys-apps/systemd[-cgroup-hybrid(+)]
   ...
   zfs? ( sys-fs/zfs )"
Back to top
View user's profile Send private message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sun Aug 18, 2019 5:24 pm    Post subject: Reply with quote

So basically should I enable or disable the USE flag???
What I did was to enable it and this cleared the conflict.
PS I can confirm that if I try to use -cgroup-hybrid and try to re-emerge systemd I get the same exact crazy message about libvirt and systemd blocking.
Therefore i assume that it wants it on.
So this begs the question --Do USE flags have three possible values?
<USE>
<-USE> and
<UNDEFINED>
?
And if yes do UNDEFINED ones always default to "-" unless otherwise specified?
I now feel more confused than ever.................
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 17283

PostPosted: Sun Aug 18, 2019 7:26 pm    Post subject: Reply with quote

My prior message was unintentionally confusing. The expression sys-apps/systemd[-cgroup-hybrid(+)] matches sys-apps/systemd with USE=-cgroup-hybrid, does not match with USE=cgroup-hybrid, and does not match with undefined because (+) says undefined is the same as USE=cgroup-hybrid. Where my prior message could be misleading is that things that match are blockers, not requirements as is usually done with USE-flag dependencies. I focused on which packages match the rule, ignoring that matching is actually a bad thing in this case. So if you want a match, which will trigger a block, set USE=-cgroup-hybrid. If you want no match, thus avoiding the blocker, set USE=cgroup-hybrid or use a version that lacks this flag.
Back to top
View user's profile Send private message
alamahant
Veteran
Veteran


Joined: 23 Mar 2019
Posts: 1359

PostPosted: Sun Aug 18, 2019 7:59 pm    Post subject: Reply with quote

Thanks Hu...
Resolution at last.
Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum