Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]@preserved-rebuild aparece constantemente
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Tue Jul 09, 2019 5:43 am    Post subject: [SOLVED]@preserved-rebuild aparece constantemente Reply with quote

Buenas con todos.

Hace algún tiempo hice una limpieza de paquetes y eliminé paquetes que ya no usaba y cosas que ya ni me acuerdo. Desde ese entonces me ha venido apareciendo el mismo mensaje una y otra vez y por más que ejecuto el comando que emerge me pide, sigue apareciendo...

Code:
!!! existing preserved libs:
>>> package: dev-libs/jemalloc-3.6.0
 *  - /usr/lib64/libjemalloc.so.1
 *      used by /usr/lib/plexmediaserver/Plex DLNA Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
>>> package: media-libs/opencv-3.4.1-r5
 *  - /usr/lib64/libopencv_core.so.2.4
 *  - /usr/lib64/libopencv_core.so.2.4.13
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/libopencv_imgproc.so.2.4 (media-tv/plex-media-server-1.13.2-r1)
 *  - /usr/lib64/libopencv_imgproc.so.2.4
 *  - /usr/lib64/libopencv_imgproc.so.2.4.13
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries


Cómo puedo limpiar de mejor manera lo que no me sirve para evitar que siga saliendo éste mensaje?
Cabe señalar que no ha afectado mi uso pero es molestoso verlo en cada actualización :lol:


Last edited by Jack Krauser on Wed Jul 10, 2019 1:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Tue Jul 09, 2019 2:41 pm    Post subject: Reply with quote

Los paquetes en conflicto (dev-libs/jemalloc y media-libs/opencv) en algún momento anterior en tu sistema han sido dependientes, a nivel de ebuild, de media-tv/plex-media-server pero creo que ya no lo son y tu portage no lo sabe. Mi consejo es que los elimines (dev-libs/jemalloc y media-libs/opencv).

Si el paquete media-tv/plex-media-server te interesa lo reconstruyes y después haces un emerge --depclean

Si el paquete media-tv/plex-media-server no te interesa lo eliminas también.
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Wed Jul 10, 2019 1:38 pm    Post subject: Reply with quote

Hola quilosaq.

quilosaq wrote:
Los paquetes en conflicto (dev-libs/jemalloc y media-libs/opencv) en algún momento anterior en tu sistema han sido dependientes, a nivel de ebuild, de media-tv/plex-media-server pero creo que ya no lo son y tu portage no lo sabe. Mi consejo es que los elimines (dev-libs/jemalloc y media-libs/opencv)


A pesar de haber eliminado esos paquetes, emerge @preserved-rebuild seguía apareciendo :?

quilosaq wrote:
Si el paquete media-tv/plex-media-server te interesa lo reconstruyes y después haces un emerge --depclean
Si el paquete media-tv/plex-media-server no te interesa lo eliminas también.


A pesar de que ejecuté emerge plex-media-server para que se vuelva a instalar, igual seguía saliendo lo mismo; lo que hice fue desinstalar plex-media-server, ejecutar emerge --depclean como recomendaste, volver a instalar plex-media-server y al fin se pudo solucionar el asunto aunque plex-media-server no funciona como estaba funcionando pero eso es asunto de otro tema

Muchas gracias por la ayuda amigo :D
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Wed Jul 10, 2019 1:44 pm    Post subject: [SOLVED]@preserved-rebuild aparece constantemente Reply with quote

Jack Krauser wrote:
Buenas con todos.

Hace algún tiempo hice una limpieza de paquetes y eliminé paquetes que ya no usaba y cosas que ya ni me acuerdo. Desde ese entonces me ha venido apareciendo el mismo mensaje una y otra vez y por más que ejecuto el comando que emerge me pide, sigue apareciendo...

Code:
!!! existing preserved libs:
>>> package: dev-libs/jemalloc-3.6.0
 *  - /usr/lib64/libjemalloc.so.1
 *      used by /usr/lib/plexmediaserver/Plex DLNA Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
>>> package: media-libs/opencv-3.4.1-r5
 *  - /usr/lib64/libopencv_core.so.2.4
 *  - /usr/lib64/libopencv_core.so.2.4.13
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/libopencv_imgproc.so.2.4 (media-tv/plex-media-server-1.13.2-r1)
 *  - /usr/lib64/libopencv_imgproc.so.2.4
 *  - /usr/lib64/libopencv_imgproc.so.2.4.13
 *      used by /usr/lib/plexmediaserver/Plex Media Scanner (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server (media-tv/plex-media-server-1.13.2-r1)
 *      used by /usr/lib/plexmediaserver/Plex Media Server Tests (media-tv/plex-media-server-1.13.2-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries


Cómo puedo limpiar de mejor manera lo que no me sirve para evitar que siga saliendo éste mensaje?
Cabe señalar que no ha afectado mi uso pero es molestoso verlo en cada actualización :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum