Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Spidermonkey? More like King Kong!
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
fcl
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2016
Posts: 76

PostPosted: Fri Apr 24, 2020 9:06 am    Post subject: Reply with quote

It seems there is a patch[1] for polkit to use duktape instead of spidermonkey. The comments in the merge request include a link to someone's overlay where they have an ebuild[2] for it.
I haven't tested it myself.


[1] https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/35
[2] https://github.com/hhoffstaette/portage/tree/master/sys-auth/polkit
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1822
Location: KUUSANKOSKI, Finland

PostPosted: Fri Apr 24, 2020 10:14 am    Post subject: Reply with quote

Well, that's a better direction for centain.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
CaptainBlood
Veteran
Veteran


Joined: 24 Jan 2010
Posts: 1892

PostPosted: Fri Apr 24, 2020 12:23 pm    Post subject: Reply with quote

fcl wrote:
It seems there is a patch[1] for polkit to use duktape instead of spidermonkey. The comments in the merge request include a link to someone's overlay where they have an ebuild[2] for it.
I haven't tested it myself.
[1] https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/35
[2] https://github.com/hhoffstaette/portage/tree/master/sys-auth/polkit
Quite interesting, let's see...
Code:
edep spidermonkey
 * These packages depend on spidermonkey:
dev-libs/gjs-1.58.6 (dev-lang/spidermonkey:60)
soidermonkey removal showstopper:
Code:
edep dev-libs/gjs
 * These packages depend on dev-libs/gjs:
gnome-base/gnome-shell-3.34.5 (>=dev-libs/gjs-1.57.3)
only here for evaluation,:cry:
spidermonkey free out of tree polkit here, though:
Code:
sys-auth/polkit
     Installed versions:  0.115-r7^t[1](14:13:15 16/03/2020)(duktape elogind gtk introspection pam -consolekit -examples -jit -kde -nls -selinux -systemd -test)
Thks 4 ur attention, interest & support
Back to top
View user's profile Send private message
sdauth
Apprentice
Apprentice


Joined: 19 Sep 2018
Posts: 195
Location: Ásgarðr

PostPosted: Fri Apr 24, 2020 9:41 pm    Post subject: Reply with quote

fcl wrote:
It seems there is a patch[1] for polkit to use duktape instead of spidermonkey. The comments in the merge request include a link to someone's overlay where they have an ebuild[2] for it.
I haven't tested it myself.


[1] https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/35
[2] https://github.com/hhoffstaette/portage/tree/master/sys-auth/polkit


Nice, finally able to remove spiderkingkong on my bloated system! :o thanks
Back to top
View user's profile Send private message
ipic
Guru
Guru


Joined: 29 Dec 2003
Posts: 316
Location: UK

PostPosted: Sat Apr 25, 2020 8:21 am    Post subject: Reply with quote

The 'duktape' use flag has been removed from latest ebuild in the hhoffstaette overlay:
Code:

sys-auth/polkit
Installed versions:  0.116-r2^t[1](09:11:10 25/04/20)(elogind gtk introspection nls pam -consolekit -examples -kde -selinux -systemd -test)


Which I am OK with. (see rant below).

Now I get this, and I am sooo excited:
Code:

ian2 ~ # emerge --depclean -p

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 dev-lang/spidermonkey
    selected: 60.5.2_p0-r4
   protected: none
     omitted: none

 sys-devel/autoconf
    selected: 2.13-r1
   protected: none
     omitted: 2.69-r4

 dev-lang/python
    selected: 2.7.17-r2
   protected: none
     omitted: 3.6.10-r1 3.7.7-r1 3.8.2-r1

All selected packages: =sys-devel/autoconf-2.13-r1 =dev-lang/spidermonkey-60.5.2_p0-r4 =dev-lang/python-2.7.17-r2

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Packages installed:   1428
Packages in world:    184
Packages in system:   43
Required packages:    1425
Number to remove:     3
ian2 ~ #


<rant>
Which ******* genius decided to use JavaScript for a security package????
JavaScript - Really?
And Spidermonkey?? How are they ever going to be sure its not a risk??
I bet they use an IDE for writing code as well. I had an IDE once, my doctor gave me some tablets and it went away.
</rant>

Deep breath...
Back to top
View user's profile Send private message
CaptainBlood
Veteran
Veteran


Joined: 24 Jan 2010
Posts: 1892

PostPosted: Sat Apr 25, 2020 5:09 pm    Post subject: Reply with quote

Another duktape compatible polkit github repository
Check open issues though(AFAIR OSS/OSC related).
Thks 4 ur attention, interest & support.
Back to top
View user's profile Send private message
nokilli
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 196

PostPosted: Wed Aug 12, 2020 11:45 pm    Post subject: Reply with quote

I had a rant all prepared but I see now you've all beaten me to it.

Some of us are running on hardware like Raspberry Pis, ok? These emerges be epic events. There's already drama is what I'm saying.

Anyways, want a language for configuration? Use lua. It's tiny, it isn't web, it can only run amok to the extent you decide to let it. Highly recommended. Also, not JavaScript.
_________________
Today is the first day of the rest of your Gentoo installation.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7967
Location: Austria

PostPosted: Thu Aug 13, 2020 3:14 pm    Post subject: Reply with quote

lua is a packaging trainwreck.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum