Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[erledigt] Konflikte zwischen Paketen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 580

PostPosted: Tue Jun 25, 2019 8:00 am    Post subject: [erledigt] Konflikte zwischen Paketen Reply with quote

Hallo zusammen,

ich wollte wieder einmal mein System aktualisieren (Profil 17.1).

Etwa 16 Pakete liefen einwandfrei durch, aber zusätzlich gab es folgende Meldung:

Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-libs/libX11:0
  (x11-libs/libX11-1.6.7:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libX11-1.6.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libvdpau-1.2:0/0::gentoo, installed)
                                                     
    >=x11-libs/libX11-1.6.2:=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.4:0/0::gentoo, installed)
                                                         
    >=x11-libs/libX11-1.6.2:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.4:0/0::gentoo, installed)
                                                             
    >=x11-libs/libX11-1.6.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-drivers/nvidia-drivers-430.26:0/430::gentoo, installed)
                                                       
x11-libs/libXext:0
  (x11-libs/libXext-1.3.4:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXext-1.3.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-drivers/nvidia-drivers-430.26:0/430::gentoo, installed)
                                                         
    >=x11-libs/libXext-1.3.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libvdpau-1.2:0/0::gentoo, installed)
                                                       
sys-libs/zlib:0
  (sys-libs/zlib-1.2.11-r2:0/1::gentoo, ebuild scheduled for merge) conflicts with
    sys-libs/zlib[abi_x86_32(-),abi_x86_64(-)] required by (x11-drivers/nvidia-drivers-430.26:0/430::gentoo, installed)
                                             
x11-libs/libxcb:0
  (x11-libs/libxcb-1.13.1:0/1.12::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libxcb-1.11.1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libX11-1.6.7:0/0::gentoo, installed)
                                                         
dev-libs/libpthread-stubs:0
  (dev-libs/libpthread-stubs-0.4-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libpthread-stubs-0.3-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.13.1:0/1.12::gentoo, installed)
                                                                   
x11-libs/libXau:0
  (x11-libs/libXau-1.0.9:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.13.1:0/1.12::gentoo, installed)
                                                           
x11-libs/libXdmcp:0
  (x11-libs/libXdmcp-1.1.3:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libxcb-1.13.1:0/1.12::gentoo, installed)
                                                           
Nothing to merge; quitting.


Diese Pakete wurden nicht installiert, vermutlich ist das ein Zwischenstadium bis zum nächsten Update.

Gruß
Manfred


Last edited by ManfredB on Thu Jul 18, 2019 9:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3889
Location: Germany

PostPosted: Fri Jul 05, 2019 6:07 am    Post subject: Reply with quote

Hallo Manfred,

nein, das schaut eher nach nicht passend gesetzten abi_x86_32 USE-Flag aus.
Mit dem (-)
bei [abi_x86_32(-),abi_x86_64(-)]
ist gemeint das diese Flags vorhanden, und auch gesetzt sein müssen -- und das scheint bei dir nicht der Fall zu sein.

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

x11-libs/libX11:0
  (x11-libs/libX11-1.6.7:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=x11-libs/libX11-1.6.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libvdpau-1.2:0/0::gentoo, installed)
                                                     
    >=x11-libs/libX11-1.6.2:=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.4:0/0::gentoo, installed)
                                                         
    >=x11-libs/libX11-1.6.2:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/libXext-1.3.4:0/0::gentoo, installed)
                                                             
    >=x11-libs/libX11-1.6.2[abi_x86_32(-),abi_x86_64(-)] required by (x11-drivers/nvidia-drivers-430.26:0/430::gentoo, installed)
[...]

^ das bedeutet bei diesem Beispiel dass diese Pakete (x11-libs/libX11 x11-libs/libvdpau und x11-libs/libXext) alle gleich mit den
abi_x86_32 und abi_x86_64 Flags gebaut werden müssen (das fordert in diesem Fall das x11-drivers/nvidia-drivers Paket so.

Vermutlich hast du das abi_x86_32 Useflag für diese Pakete in der package.use nur für eine bestimmte Version gesetzt -- nicht aber für die nun neue Version.
Schau mal was
Code:
grep -re x11-libs/libX11 -e x11-libs/libXext -e x11-libs/libvdpau /etc/portage/package.use
dazu meint.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3889
Location: Germany

PostPosted: Thu Jul 18, 2019 2:01 pm    Post subject: Reply with quote

Lass mich raten - du hast es inzwischen mit einer Neuinstallation "gelöst"?
Falls ja, dann setze doch bitte ein [erledigt] Präfix.
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 580

PostPosted: Thu Jul 18, 2019 9:11 pm    Post subject: Reply with quote

Hallo Josef.95!

Zuvor noch herzlichen Dank für deine Antwort.

Entschuldige bitte, daß ich erst jetzt darauf reagiere.

Deine Vermutung ist korrekt.

Da ja nun 17.1 fertig ist, habe ich es versucht mit einer kompletten Neuinstallation.

Dazu habe ich ja hier schon etwas geschrieben, weil es nicht nur um das Profil geht,
sondern auch um Änderungen, was /usr/portage angeht, das es nicht mehr gibt.

Liebe Grüße
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 580

PostPosted: Tue Jul 23, 2019 4:51 am    Post subject: Reply with quote

Nachtrag:

Bei der mit diesen Fehlerangaben bestehenden Gentoo-Version habe ich
gestern ein Update durchgeführt, danach waren diese Fehlermeldungen beseitigt.

Da ich einige verschiedene Gentoo-Installationen auf meinem Rechner habe,
war mir - als du das geschrieben hast - nicht mehr ganz klar, welche Version
von Gentoo das gewesen ist.

Doch nun kann ich endlich von einem Erfolg sprechen.

Gruß
Manfred
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum