Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Errore emerge @module-rebuild
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Apr 06, 2019 11:06 am    Post subject: [RISOLTO] Errore emerge @module-rebuild Reply with quote

Ciao a tutti,
dopo aver aggiornato gentoo, quando eseguo

Code:
emerge @module-rebuild


ottengo questo errore:

Quote:
...
...
/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/linux_nvswitch.o
x86_64-pc-linux-gnu-ld: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-frontend.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-ld: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-frontend.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-ld: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-frontend.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-ld: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-frontend.o: unable to initialize decompress status for section .debug_info
/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-frontend.o: file not recognized: file format not recognized
make[2]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nvidia.Kbuild:91: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia/nv-interface.o] Error 1
make[2]: *** Waiting for unfinished jobs....
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-modeset.o";
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-prime-fence.o";
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-modeset.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-modeset.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-modeset.o: file format not recognized
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-prime-fence.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-prime-fence.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-prime-fence.o: file format not recognized
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-linux.o";
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-linux.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-linux.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-linux.o: file format not recognized
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nv-pci-table.o";
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-helper.o";
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-helper.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-helper.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-helper.o: file format not recognized
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-nvkms-memory.o";
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-nvkms-memory.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-nvkms-memory.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-nvkms-memory.o: file format not recognized
./tools/objtool/objtool orc generate --module --no-fp --retpoline "/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-user-memory.o";
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-user-memory.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-user-memory.o: unable to initialize decompress status for section .debug_info
x86_64-pc-linux-gnu-objdump: /var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel/nvidia-drm/.tmp_nvidia-drm-gem-user-memory.o: file format not recognized
make[1]: *** [Makefile:1520: _module_/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel] Error 2
make[1]: Leaving directory '/usr/src/linux-4.19.27-gentoo-r1'
make: *** [Makefile:79: modules] Error 2
* ERROR: x11-drivers/nvidia-drivers-418.43::gentoo failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-418.43::gentoo'`,
* the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-418.43::gentoo'`.
* The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/temp/environment'.
* Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/kernel'
* S: '/var/tmp/portage/x11-drivers/nvidia-drivers-418.43/work/'


Last edited by Maxxx on Sat Apr 06, 2019 12:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Apr 06, 2019 11:08 am    Post subject: Reply with quote

Premetto che avevo installato virtualbox e che mi dava lo stesso errore (sempre su @modulke.rebuild) su:

app-emulation/virtualbox-modules

ho disinstallato app-emulation/virtualbox-modules e ora me lo da sui driver nvidia
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 06, 2019 11:14 am    Post subject: Reply with quote

Che versione di dev-libs/elfutils hai installato?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Apr 06, 2019 11:27 am    Post subject: Reply with quote

dev-libs/elfutils-0.176
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 06, 2019 11:37 am    Post subject: Reply with quote

Maxxx wrote:
dev-libs/elfutils-0.176

Ok sembra un bug di binutils 2.31. Hai due possibilita' ho fai il downgrade di dev-libs/elfutils a una versione minore di 0.175, ho applichi una patch a binutils
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Apr 06, 2019 11:42 am    Post subject: Reply with quote

ho fatto downgrade e ora funziona... mi hai risolto anche questa.
Grazie veramente.

Ma una cosa, la prossima settimana, quando riaggiorno tutto, in teoria la patch la troverò in serie sul sync, oppure dovrò ancora lasciare mascherata la versione errata di elfutils?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 06, 2019 2:24 pm    Post subject: Reply with quote

Maxxx wrote:
Ma una cosa, la prossima settimana, quando riaggiorno tutto, in teoria la patch la troverò in serie sul sync, oppure dovrò ancora lasciare mascherata la versione errata di elfutils?

Ho aperto un nuovo bug, vediamo se risolvono
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sat Apr 06, 2019 2:31 pm    Post subject: Reply with quote

Scusa ma come hai fatto a capire che si trattava di quello?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 06, 2019 3:10 pm    Post subject: Reply with quote

Maxxx wrote:
Scusa ma come hai fatto a capire che si trattava di quello?

Semplicemente cercando il tuo messaggio di errore in google e ho trovato lo stesso problema sul bug tracker di redhat
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum