Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] dbus (cerrado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Sat Mar 30, 2019 10:47 pm    Post subject: [emerge] dbus (cerrado) Reply with quote

Un saludo a todos los amigos de este respetuoso foro.

El problema es que toque un archivo de configuración o un paquete y no se cual fue por error. Ahora no puedo actualizar :(
Quote:
emerge --update --deep --newuse -atv @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=sys-apps/dbus-1.5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" has unmet requirements.
- sys-apps/dbus-1.12.12-r1::gentoo USE="X elogind systemd -debug -doc (-selinux) -static-libs -test -user-session" ABI_X86="32 (64) (-x32)"

The following REQUIRED_USE flag constraints are unsatisfied:
at-most-one-of ( elogind systemd )

(dependency required by "app-accessibility/at-spi2-atk-2.26.2::gentoo" [installed])
(dependency required by "x11-libs/gtk+-3.24.1::gentoo[X]" [installed])
(dependency required by "x11-themes/adwaita-icon-theme-3.24.0::gentoo" [installed])


No uso systemd ya que el sistema lo hice con OpenRc, Alguna ayuda tengo en package.use/dbus
Quote:
>=sys-apps/dbus-1.12.12-r1 -systemd elogind

Pero sigue pidiendo systemd :evil:

Alguna luz por favor de como corregir mi error. :idea: :idea:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810


Last edited by carlos plaza on Mon Apr 01, 2019 10:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Sat Mar 30, 2019 11:38 pm    Post subject: Re: [emerge] dbus (open) Reply with quote

carlos plaza wrote:
...
tengo en package.use/dbus
Quote:
>=sys-apps/dbus-1.12.12-r1 -systemd elogind
...
¿Qué pasa si lo cambias a
Code:
>=sys-apps/dbus-1.12.12-r1 -systemd -elogind
?
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Sun Mar 31, 2019 12:45 am    Post subject: Re: [emerge] dbus (open) Reply with quote

Gracias quilosaq
Peor me quiere instalar systemd y otros paquetes como gentoo-systemd-integration y se bloquean otros.
quilosaq wrote:
¿Qué pasa si lo cambias a
Code:
>=sys-apps/dbus-1.12.12-r1 -systemd -elogind
?


Lo peor es que tuve que apagar la portatil donde tengo el problema y ahora no puedo conectarme por wifi, estoy utilizando otra maquina para poder escribir y buscar solución.
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Sun Mar 31, 2019 12:13 pm    Post subject: Reply with quote

¿Que servicios de red tienes y en que estado están?
Code:
rc-status -a | grep net.
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Sun Mar 31, 2019 1:16 pm    Post subject: Reply with quote

Gracias quilosap
quilosaq wrote:
¿Que servicios de red tienes y en que estado están?
Code:
rc-status -a | grep net.

Code:

net.lo                                           [started]
net.eth0                                       [inactive]
net.wlan0                                     [inactive]
netmount                                     [schheduled]
Runlevel:  nonetwork

_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Sun Mar 31, 2019 2:05 pm    Post subject: Reply with quote

Mira si lo puedes arrancar manualmente.
Code:
(root)# /etc/init.d/net.wlan0 start
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Sun Mar 31, 2019 5:53 pm    Post subject: Reply with quote

Gracias quilosap
quilosaq wrote:
Mira si lo puedes arrancar manualmente.
Code:
(root)# /etc/init.d/net.wlan0 start

ya tengo wifi, pude instalar dbus
Code:
USE="-systemd" emerge -v sys-apps/dbus

pero todavia tengo problemas con las use, cuando quiero actualizar
Code:
emerge --update --deep --newuse -atv @world

These are the packages that would be merged, in reverse order:

Calculating dependencies |

!!! Problem resolving dependencies for sys-apps/dbus from @selected
... done!

!!! The ebuild selected to satisfy "sys-apps/dbus" has unmet requirements.
- sys-apps/dbus-1.12.12-r1::gentoo USE="X elogind systemd -debug -doc (-selinux) -static-libs -test -user-session" ABI_X86="32 (64) (-x32)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( elogind systemd )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
:?: :?: :?: quien me llama systemd mi sistema esta con OpenRc
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Sun Mar 31, 2019 6:32 pm    Post subject: Reply with quote

¿Que dice
Code:
USE="-systemd -elogind" emerge -pv sys-apps/dbus
?
Back to top
View user's profile Send private message
expobi
n00b
n00b


Joined: 29 Dec 2014
Posts: 69
Location: Santander - España

PostPosted: Mon Apr 01, 2019 1:01 pm    Post subject: Reply with quote

¿Cambiaste el perfil, cuál tienes activo?

Code:
eselect profile list


¿Que te sale con:?

Code:
grep -r -i "systemd" /etc/portage/

y
Code:
grep -r -i "elogind" /etc/portage/
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Mon Apr 01, 2019 9:26 pm    Post subject: Reply with quote

Gracias quilosaq
quilosaq wrote:
¿Que dice
Code:
USE="-systemd -elogind" emerge -pv sys-apps/dbus
?

pude instalar dbus que lo habia borrado por error :oops:
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810


Last edited by carlos plaza on Mon Apr 01, 2019 10:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Mon Apr 01, 2019 9:47 pm    Post subject: Reply with quote

Gracias expobi
expobi wrote:
¿Cambiaste el perfil, cuál tienes activo?

Code:
eselect profile list


¿Que te sale con:?

Code:
grep -r -i "systemd" /etc/portage/

y
Code:
grep -r -i "elogind" /etc/portage/

Como ya había dicho uso OpenRc
Code:
 eselect profile list

  [16]  default/linux/amd64/17.0/desktop (stable) *
 


Gracias a estos comando puedo ver y creo que el problema lo tengo en
Quote:
/etc/portage/package.use/zlib

Code:
 grep -r -i "systemd" /etc/portage/
/etc/portage/package.use/dbus:#>=sys-apps/dbus-1.12.12-r1 -systemd -elogind
/etc/portage/package.use/dbus:sys-apps/dbus -systemd elogind
/etc/portage/package.use/networkmanager:>=net-misc/networkmanager-1.8.4 audit connection-sharing dhcpcd json ofono policykit resolvconf elogind consolekit -systemd teamd test vala modemmanager wext nss gnutls ppp wifi
/etc/portage/package.use/zlib:# required by virtual/libudev-232::gentoo[-static-libs,-systemd]
/etc/portage/package.use/zlib:# required by sys-apps/systemd-239-r4::gentoo
/etc/portage/package.use/zlib:>=sys-apps/dbus-1.12.12-r1 systemd


Code:
grep -r -i "elogind" /etc/portage/
/etc/portage/make.conf:USE="readline tcl uuid 3dnow symlink hddtemp unicode vorbis mpeg mp3 Flac ffmpeg a52 aac cdda xcomposite qt4 qt5 scrypt zstd -vala wext icu gnome-keyring ssl $USE mtp libnotify appstream ibus legacy-systray -test analyzer cover crossfade cue curl enca game -libav lyrics mms modplug musepack notifier opus projectm qsui qtmedia scrobbler sid sndfile soxr stereo tray wavpack aalib bidi bl bs2b cddb cdparanoia cpudetection dga dv dvb faac faad fbcon ftp ggi gsm ladspa libcaca libmpeg2 lirc live lzo md5sum nas nut openal pnm pvr radio rtc rtmp samba speex tga theora toolame tremor twolame vcd xinerama xvmc yuv4mpeg zoran extras gstreamer mplayer apache2 cgi fpm cli java kerberos python dmalloc ldap libtirpc mount-locking sasl bazaar dropbox git mercurial subversion pch rar wxwidgets bzip2 natspec librsync-bundled bluetooth deprecated mesh obex test-programs branding cups eds firebird googledrive pm-utils ncurses nss gnutls consolekit wifi crypt display-manager grub gtk2 gtk3 gtk4 pdfimport vlc gtk handbook plymouth pulseaudio sddm sdk wallpapers kde fbcondecor hwdb kmod rule-generator dbus acl cgroups evdev pm-utils policykit -ppp elogind nls udisks introspection usb alsa alisp touchpad lm_sensors kde -pam"
/etc/portage/make.conf:#USE="readline -llvm tcl uuid 3dnow symlink hddtemp unicode vorbis mpeg mp3 Flac ffmpeg a52 aac cdda xcomposite qt4 qt5 scrypt zstd -vala wext icu gnome-keyring ssl $USE mtp libnotify appstream ibus legacy-systray -test analyzer cover crossfade cue curl enca game -libav lyrics mms modplug musepack notifier opus projectm qsui qtmedia scrobbler sid sndfile soxr stereo tray wavpack aalib bidi bl bs2b cddb cdparanoia cpudetection dga dv dvb faac faad fbcon ftp ggi gsm ladspa libcaca libmpeg2 lirc live lzo md5sum nas nut openal pnm pvr radio rtc rtmp samba speex tga theora toolame tremor twolame vcd xinerama xvmc yuv4mpeg zoran extras gstreamer mplayer apache2 cgi fpm cli java kerberos python dmalloc ldap libtirpc mount-locking sasl bazaar dropbox git mercurial subversion pch rar wxwidgets bzip2 natspec librsync-bundled bluetooth deprecated mesh obex test-programs branding cups eds firebird googledrive pm-utils ncurses nss gnutls consolekit wifi crypt display-manager grub gtk2 gtk3 gtk4 pdfimport vlc gtk handbook plymouth pulseaudio sddm sdk wallpapers kde fbcondecor hwdb kmod rule-generator dbus acl cgroups evdev pm-utils policykit -ppp elogind nls udisks introspection usb alsa alisp touchpad lm_sensors kde -pam"
/etc/portage/make.conf.euse_backup:USE="dbus consolekit acl cgroups evdev pm-utils policykit elogind nls udisks gtk introspection policykit usb"
/etc/portage/make.conf.carlos1:USE="java kerberos python dmalloc ldap libtirpc mount-locking sasl bazaar dropbox git mercurial subversion pch rar wxwidgets bzip2 natspec librsync-bundled bluetooth deprecated mesh obex test-programs static-libs branding cups eds firebird googledrive pm-utils ncurses nss gnutls consolekit wifi crypt display-manager grub gtk2 pdfimport vlc gtk handbook plymouth pulseaudio sddm sdk wallpapers kde fbcondecor hwdb kmod rule-generator dbus acl cgroups evdev pm-utils policykit ppp elogind nls udisks introspection usb alsa alisp touchpad lm_sensors kde -pam"
/etc/portage/make.conf.carlos2:USE="hddtemp unicode vorbis mpeg mp3 Flac ffmpeg a52 aac cdda xcomposite qt4 qt5 scrypt zstd -vala wext icu gnome-keyring ssl $USE mtp libnotify appstream ibus legacy-systray -test analyzer cover crossfade cue curl enca game -libav lyrics mms modplug musepack notifier opus projectm qsui qtmedia scrobbler sid sndfile soxr stereo tray wavpack aalib bidi bl bs2b cddb cdparanoia cpudetection dga dv dvb faac faad fbcon ftp ggi gsm ladspa libcaca libmpeg2 lirc live lzo md5sum nas nut openal pnm pvr radio rtc rtmp samba speex tga theora toolame tremor twolame vcd xinerama xvmc yuv4mpeg zoran extras gstreamer -mplayer apache2 cgi fpm cli java kerberos python dmalloc ldap libtirpc mount-locking sasl bazaar dropbox git mercurial subversion pch rar wxwidgets bzip2 natspec librsync-bundled bluetooth deprecated mesh obex test-programs branding cups eds firebird googledrive pm-utils ncurses nss gnutls consolekit wifi crypt display-manager grub gtk2 gtk3 gtk4 pdfimport vlc gtk handbook plymouth pulseaudio sddm sdk wallpapers kde fbcondecor hwdb kmod rule-generator dbus acl cgroups evdev pm-utils policykit -ppp elogind nls udisks introspection usb alsa alisp touchpad lm_sensors kde -pam"
/etc/portage/package.use/dbus:#>=sys-apps/dbus-1.12.12-r1 -systemd -elogind
/etc/portage/package.use/dbus:sys-apps/dbus -systemd elogind
/etc/portage/package.use/networkmanager:>=net-misc/networkmanager-1.8.4 audit connection-sharing dhcpcd json ofono policykit resolvconf elogind consolekit -systemd teamd test vala modemmanager wext nss gnutls ppp wifi
/etc/portage/package.use/zlib:# required by sys-auth/elogind-235.2-r2::gentoo[pam]
/etc/portage/package.use/zlib:# required by gnome-base/gvfs-1.32.1-r1::gentoo[elogind]
/etc/portage/package.use/elogind:>=sys-auth/elogind-235.2-r1 pam

_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
carlos plaza
Guru
Guru


Joined: 22 Jan 2005
Posts: 329
Location: Venezuela

PostPosted: Mon Apr 01, 2019 10:10 pm    Post subject: Reply with quote

Muchas gracias a los amigos quilosaq y expobi que muy gentilmente me han ayudado

Solución:
Quote:

Elimine
Code:
net-misc/networkmanager
que no lo utilizo y comente la linea en
Code:
>=sys-apps/dbus-1.12.12-r1 systemd

de /etc/portage/package.use/zlib
Gracias de nuevo y muy agradecido.
_________________
“La amabilidad es un idioma que el sordo puede oír y el ciego puede ver.”

linux user 384810
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum