Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perché systemd su Gentoo anche se non lo voglio? [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Sat Feb 23, 2019 11:55 pm    Post subject: perché systemd su Gentoo anche se non lo voglio? [RISOLTO] Reply with quote

Portage mi obbliga a passare a Systemd:

Code:
BlackyPavel64 /home/velociraptor # emerge -uDNva world --with-bdeps\=y

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=sys-apps/dbus-1.6:0/0=[-user-session]" has unmet requirements.
- sys-apps/dbus-1.10.24::gentoo USE="X elogind systemd -debug -doc (-selinux) -static-libs -test -user-session" ABI_X86="32 (64) (-x32)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( elogind systemd )

  The above constraints are a subset of the following complete expression:
    at-most-one-of ( elogind systemd ) test? ( debug )

(dependency required by "net-wireless/bluez-5.50-r1::gentoo" [installed])
(dependency required by "dev-lang/python-2.7.15::gentoo[bluetooth]" [installed])
(dependency required by "dev-libs/libxml2-2.9.9::gentoo[python,python_targets_python2_7]" [installed])
(dependency required by "sys-devel/gettext-0.19.8.1::gentoo" [installed])
(dependency required by "dev-perl/Locale-gettext-1.70.0::gentoo" [installed])
(dependency required by "sys-apps/help2man-1.47.6::gentoo[nls]" [installed])
(dependency required by "sys-devel/automake-1.16.1-r1::gentoo" [installed])
(dependency required by "sys-devel/libtool-2.4.6-r3::gentoo" [installed])
(dependency required by "sys-libs/db-5.3.28-r2::gentoo" [installed])
(dependency required by "dev-lang/perl-5.26.2::gentoo" [installed])
(dependency required by "dev-util/gtk-doc-am-1.25-r1::gentoo" [installed])
BlackyPavel64 /home/velociraptor # nano /etc/portage/package.use/wayland
BlackyPavel64 /home/velociraptor # emerge -uDNva world --with-bdeps\=y

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/openpgp-keys-gentoo-release-20190223::gentoo [20190102::gentoo] USE="-test" 50 KiB
[ebuild     U  ] sys-libs/cracklib-2.9.6-r2::gentoo [2.9.6-r1::gentoo] USE="nls zlib -python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 0 KiB
[ebuild     U  ] app-arch/rar-5.6.1_p20180930::gentoo [5.6.0_p20180624::gentoo] USE="-all_sfx" 530 KiB
[ebuild  r  U ~] media-libs/libvpx-1.8.0-r1:0/6::gentoo [1.7.0:0/5::gentoo] USE="highbitdepth postproc svc threads -doc -static-libs -test" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(-avx%) (-avx2%) (-mmx%*) (-sse%*) (-sse2%*) (-sse3%*) (-sse4_1%*) (-ssse3%*)" 0 KiB
[ebuild  rR   ~] media-libs/libvpx-1.7.0:0/5::gentoo  USE="highbitdepth postproc svc threads -doc -static-libs -test" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 sse3 sse4_1 ssse3 -avx -avx2" 0 KiB
[ebuild  NS    ] sys-devel/gcc-8.2.0-r6:8.2.0::gentoo [7.3.0-r3:7.3.0::gentoo] USE="cxx fortran (multilib) nls nptl openmp pch (pie) sanitize ssp vtv (-altivec) -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc -pgo -regression-test -systemtap -vanilla" 61992 KiB
[ebuild     U  ] app-text/wgetpaste-2.28-r2::gentoo [2.28::gentoo] USE="ssl%*" 0 KiB
[ebuild  N     ] app-arch/lz4-1.8.2:0/r131::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 314 KiB
[ebuild     U  ] sys-libs/libblockdev-2.20-r2::gentoo [2.20-r1::gentoo] USE="cryptsetup -bcache -device-mapper% -dmraid -doc -escrow -kbd -lvm -test -vdo" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5 (-python3_7)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 (-python3_7)" 0 KiB
[ebuild  N     ] sys-apps/systemd-239-r4:0/2::gentoo  USE="acl gcrypt kmod lz4 pam pcre (policykit) resolvconf seccomp split-usr ssl sysv-utils -apparmor -audit -build -cryptsetup -curl -elfutils -gnuefi -http -idn -importd -libidn2 -lzma -nat -qrcode (-selinux) -test -vanilla -xkb" ABI_X86="(64) -32 (-x32)" 7023 KiB
[ebuild   R    ] sys-apps/dbus-1.10.24::gentoo  USE="X systemd* -debug -doc -elogind* (-selinux) -static-libs -test -user-session" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-7::gentoo  63 KiB
[ebuild     U  ] www-misc/profile-sync-daemon-6.31::gentoo [5.45.1::gentoo] USE="(-systemd%)" 21 KiB
[ebuild  r  U  ] app-text/poppler-0.74.0:0/85::gentoo [0.68.0:0/79::gentoo] USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" 1479 KiB
[ebuild  rR    ] net-print/cups-filters-1.21.6::gentoo  USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs -test -zeroconf" 0 KiB
[ebuild  rR    ] app-text/texlive-core-2017-r4::gentoo  USE="X cjk luajittex xetex -doc -source -tk" 0 KiB
[ebuild  rR   ~] app-emulation/virtualbox-6.0.4-r1::gentoo  USE="alsa opengl opus pam qt5 sdk udev -debug -doc -headless -java -libressl -lvm -pax_kernel -pulseaudio -python -vboxwebsrv -vnc" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] media-sound/kid3-3.7.0:5::gentoo [3.6.1:5::gentoo] USE="flac kde mp3 mp4 taglib vorbis -acoustid -debug" 1433 KiB
[ebuild     U ~] x11-drivers/nvidia-drivers-418.43:0/418::gentoo [418.30:0/418::gentoo] USE="X acpi compat driver kms multilib tools uvm wayland -gtk3 -static-libs" ABI_X86="32 (64) (-x32)" 105252 KiB
[ebuild     U  ] media-video/kaffeine-2.0.16.2:5::gentoo [2.0.15:5::gentoo] USE="handbook -debug -dvb" 5856 KiB
[ebuild  rR    ] app-office/libreoffice-6.1.5.2::gentoo  USE="bluetooth branding cups dbus googledrive gtk java pdfimport -accessibility -coinmp -debug -eds -firebird -gstreamer -gtk2 -kde -mysql -odk -postgres -test -vlc" LIBREOFFICE_EXTENSIONS="nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5 -python3_7" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.2.5)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.2.5, sys-auth/elogind-239.3)
[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-239-r4)
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-7, sys-apps/systemd-239-r4)

Total: 21 packages (11 upgrades, 3 new, 1 in new slot, 6 reinstalls), Size of downloads: 184006 KiB
Conflict: 4 blocks (4 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libvpx:0

  (media-libs/libvpx-1.8.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libvpx-1.7.0:0/5::gentoo, ebuild scheduled for merge) pulled in by
    <media-libs/libvpx-1.8 required by (www-client/firefox-65.0.1-r1:0/0::gentoo, installed)
    ^                  ^^^                                                                                                                         
    >=media-libs/libvpx-1.7.0:0/5=[postproc] required by (www-client/firefox-65.0.1-r1:0/0::gentoo, installed)
                             ^^^^^                                                                                                               
    (and 2 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/eudev-3.2.5:0/0::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-fs/eudev-1.3:0/0[abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)
    >=sys-fs/eudev-2.1.1 required by (virtual/udev-217:0/0::gentoo, installed)

  (sys-apps/systemd-239-r4:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    sys-apps/systemd required by (www-misc/profile-sync-daemon-6.31:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.10.24:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, ebuild scheduled for merge)

  (sys-auth/elogind-239.3:0/0::gentoo, installed) pulled in by
    >=sys-auth/elogind-229.4 required by (sys-apps/accountsservice-0.6.50-r1:0/0::gentoo, installed)
    sys-auth/elogind required by @selected
    sys-auth/elogind required by (sys-auth/polkit-0.115-r2:0/0::gentoo, installed)
    >=sys-auth/elogind-219 required by (sys-fs/udisks-2.8.1:2/2::gentoo, installed)
    sys-auth/elogind required by (x11-misc/sddm-0.18.0:0/0::gentoo, installed)
    sys-auth/elogind required by (sys-process/procps-3.3.15-r1:0/6::gentoo, installed)
    >=sys-auth/elogind-219 required by (net-misc/networkmanager-1.14.4:0/0::gentoo, installed)
    sys-auth/elogind[pam] required by (sys-auth/pambase-20150213-r2:0/0::gentoo, installed)

  (sys-apps/sysvinit-2.91-r1:0/0::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.38.3-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (app-text/poppler-0.74.0:0/85::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-office/libreoffice-6.1.5.2:0/0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.21.6:0/0::gentoo, ebuild scheduled for merge)
    (app-text/texlive-core-2017-r4:0/0::gentoo, ebuild scheduled for merge)
  (media-libs/libvpx-1.8.0-r1:0/6::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-emulation/virtualbox-6.0.4-r1:0/0::gentoo, ebuild scheduled for merge)

Per quale motivo?
Grazie a chi mi aiuta.
_________________
Il numero di post non fa di me un esperto! Anzi!


Last edited by bandreabis on Sun Feb 24, 2019 4:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 690

PostPosted: Sun Feb 24, 2019 12:06 pm    Post subject: Reply with quote

Quote:
sys-apps/dbus-1.10.24::gentoo USE="X elogind systemd -debug -doc (-selinux) -static-libs -test -user-session" ABI_X86="32 (64) (-x32)"
at-most-one-of ( elogind systemd )


at-most-one-of ---> elmeno uno dei due suggeriti

D-Bus richiede una delle due (o elogind o systemd) e per come è configurato ora cerca di portarsi dietro entrambi , lo si nota dalle USE indicate

o disabiliti globalmente systemd
Code:
# euse -D systemd


e se non basta perchè qualcosa forza (dbus nel caso) , disabiliti systemd per dbus
Code:
# euse -D systemd -p sys-apps/dbus


il comando "euse" fa parte del pacchetto app-portage/gentoolkit

PS : quale profilo stai utilizando ?
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21668
Location: here

PostPosted: Sun Feb 24, 2019 12:15 pm    Post subject: Reply with quote

Passa a elogind al posto di consolekit https://wiki.gentoo.org/wiki/Elogind
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Sun Feb 24, 2019 12:38 pm    Post subject: Reply with quote

Il mio profilo è
Code:
default/linux/amd64/17.0/desktop/plasma (stable)
fedeliallalinea wrote:
Passa a elogind al posto di consolekit https://wiki.gentoo.org/wiki/Elogind

Code:
cat /etc/portage/package.use/elogind
####elogind###
sys-apps/dbus elogind -consolekit
sys-auth/polkit elogind -consolekit
x11-misc/sddm elogind -consolekit
sys-fs/udisks elogind -consolekit
sys-auth/pambase elogind -consolekit
sys-process/procps elogind -consolekit
sys-apps/accountsservice elogind -consolekit
net-misc/networkmanager elogind -consolekit
kde-plasma/powerdevil elogind -consolekit

ma anche mettendo
Code:
USE="elogind -consolekit" emerge -uDNpv world --with-bdeps\=y
non cambia.
E neppure
Code:
USE="-systemd" emerge -uDNpv world --with-bdeps\=y


oppure usando euse
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21668
Location: here

PostPosted: Sun Feb 24, 2019 1:41 pm    Post subject: Reply with quote

Scusa ho letto male l'errore.
Il problema e' il pacchetto www-misc/profile-sync-daemon dove ora richiede systemd (hanno rimosso la use flag che permetteva di disabilitarlo)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Sun Feb 24, 2019 3:02 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Scusa ho letto male l'errore.
Il problema e' il pacchetto www-misc/profile-sync-daemon dove ora richiede systemd (hanno rimosso la use flag che permetteva di disabilitarlo)


Tocca passare a systemd?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21668
Location: here

PostPosted: Sun Feb 24, 2019 3:06 pm    Post subject: Reply with quote

Se questo pacchetto per te e' indispensabile probabilmente e' l'unica soluzione (vedi https://github.com/graysky2/profile-sync-daemon#note-for-version-6)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Sun Feb 24, 2019 3:59 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Se questo pacchetto per te e' indispensabile probabilmente e' l'unica soluzione (vedi https://github.com/graysky2/profile-sync-daemon#note-for-version-6)

E chi si ricorda perché l'ho installato? :lol:
o tolgo a via.

Grazie mille.
Metto risolto
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum