Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RPI3 mail-mta/postfix: install failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Wed Mar 07, 2018 9:49 am    Post subject: RPI3 mail-mta/postfix: install failed Reply with quote

Hello

I am trying to install postfix on my rpi3. I have tried different versions (3.1.6, 3.2.4, 3.3.0) , all with the same result.

Compilation seems to work but it fails during installation (postfix-install):
Code:

postfix-install: Error: "" should be "no" or an absolute path name.
 * ERROR: mail-mta/postfix-3.3.0::gentoo failed (install phase):
 *   postfix-install failed
 *
 * Call stack:
 *     ebuild.sh, line 124:  Called src_install
 *   environment, line 2927:  Called die
 * The specific snippet of code:
 *       LD_LIBRARY_PATH="${S}/lib" /bin/sh postfix-install -non-interactive install_root="${D}" config_directory="/etc/postfix" manpage_directory="/usr/share/man" command_directory="/usr/sbin" mailq_path="/usr/bin/mailq" newaliases_path="/usr/bin/newaliases" sendmail_path="/usr/sbin/sendmail" ${myconf} || die "postfix-install failed";


something is wrong with the install script. However I can't figure it out what Error: "" relates to ;/
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46368
Location: 56N 3W

PostPosted: Wed Mar 07, 2018 9:57 am    Post subject: Reply with quote

laizzn,

The error is somewhere above your log snippit. Please put the whole build log onte a pastebin site.
wgetpaste can help.

Code:
postfix-install: Error: "" should be "no" or an absolute path name.

Reads as if that empty string should have something in it.

A Pi3 can run a 32 bit install or a 64 bit install. We may need to know which.
It will be in your build log.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Thu Mar 08, 2018 9:49 am    Post subject: Reply with quote

hi, thanks for you reply.

here is the (build-) log: https://hastebin.com/ajohomiqup.tex

for me everything looked fine, but I am quite a noob :) No idea what that empty string could be....

it's a 64bit system:

Code:

Portage 2.3.19 (python 3.5.4-final-0, default/linux/arm64/17.0/desktop, gcc-6.4.0, glibc-2.26-r6, 4.10.17-v8-9411792647f6+ aarch64)
=================================================================
System uname: Linux-4.10.17-v8-9411792647f6+-aarch64-with-gentoo-2.4.1
ACCEPT_KEYWORDS="arm64 ~arm64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="aarch64-unknown-linux-gnu"
CFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -ftree-vectorize -O2 -pipe -fomit-frame-pointer"
CHOST="aarch64-unknown-linux-gnu"

Back to top
View user's profile Send private message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Thu Mar 08, 2018 10:11 am    Post subject: Reply with quote

..forgoing distcc and it worked. sorry for bothering..!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46368
Location: 56N 3W

PostPosted: Thu Mar 08, 2018 10:37 am    Post subject: Reply with quote

laizzn,

It built for me both with my USE flags and yours.
A few points to note. I used
    gcc-7.3
    the gold linker
    no distcc


Something to try, to coax it to complete. Run
Code:
ebuild /full/path/to/.ebuild merge
This is attempting to run the emerge phases directly.
It will build on what is already in /var/tmp/portage.
As your compile completed, it will retry the install, using the existing compile.

If all else fails, the binary, built with your USE flags, is in my arm64 binhost
emerge can install that directly.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
laizzn
n00b
n00b


Joined: 24 Feb 2015
Posts: 24

PostPosted: Wed Mar 14, 2018 9:10 am    Post subject: Reply with quote

@NeddySeagoon
Thank you. I will check it out.

Is the goldliner any good? Is there a howto for installation?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46368
Location: 56N 3W

PostPosted: Wed Mar 14, 2018 9:19 am    Post subject: Reply with quote

laizzn,

The gold linker is still experimental. There are still a few packages that don't link.

If you want to play with it see the Wiki.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum