Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QXcbConnection: XCB error: 3 (BadWindow)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 182
Location: Rosario, Argentina

PostPosted: Fri Nov 17, 2017 2:55 am    Post subject: QXcbConnection: XCB error: 3 (BadWindow) Reply with quote

Hola, de un dia para el otro usando qbittorrent no aparece mas en pantalla, lo ejecuto desde la linea de comandos para ver la salida y me encuentro con este mensaje de error.

Code:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 564, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 565, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 566, resource id: 48234513, major code: 12 (ConfigureWindow), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 567, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 568, resource id: 48234513, major code: 12 (ConfigureWindow), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 569, resource id: 48234513, major code: 2 (ChangeWindowAttributes), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 570, resource id: 48234513, major code: 2 (ChangeWindowAttributes), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 571, resource id: 48234513, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 572, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 573, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 574, resource id: 48234513, major code: 19 (DeleteProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 575, resource id: 48234513, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 576, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 577, resource id: 48234513, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 578, resource id: 48234513, major code: 19 (DeleteProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 579, resource id: 48234513, major code: 1 (CreateWindow), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 580, resource id: 48234513, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 581, resource id: 48234513, major code: 19 (DeleteProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 582, resource id: 48234515, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 583, resource id: 48234513, major code: 8 (MapWindow), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 585, resource id: 48234513, major code: 12 (ConfigureWindow), minor code: 0


Reinstale qbittorrent y sigue el mismo comportamiento.

Donde podria revisar?

Saludos.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1138

PostPosted: Wed Nov 22, 2017 10:00 am    Post subject: Reply with quote

Hola,
podría ser culpa de alguna actualización.
Haz un revdep-rebuild
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 182
Location: Rosario, Argentina

PostPosted: Fri Nov 24, 2017 10:08 am    Post subject: Reply with quote

Gracias por la sugerencia cameta, siempre hago revdep-rebuild.

Sigo buscando solucion.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1138

PostPosted: Sun Nov 26, 2017 12:05 pm    Post subject: Reply with quote

Pon que USE usas, y comprueba si no hay algún tema de bugs.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 182
Location: Rosario, Argentina

PostPosted: Sun Nov 26, 2017 4:58 pm    Post subject: Reply with quote

Code:

fitap@gentoo-Desktop-i7 ~ $ equery u qbittorrent

[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for net-p2p/qbittorrent-3.3.16:
 U I
 + + X     : Add support for X11
 + + dbus  : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
 + + debug : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
             https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 + + webui : Enable the Web UI


Los USES todos habilitados.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1138

PostPosted: Mon Nov 27, 2017 10:03 pm    Post subject: Reply with quote

Hola,
prueba dos cosas.
1º Borrar la configuración de transmision en tu usuario (o como yo tener un usuario de reserva donde no me importa borrar configuraciones ya que solo lo uso para testear).
Bueno, no borres, está en ~/.config/transmission/ sino cambia el nombre por ~/.config/transmissionbak/ para asi poder recuperarla en caso de que no sea ese el problema.
2º Elimina las uses debug y webui
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 182
Location: Rosario, Argentina

PostPosted: Tue Nov 28, 2017 8:17 pm    Post subject: Reply with quote

Hola cameta, no es transmission, es qbittorrent la app.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1280

PostPosted: Tue Nov 28, 2017 9:53 pm    Post subject: Reply with quote

Prueba a reinstalar libxcb, y si sigues con el error, reinstala qtgui.
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 182
Location: Rosario, Argentina

PostPosted: Thu Nov 30, 2017 7:26 pm    Post subject: Reply with quote

Gracias por responder quilosaq, hice ambas cosas sugeridas sin encontrar solucion.

Saludos.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1138

PostPosted: Fri Dec 01, 2017 5:10 pm    Post subject: Reply with quote

Prueba a instalar una versión distinta como la 3.3.10
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1138

PostPosted: Sat Dec 02, 2017 9:58 am    Post subject: Reply with quote

Code:
[ebuild  N     ] net-libs/libtorrent-rasterbar-1.1.5-r1:0/9::gentoo  USE="dht ssl -debug -doc -examples -libressl -python -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 (-python3_6)" 3851 KiB
[ebuild  N     ] dev-qt/qtlockedfile-2.4.1_p20150629::gentoo  USE="qt4 qt5 -doc" 694 KiB
[ebuild  N     ] dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo  USE="X qt4 qt5 -doc" 0 KiB
[ebuild  N     ] net-p2p/qbittorrent-3.3.16::gentoo  USE="X dbus -debug -webui" 2893 KiB

Intenta reinstalar estas dependencias y comprueba que uses hay en ellas. No te fíes de las mías.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum