Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas al instalar blender
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Thu Jun 15, 2017 6:18 am    Post subject: Problemas al instalar blender Reply with quote

Hola amigos. Siguiendo la wiki de cómo instalar blender me quedé atorado aquí:


emerge --ask --verbose media-gfx/blender:
 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.14.2::gentoo" [ebuild])
(dependency required by "media-gfx/blender-2.78a-r1::gentoo" [ebuild])
(dependency required by "media-gfx/blender" [argument])


Alguien tiene alguna idea?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16612
Location: here

PostPosted: Thu Jun 15, 2017 2:14 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-1062758.html
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1213

PostPosted: Thu Jun 15, 2017 10:17 pm    Post subject: Reply with quote

¿Qué versiones de python tienes instaladas?
Code:
eselect python list
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Fri Jun 16, 2017 1:37 am    Post subject: Reply with quote

quilosaq wrote:
¿Qué versiones de python tienes instaladas?
Code:
eselect python list


Hola quilosaq
He aquí la respuesta:


eselect python list:
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7



También intenté el enlace del mensaje anterior pero aún no funciona
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1213

PostPosted: Fri Jun 16, 2017 3:42 pm    Post subject: Reply with quote

Primero instala python-3.5. Si has seguido las instrucciones que enlazas debería bastar con
Code:
(root)# emerge -v python
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Fri Jun 16, 2017 4:20 pm    Post subject: Reply with quote

quilosaq wrote:
Primero instala python-3.5. Si has seguido las instrucciones que enlazas debería bastar con
Code:
(root)# emerge -v python


Pues seguí las instrucciones e instalé python


emerge -pv python:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-lang/python-3.5.3:3.5/3.5m::gentoo  USE="gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened -libressl -sqlite -tk -wininst" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Pero aún así sigo teniendo problemas al querer instalar blender:


emerge -pv blender:
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.14.2::gentoo" [ebuild])
(dependency required by "media-gfx/blender-2.78a-r1::gentoo" [ebuild])
(dependency required by "blender" [argument])


Estoy usando la última versión de python que instalé:

eselect python list:
Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7
  [3]   python3.4


Y no sé qué más hacer :/
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1213

PostPosted: Fri Jun 16, 2017 6:00 pm    Post subject: Reply with quote

Puedes poner lo lo dice
Code:
emerge --info
y
Code:
grep -R PYTHON /etc/portage/package.use
?
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Fri Jun 16, 2017 6:04 pm    Post subject: Reply with quote

Hola una vez más amigo quilosaq. He aquí las salidas


emerge --info:
Portage 2.3.5 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop, gcc-5.4.0, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.3
KiB Mem:    16399112 total,    432456 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Tue, 13 Jun 2017 14:30:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.3::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.c3sl.ufpr.br/ ftp://gentoo.c3sl.ufpr.br/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/"
LANG="es_EC.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 ao audiofile berkdb bindist bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt css cups cxx dbus dri dts dv dvb dvd dvdr emboss encode exif expat fam ffmpeg fftw firefox flac fortran gdbm gif glamor gnome gpm gstreamer gtk iconv ipv6 jack joystick jpeg jpeg2k kde lame lcms ldap libnotify mad matroska mms mmx mng modules mp3 mp4 mpeg mplayer multilib musepack nas ncurses nls nptl ogg openal openexr opengl openmp osc oss pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 qt5 quicktime readline samba sdl seccomp session sound spell sse sse2 sse3 ssh ssl ssse3 startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower usb v4l vcd videos vorbis win32codecs wxwidgets x264 xattr xcb xine xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Y

grep -R PYTHON /etc/portage/package.use:
/etc/portage/package.use/blender:>=media-gfx/blender-2.72b-r4 collada colorio fftw ndof openimageio python_single_target_python3_5 cycles boost openexr tiff openimageio player game-engine bullet fftw openal jemalloc opensubdiv openvdb openvdb-compression cuda PYTHON_TARGETS: -* python3_5 PYTHON_SINGLE_TARGET: -* python3_5
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1213

PostPosted: Fri Jun 16, 2017 6:39 pm    Post subject: Reply with quote

Y
Code:
cat /etc/portage/profile/use.stable.mask
?
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Fri Jun 16, 2017 10:35 pm    Post subject: Reply with quote

quilosaq wrote:
Y
Code:
cat /etc/portage/profile/use.stable.mask
?


cat /etc/portage/profile/use.stable.mask:
-python_targets_python3_5
-python_single_target_python3_5
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1092

PostPosted: Sun Jun 18, 2017 12:14 am    Post subject: Reply with quote

Pueden ser varias cosas
O primero tener el portage actualizado

Code:
emerge --sync
emerge --update --deep --with-bdeps=y --newuse -q @world
emerge --depclean
revdep-rebuild.

Y si hay instalado el nuevo gcc
hay que hacer esto, porque sino pasan cosas raras.
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc

_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Sun Jun 18, 2017 4:56 am    Post subject: Reply with quote

cameta wrote:
Pueden ser varias cosas
O primero tener el portage actualizado

Code:
emerge --sync
emerge --update --deep --with-bdeps=y --newuse -q @world
emerge --depclean
revdep-rebuild.

Y si hay instalado el nuevo gcc
hay que hacer esto, porque sino pasan cosas raras.
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc


Pues veo que el problema es más grave de lo esperado :/

emerge --update --deep --with-bdeps=y --newuse -q @world:
 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.14.2::gentoo" [ebuild])
(dependency required by "media-sound/gnome-music-3.22.2-r1::gentoo" [installed])
(dependency required by "gnome-base/gnome-extra-apps-3.22.2::gentoo[tracker]" [installed])
(dependency required by "gnome-base/gnome-3.22.2::gentoo[extras]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])



Si desintalo "idna" me sale lo siguiente:

emerge --update --deep --with-bdeps=y --newuse -q @world:
 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/requests-2.14.2::gentoo" [ebuild])
(dependency required by "media-sound/gnome-music-3.22.2-r1::gentoo" [installed])
(dependency required by "gnome-base/gnome-extra-apps-3.22.2::gentoo[tracker]" [installed])
(dependency required by "gnome-base/gnome-3.22.2::gentoo[extras]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Aún estoy estancado en esta parte y ya no solo es problema de instalar blender sino ya de todo el sistema en general :/
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1213

PostPosted: Sun Jun 18, 2017 1:47 pm    Post subject: Reply with quote

Seguramente podrás avanzar si admites versiones de prueba de idna, metiendo en package.accept_keywords
Code:
dev-python/idna ~amd64

También seguramente encontrarás que tienes que añadir paquetes a package.use y de nuevo a package.accept_keywords.

Todo esto es consecuencia de mezclar versiones estables con las de prueba. Mira si no te convendrá mas eliminar todas las versiones de prueba que hayas instalado y usar la versión estable de blender.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1092

PostPosted: Sun Jun 18, 2017 4:09 pm    Post subject: Reply with quote

emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5
Algo claramente te falla en el portage, porque ese ebuild existe.
En este directorio
Code:
ls /usr/portage/dev-python/idna
idna-2.0.ebuild  idna-2.5.ebuild  Manifest  metadata.xml

has probado a hacer un emerge portage?
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Sun Jun 18, 2017 11:05 pm    Post subject: Reply with quote

quilosaq wrote:
Seguramente podrás avanzar si admites versiones de prueba de idna, metiendo en package.accept_keywords
Code:
dev-python/idna ~amd64

También seguramente encontrarás que tienes que añadir paquetes a package.use y de nuevo a package.accept_keywords.


Después de hacer ésto, y algunas configuraciones más, logré hacer que no salgan más mensajes de esa índole y ahora podré a proceder a instalar lo que necesito

quilosaq wrote:
Todo esto es consecuencia de mezclar versiones estables con las de prueba. Mira si no te convendrá mas eliminar todas las versiones de prueba que hayas instalado y usar la versión estable de blender.


La razón de mezclar versiones es porque el compilador falló al momento de querer instalar blender y por eso recurrí a la guía en donde me dice que debo usar pyhton3.5 y por eso es que salió todo este embrollo.
Con "todo y chiste" me toca descargar 1.5GB de información para instalar blender y no sé cuánto más para actualizar el sistema. En unos días sabré si todo salió bien jejeje


cameta wrote:
emerge: there are no ebuilds to satisfy ">=dev-python/idna-2.5
Algo claramente te falla en el portage, porque ese ebuild existe.
En este directorio
Code:
ls /usr/portage/dev-python/idna
idna-2.0.ebuild  idna-2.5.ebuild  Manifest  metadata.xml

has probado a hacer un emerge portage?


Pues es una instalación limpia de hace unas 2 semanas y un poquito más, incluso hace 3 días ya hice un emerge --sync para actualizar alguna situación por la instalación de blender, pero nada.
Intenté el mismo comando que usaste tú y tengo la misma respuesta:

ls /usr/portage/dev-python/idna:
idna-2.0.ebuild  idna-2.5.ebuild  Manifest  metadata.xml


Así que supongo que también estoy al día en cuanto a portage se refiere, no?
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Mon Jun 26, 2017 12:46 am    Post subject: Reply with quote

Hola amigos :)

Aún tengo problemas al instalar blender y si sigo la guía, más me da problemas a nivel de sistema. Hay alguna forma de poderme hacer con la instalación sin la necesidad de usar la rama de pruebas de ciertas aplicaciones en gentoo?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16612
Location: here

PostPosted: Mon Jun 26, 2017 5:19 am    Post subject: Reply with quote

He creado un parche para llenar la blender-2.72b con ffmpeg-3 (google translator sorry)
Code:
# mkdir -p /etc/portage/patches/media-gfx/blender-2.72b
# cd /etc/portage/patches/media-gfx/blender-2.72b
# wget "https://609716.bugs.gentoo.org/attachment.cgi?id=477990" -O blender-2.72b-ffmpeg3.patch
# emerge =media-gfx/blender-2.72b-r4

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 161

PostPosted: Mon Jun 26, 2017 5:45 am    Post subject: Reply with quote

fedeliallalinea wrote:
He creado un parche para llenar la blender-2.72b con ffmpeg-3 (google translator sorry)
Code:
# mkdir -p /etc/portage/patches/media-gfx/blender-2.72b
# cd /etc/portage/patches/media-gfx/blender-2.72b
# wget "https://609716.bugs.gentoo.org/attachment.cgi?id=477990" -O blender-2.72b-ffmpeg3.patch
# emerge =media-gfx/blender-2.72b-r4


Woooooow, it worked. Thank you very much :)
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1092

PostPosted: Tue Jun 27, 2017 11:19 am    Post subject: Reply with quote

Me alegro de que te hayan podido ayudar.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum