Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Deepin Desktop
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 7:34 am    Post subject: Deepin Desktop Reply with quote

Bonjour,

Toujours dans la découverte de Gentoo, je suis assez fan mais il y a encore pas mal de choses que je ne comprends pas bien.

Je cherche maintenant à installer l'environnement de bureau Deepin pour l'essayer à côté d'Xfce. Dans l'idée, je voudrais créeer un nouveau compte utilisateur sous Deepin, le temps de choisir un environnement ou l'autre.

Le wiki propose d'utiliser le mot-clé "~amd64" de manière globale pour cela (dans /etc/portage/make.conf) :? J'espère que ça ne cassera pas tout.
Ceci dit, ne serait-ce que pour l'installation initiale, ça semble poser problème :

Pour ce qui est du global, l'ajout de ~amd64 semble poser problème à une dépendance de libreoffice-bin (peut-être résolue si je compile la suite libreoffice sur place, mais il parait que c'est très long... ?).
En revanche, cette erreur ne bloque pas le reste.
Code:
[anard@gentoo ~]$ sudo emerge -auDN @world
Mot de passe :
These are the packages that would be merged, in order:
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/boost:0

  (dev-libs/boost-1.74.0-r1:0/1.74.0::gentoo, ebuild scheduled for merge) USE="bzip2 icu nls threads zlib -context -debug -doc -lzma -mpi -numpy -python -static-libs -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 -python3_9" conflicts with
    dev-libs/boost:0/1.72.0= required by (dev-util/mdds-1.6.0:1/1.5::gentoo, installed) USE="openmp -doc -test -valgrind" ABI_X86="(64)"
                  ^^^^^^^^^^
    dev-libs/boost:0/1.72.0= required by (dev-libs/libixion-0.15.0:0/0.15::gentoo, installed) USE="threads -debug -python" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8"
                  ^^^^^^^^^^
    dev-libs/boost:0/1.72.0 required by (app-office/libreoffice-bin-6.4.6.2-r2:0/0::gentoo, installed) USE="-gnome -java -kde" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_7"
                  ^^^^^^^^^
    dev-libs/boost:0/1.72.0= required by (dev-cpp/libcmis-0.5.2-r1:0.5/0.5::gentoo, installed) USE="-man -static-libs -test -tools" ABI_X86="(64)"
                  ^^^^^^^^^^
    >=dev-libs/boost-1.72.0:0/1.72.0=[nls] required by (app-office/libreoffice-bin-6.4.6.2-r2:0/0::gentoo, installed) USE="-gnome -java -kde" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_7"
                           ^^^^^^^^^^     
    dev-libs/boost:0/1.72.0=[zlib(+)] required by (dev-libs/liborcus-0.15.4:0/0.15::gentoo, installed) USE="spreadsheet-model -python -tools" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8"
                  ^^^^^^^^^^         

dev-util/boost-build:0

  (dev-util/boost-build-1.74.0:0/0::gentoo, ebuild scheduled for merge) USE="-examples" ABI_X86="(64)" conflicts with
    =dev-util/boost-build-1.72* required by (dev-libs/boost-1.72.0-r2:0/1.72.0::gentoo, installed) USE="bzip2 icu nls threads zlib -context -debug -doc -lzma -mpi -numpy -python -static-libs -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8"
    ^                     ^^^^^

Nothing to merge; quitting.
[anard@gentoo ~]$


Pour ce qui est de deepin lui-même, il semble rechercher une version plus ancienne de qtgui, bloquant l'installation de dde-meta :
Code:
[anard@gentoo ~]$ emerge -pv dde-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~dev-qt/qtgui-5.15.0".
(dependency required by "dev-qt/qtxcb-private-headers-5.15.0::deepin" [ebuild])
(dependency required by "dev-qt/dde-qt5platform-plugins-5.0.12::deepin" [ebuild])
(dependency required by "dde-base/dde-qt5integration-5.1.0.4::deepin" [ebuild])
(dependency required by "dde-base/dde-dock-5.1.0.11-r1::deepin" [ebuild])
(dependency required by "dde-base/dde-session-ui-5.3.0.2::deepin" [ebuild])
(dependency required by "dde-base/dde-meta-20::deepin" [ebuild])
(dependency required by "dde-meta" [argument])
[anard@gentoo ~]$ emerge -s dev-qt/qtgui
 
[ Results for search key : dev-qt/qtgui ]
Searching...

*  dev-qt/qtgui
      Latest version available: 5.15.1-r1
      Latest version installed: 5.15.1-r1
      Size of files: 48 978 KiB
      Homepage:      https://www.qt.io/
      Description:   The GUI module and platform plugins for the Qt5 framework
      License:       || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3

[ Applications found : 1 ]
[anard@gentoo ~]$


Y a-t-il une syntaxe qui me permettrait d'activer le mot-clé "~amd64" uniquement pour dde-meta ET toutes ses dépendances... sauf qtgui ?
Sinon, quelles solutions s'offrent à moi ?

Merci beaucoup.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 7:43 am    Post subject: Reply with quote

Bonjour,

Pourrais-tu nous donner la sortie de "emerge --info" afin de savoir si tu es en full stable, testing, mixte, ... ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 7:50 am    Post subject: Reply with quote

Bien sûr.

Code:
[anard@gentoo ~]$ emerge --info
Portage 3.0.8 (python 3.7.9-final-0, default/linux/amd64/17.1/desktop, gcc-10.2.0, glibc-2.32-r2, 5.8.13-gentoo-x86_64 x86_64)
=================================================================
System uname: Linux-5.8.13-gentoo-x86_64-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T6400_@_2.00GHz-with-gentoo-2.7
KiB Mem:     4024648 total,    841476 free
KiB Swap:    2097148 total,   1760204 free
Timestamp of repository gentoo: Thu, 08 Oct 2020 21:00:01 +0000
Head commit of repository gentoo: 66f8fb307e3b4765903b4010b9801ea37bcf8bd1
Head commit of repository deepin: 7cbf1bf986c07987158c32b2e8e854bf77f39798

sh bash 5.0_p18
ld GNU ld (Gentoo 2.35.1 p1) 2.35.1
app-shells/bash:          5.0_p18::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          3.7.9::gentoo, 3.8.6::gentoo, 3.9.0::gentoo
dev-util/cmake:           3.18.4::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.35.1::gentoo
sys-devel/gcc:            10.2.0-r2::gentoo
sys-devel/gcc-config:     2.3.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r2::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

deepin
    location: /usr/local/overlay/deepin
    sync-type: git
    sync-uri: https://github.com/zhtengw/deepin-overlay.git
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@BINARY-REDISTRIBUTABLE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=core2 -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus dri dts dvd dvdr elogind emboss encode exif flac fortran fr gdbm gif gpm gtk gui iconv icu ipv6 jpeg lcms libglvnd libnotify libtirpc mad matroska mng mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt5 readline sdl seccomp spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="libinput synaptics" KERNEL="linux" L10N="fr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

[anard@gentoo ~]$

_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 8:15 am    Post subject: Reply with quote

En effet, en testing, qtgui est en version 5.15.1 et pas 5.15.0
D'où vient l'ebuild de dde-meta ? Je ne le vois pas dans portage.

Apparemment cet ebuild doit être mis à jour.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 8:27 am    Post subject: Reply with quote

Oui j'ai dû rajouter un dépôt
Code:
[anard@gentoo ~]$ cat /etc/portage/repos.conf/deepin.conf
[deepin]
location = /usr/local/overlay/deepin
sync-type = git
sync-uri = https://github.com/zhtengw/deepin-overlay.git
auto-sync = yes
[anard@gentoo ~]$


Pour ce qui est de qtgui, je ne peux pas le forcer à utiliser la version que demande dde-meta ?
Aussi pour pas mal d'autres raisons, j'aimerais que ~amd64 ne soit pas appliqué à l'ensemble des paquets. Par exemple, il découvre une nouvelle version de gentoo-sources tous les jours !
Désolé, je suis vraiment débutant en la matière (jusque là, j'ai surtout utilisé [X]Ubuntu). :)
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 8:40 am    Post subject: Reply with quote

Pour la version de QT : non, il faut adapter l'ebuild de dde-meta pour qu'il utilise la bonne version de QT, ou alors tu dois récupérer à la main les anciens ebuilds de cette version de QT et les mettre dans un overlay local.

Tu peux passer en "stable" en elevant "~amd64" de ACCEPT_KEYWORDS, puis recompiler tout ce qui est nécess.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 9:04 am    Post subject: Reply with quote

Merci. C'est embêtant, car finalement je ne veux ~amd64 que pour dde-meta et ses dépendances.
Sans lui, j'obtiens ça :
Code:
[anard@gentoo ~]$ sudo emerge -apv dde-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "dde-meta" have been masked.
!!! One of the following masked packages is required to complete your request:
- dde-base/dde-meta-20::deepin (masked by: ~amd64 keyword)
- dde-base/dde-meta-15.11::deepin (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

[anard@gentoo ~]$


J'avais essayé d'ajouter dans /etc/portage/package.accept-keywords
Code:
dde-base/dde-meta ~amd64


Mais évidemment, les dépendances en ont besoin également, j'imagine qu'il faudrait noter beaucoup de paquets dans ce cas...
Ne searit-il pas possible de noter la base plutôt que le paquet ? Je veux dire quelque chose comme ça :
Code:
dde-base/* ~amd64
dde-extra/* ~amd64

_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 10:00 am    Post subject: Reply with quote

Utilise l'option --autounmask-write

EDIT: changement de lien
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Fri Oct 09, 2020 10:19 am    Post subject: Reply with quote

Merci, j'ai essayé (avec --pretend), il a pas mal de choses à écrire apparemment...
Mais surtout dans mes dernières recherches, j'ai cru comprendre que je ne trouverai pas qtgui-5.15.0 dans les dépôts de gentoo, avec ou sans l'option "~amd64" :
https://packages.gentoo.org/packages/dev-qt/qtgui
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 11:14 am    Post subject: Reply with quote

En effet,

Portage contient un certain nombre de versions, parmi lesquelles certaines sont marquées "stables", d'autres "testing", et d'autres encore sont sans keyword (dont entre autre les "live", en -9999).
En fonction des mainteneurs et des contraintes techniques, de disponibilité, ou d'incompatibilité, de bugs, sécurité, ... certaines versions intermédiaires sont conservées ou effacées (comme la 15.1.01 par exemple).
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Sun Oct 25, 2020 3:30 pm    Post subject: Reply with quote

La problème de version de qtgui a été reglé, mais toujours impossible d'installer dde-meta :x
Ca semble être un problème d'autorisations au moment d'installer deepin-grub2-themes. J'ai désactivé le use flag "grub" pour dde-meta sans résultat :

Code:

anard@gentoo-imack ~ $ sudo emerge -av dde-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] acct-group/plugdev-0::gentoo  0 KiB
[ebuild  N     ] net-wireless/wireless-regdb-20190603::gentoo  0 KiB
[ebuild  N     ] net-dialup/ppp-scripts-0::gentoo  0 KiB
[ebuild  N    ~] dde-extra/deepin-grub2-themes-1.0.0::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-sound-theme-15.10.6::deepin  0 KiB
[ebuild  N     ] dev-lang/luajit-2.0.5-r2:2::gentoo  USE="-lua52compat -static-libs" 0 KiB
[ebuild  N     ] sys-apps/i2c-tools-4.1-r1::gentoo  USE="-perl -python -static-libs" PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB
[ebuild  N    ~] dde-base/dde-account-faces-1.0.11::deepin  0 KiB
[ebuild  N     ] sys-auth/nss-myhostname-0.3-r1::gentoo  0 KiB
[ebuild  N     ] dev-lang/go-bootstrap-1.13.6::gentoo  USE="(-big-endian)" 0 KiB
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.74.0:5/5.74::gentoo  USE="-doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kf-env-5:5::gentoo  0 KiB
[ebuild  N    ~] x11-libs/gsettings-qt-0.2::deepin  USE="-test" 0 KiB
[ebuild  N    ~] dde-base/dde-qt-dbus-factory-5.3.0.19::deepin  0 KiB
[ebuild  N     ] dev-lang/go-1.15.3:0/1.15.3::gentoo  22 476 KiB
[ebuild  N     ] sys-auth/polkit-qt-0.113.0::gentoo  USE="-debug" 0 KiB
[ebuild  N     ] dev-libs/libnl-3.5.0:3::gentoo  USE="debug threads -python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB
[ebuild  N     ] dev-util/lxqt-build-tools-0.7.0::gentoo  0 KiB
[ebuild  N     ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-libs/libdbusmenu-qt-0.9.3_pre20160218-r3::gentoo  0 KiB
[ebuild  N    ~] dde-base/udisks2-qt5-5.0.5::deepin  0 KiB
[ebuild  N    ~] x11-apps/xcur2png-0.7.1::deepin  0 KiB
[ebuild  N    ~] media-gfx/blur-effect-1.1.3::deepin  0 KiB
[ebuild  N     ] app-misc/jq-1.6-r3::gentoo  USE="-oniguruma -static-libs" 0 KiB
[ebuild  N     ] net-libs/libndp-1.7::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] net-misc/mobile-broadband-provider-info-20190618::gentoo  USE="-test" 0 KiB
[ebuild  N     ] net-dialup/ppp-2.4.8:0/2.4.8::gentoo  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -libressl -radius" 0 KiB
[ebuild  N     ] sys-libs/slang-2.3.2::gentoo  USE="pcre png readline zlib -cjk -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-perl/File-chdir-0.101.100::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-perl/Unicode-UTF8-0.620.0::gentoo  USE="-test" 0 KiB
[ebuild  N    ~] dde-base/deepin-icon-theme-2020.09.25::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-gtk-theme-2020.06.10::deepin  0 KiB
[ebuild  N     ] dev-python/python-distutils-extra-2.45::gentoo  USE="-test" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] net-misc/socat-1.7.3.4::gentoo  USE="ipv6 readline ssl tcpd -bindist -libressl" 0 KiB
[ebuild  N     ] dev-libs/jemalloc-5.2.1:0/2::gentoo  USE="-debug -hardened -lazy-lock -prof -static-libs -stats -xmalloc" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N    ~] dde-extra/screensaver-pp-0.0.4::deepin  0 KiB
[ebuild  N     ] app-i18n/uchardet-0.0.6-r2::gentoo  USE="-static-libs -test" CPU_FLAGS_X86="sse2" 0 KiB
[ebuild  N     ] dev-libs/tinyxml2-8.0.0:0/8::gentoo  USE="-test" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-lang/coffee-script-1.9.3-r1::gentoo  USE="-doc -examples" 0 KiB
[ebuild  N     ] sys-libs/cracklib-2.9.7::gentoo  USE="nls (split-usr) zlib -python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB
[ebuild  N     ] virtual/perl-Module-Load-0.340.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-1.170.100_rc-r10::gentoo  0 KiB
[ebuild  N     ] virtual/perl-if-0.60.800-r3::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Archive-Tar-2.320.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Test-Simple-1.302.162::gentoo  0 KiB
[ebuild  N     ] dev-lang/swig-4.0.2::gentoo  USE="pcre -ccache -doc" 0 KiB
[ebuild  N     ] kde-frameworks/ki18n-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" PYTHON_SINGLE_TARGET="python3_7 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] dev-qt/linguist-tools-5.15.1:5/5.15::gentoo  USE="-debug -qml -test" 0 KiB
[ebuild  N     ] kde-frameworks/breeze-icons-5.74.0:5/5.74::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-qt/qtconcurrent-5.15.1:5/5.15::gentoo  USE="-debug -test" 0 KiB
[ebuild  N    ~] dev-go/deepin-go-lib-5.6.0.2::deepin  0 KiB
[ebuild  N     ] kde-frameworks/karchive-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N    ~] dev-go/go-gir-generator-2.0.2-r1::deepin  0 KiB
[ebuild  N     ] dev-qt/qtsql-5.15.1:5/5.15.1::gentoo  USE="sqlite -debug -freetds -mysql (-oci8) -odbc -postgres -test" 0 KiB
[ebuild  N     ] kde-frameworks/kguiaddons-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N    ~] dde-base/dde-network-utils-5.1.0101.2::deepin  0 KiB
[ebuild  N     ] dev-qt/qtquickcontrols-5.15.1:5/5.15::gentoo  USE="widgets -debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtopengl-5.15.1:5/5.15::gentoo  USE="-debug -gles2-only -test" 0 KiB
[ebuild  N    #] gnome-base/libgnome-keyring-3.12.0-r1::gentoo  USE="introspection -debug -vala" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N    ~] dev-qt/gio-qt-0.0.9::deepin  USE="-doc -test" 0 KiB
[ebuild  N    ~] dev-go/go-x11-client-0.6.2::deepin  0 KiB
[ebuild  N     ] dev-libs/libqtxdg-3.5.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] media-video/ffmpegthumbnailer-2.2.0-r1::gentoo  USE="gtk jpeg png -gnome -test" 0 KiB
[ebuild  N     ] gnome-base/libgtop-2.40.0-r1:2/11::gentoo  USE="introspection" 0 KiB
[ebuild  N     ] kde-frameworks/kidletime-5.74.0:5/5.74::gentoo  USE="X -debug -doc -xscreensaver" 0 KiB
[ebuild  N     ] dev-qt/qtprintsupport-5.15.1:5/5.15::gentoo  USE="cups -debug -gles2-only -test" 0 KiB
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.15.1:5/5.15::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtwayland-5.15.1:5/5.15::gentoo  USE="X -debug -test -vulkan" 0 KiB
[ebuild  N     ] dev-libs/plasma-wayland-protocols-1.1.1::gentoo  USE="-debug" 0 KiB
[ebuild  N    ~] sys-apps/lshw-02.19.2b::deepin  USE="gtk -sqlite -static" 0 KiB
[ebuild  N     ] dev-libs/newt-0.52.21-r1::gentoo  USE="gpm nls -tcl" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] net-libs/libmbim-1.18.0::gentoo  USE="udev -static-libs" 0 KiB
[ebuild  N     ] sys-power/acpid-2.0.32-r2::gentoo  USE="(-selinux)" 0 KiB
[ebuild  N     ] dev-perl/Config-Tiny-2.230.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-perl/XML-SAX-1.0.0::gentoo  0 KiB
[ebuild  N     ] dev-perl/Capture-Tiny-0.480.0::gentoo  USE="-examples -test" 0 KiB
[ebuild  N     ] dev-perl/FFI-CheckLib-0.250.0::gentoo  USE="-examples -test" 0 KiB
[ebuild  N     ] dev-perl/Path-Tiny-0.104.0::gentoo  USE="-minimal -test" 0 KiB
[ebuild  N     ] gnome-extra/mousetweaks-3.32.0::gentoo  0 KiB
[ebuild  N     ] dev-qt/qtxcb-private-headers-5.15.1:5/5.15::deepin  USE="-debug -test" 0 KiB
[ebuild  N     ] gnome-base/libglade-2.6.4-r3:2.0::gentoo  USE="-static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-libs/netpbm-10.76.00::gentoo  USE="X jpeg png tiff xml zlib -doc -jbig -postscript -rle -static-libs (-svga)" CPU_FLAGS_X86="sse2" 0 KiB
[ebuild  N     ] x11-apps/appres-1.0.5::gentoo  0 KiB
[ebuild  N     ] media-libs/libass-0.14.0:0/9::gentoo  USE="fontconfig harfbuzz -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-libs/libzen-0.4.38::gentoo  USE="-doc -static-libs" 0 KiB
[ebuild  N     ] dev-libs/libisoburn-1.5.2::gentoo  USE="acl readline xattr zlib -debug -external-filters -external-filters-setuid -frontend-optional -launch-frontend -launch-frontend-setuid -libedit -static-libs" 0 KiB
[ebuild  N    ~] app-misc/ddcutil-0.9.9::gentoo  USE="X -drm -introspection -usb-monitor -user-permissions" VIDEO_CARDS="-nvidia" 0 KiB
[ebuild  N     ] dev-libs/libpwquality-1.4.2::gentoo  USE="pam (split-usr) -python -static-libs" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] app-admin/openrc-settingsd-1.0.1-r1::gentoo  USE="-systemd" 0 KiB
[ebuild  N     ] gnome-extra/zenity-3.32.0::gentoo  USE="libnotify -debug -webkit" 0 KiB
[ebuild  N     ] gnome-base/gconf-3.2.6-r5:2::gentoo  USE="introspection policykit -debug -ldap" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_7 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] dev-qt/qtscript-5.15.1:5/5.15::gentoo  USE="jit -debug -scripttools -test" 0 KiB
[ebuild  N     ] dev-qt/qtsensors-5.15.1:5/5.15::gentoo  USE="-debug -qml -test" 0 KiB
[ebuild  N     ] kde-frameworks/kitemmodels-5.74.0:5/5.74::gentoo  USE="qml -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/attica-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N     ] dev-python/m2crypto-0.36.0-r1::gentoo  USE="-libressl" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 (-python3_9)" 0 KiB
[ebuild  N     ] kde-frameworks/kcoreaddons-5.74.0:5/5.74::gentoo  USE="nls -debug -doc (-fam) -test" 0 KiB
[ebuild  N     ] kde-frameworks/kconfig-5.74.0:5/5.74::gentoo  USE="dbus nls -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.74.0:5/5.74::gentoo  USE="nls -debug -designer -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kwindowsystem-5.74.0:5/5.74::gentoo  USE="X nls -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kdoctools-5.74.0:5/5.74::gentoo  USE="nls -debug -test" 0 KiB
[ebuild  N     ] kde-frameworks/kdbusaddons-5.74.0:5/5.74::gentoo  USE="X nls -debug -doc -test" 0 KiB
[ebuild  N    ~] dde-base/dtkcore-5.2.2.15:0/5.2.2.15::deepin  0 KiB
[ebuild  N     ] dev-qt/qtmultimedia-5.15.1:5/5.15::gentoo  USE="alsa gstreamer widgets -debug -gles2-only -openal -pulseaudio -qml -test" 0 KiB
[ebuild  N     ] kde-frameworks/kitemviews-5.74.0:5/5.74::gentoo  USE="nls -debug -designer -doc -test" 0 KiB
[ebuild  N    ~] dev-go/go-dbus-generator-0.6.6-r1::deepin  0 KiB
[ebuild  N     ] kde-frameworks/kcodecs-5.74.0:5/5.74::gentoo  USE="nls -debug -doc -test" 0 KiB
[ebuild  N    ~] dev-go/go-dbus-factory-1.7.0.6::deepin  0 KiB
[ebuild  N     ] kde-frameworks/kwayland-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N     ] kde-plasma/kdecoration-5.19.5:5::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtquickcontrols2-5.15.1:5/5.15::gentoo  USE="-debug -test -widgets" 0 KiB
[ebuild  N     ] kde-frameworks/solid-5.74.0:5/5.74::gentoo  USE="nls -debug -doc -test" 0 KiB
[ebuild  N     ] net-wireless/crda-4.14::gentoo  USE="-gcrypt -libressl" 0 KiB
[ebuild  N     ] net-libs/libqmi-1.22.2:0/5.4::gentoo  USE="mbim -doc -static-libs" 0 KiB
[ebuild  N    ~] app-accessibility/onboard-1.4.1.7::deepin  PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB
[ebuild  N    ~] dev-libs/disomaster-5.0.4::deepin  0 KiB
[ebuild  N     ] media-libs/libmediainfo-20.08::gentoo  USE="-curl -doc -mms -static-libs" 0 KiB
[ebuild  N     ] x11-misc/xscreensaver-5.44-r2::gentoo  USE="gdk-pixbuf gtk jpeg locking opengl pam perl -caps -gdm -new-login -offensive (-selinux) -suid -xinerama" 0 KiB
[ebuild  N     ] media-video/mpv-0.32.0-r1::gentoo  USE="X alsa cdda cli dvd egl iconv jpeg lcms libass libmpv lua luajit opengl uchardet xv zlib (-aqua) -archive -bluray (-coreaudio) -cplugins (-cuda) -debug -doc -drm -dvb -gamepad -gbm -jack -javascript -libcaca -openal -oss -pulseaudio (-raspberry-pi) -rubberband -samba -sdl (-selinux) -test -tools -vaapi -vdpau -vulkan -wayland -zimg" PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB
[ebuild  N    ~] x11-libs/bamf-0.5.4-r1::deepin  USE="introspection -doc -static-libs" 0 KiB
[ebuild  N     ] dev-qt/designer-5.15.1:5/5.15::gentoo  USE="-debug -declarative -test -webkit" 0 KiB
[ebuild  N     ] kde-frameworks/sonnet-5.74.0:5/5.74::gentoo  USE="hunspell nls -aspell -debug -designer -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kcrash-5.74.0:5/5.74::gentoo  USE="nls -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/knotifications-5.74.0:5/5.74::gentoo  USE="X dbus nls -debug -doc -phonon -speech" 0 KiB
[ebuild  N     ] kde-frameworks/kpackage-5.74.0:5/5.74::gentoo  USE="-debug -doc -man -test" 0 KiB
[ebuild  N     ] kde-frameworks/kcompletion-5.74.0:5/5.74::gentoo  USE="nls -debug -designer -doc -test" 0 KiB
[ebuild  N    ~] dde-base/dtkgui-5.2.2.15:0/5.2.2.15::deepin  0 KiB
[ebuild  N    ~] dev-go/dbus-factory-3.1.17-r2::deepin  0 KiB
[ebuild  N     ] kde-frameworks/kirigami-5.74.0-r1:5/5.74::gentoo  USE="-debug -examples -test" 0 KiB
[ebuild  N     ] net-misc/modemmanager-1.10.0:0/1::gentoo  USE="elogind introspection policykit qmi udev -mbim -systemd -vala" 0 KiB
[ebuild  N     ] net-wireless/wpa_supplicant-2.9-r2::gentoo  USE="dbus fils hs2-0 mbo mesh qt5 readline -ap -bindist -broadcom-sta -eap-sim -eapol-test -fasteap -libressl -macsec -p2p -privsep (-ps3) (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps" 0 KiB
[ebuild  N    ~] dev-qt/dde-qt5platform-plugins-5.0.12::deepin  0 KiB
[ebuild  N    ~] dde-extra/deepin-screensaver-5.0.4::deepin  USE="bubbles" 0 KiB
[ebuild  N    ~] dde-base/deepin-anything-5.0.1::deepin  USE="-modules" 0 KiB
[ebuild  N     ] kde-plasma/kwayland-server-5.19.5:5::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kjobwidgets-5.74.0:5/5.74::gentoo  USE="X nls -debug -doc -test" 0 KiB
[ebuild  N    ~] dde-base/dtkwidget-5.2.2.17:0/5.2.2.17::deepin  0 KiB
[ebuild  N     ] kde-frameworks/kservice-5.74.0:5/5.74::gentoo  USE="man -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kglobalaccel-5.74.0:5/5.74::gentoo  USE="nls -debug -doc -test" 0 KiB
[ebuild  N    ~] dde-base/dde-api-5.3.0.4::deepin  0 KiB
[ebuild  N     ] net-misc/networkmanager-1.26.0-r1::gentoo  USE="bluetooth elogind introspection modemmanager ncurses nss policykit ppp wext wifi -audit -connection-sharing -dhclient -dhcpcd -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -systemd -teamd -test -vala" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N    ~] dde-base/dde-qt5integration-5.1.0.9::deepin  0 KiB
[ebuild  N    ~] dde-base/dde-polkit-agent-5.3.0.2::deepin  0 KiB
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.74.0:5/5.74::gentoo  USE="-debug -doc -teamd -test" 0 KiB
[ebuild  N    ~] dde-extra/deepin-terminal-5.2.35::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-wallpapers-1.6.14::deepin  0 KiB
[ebuild  N    ~] media-video/deepin-movie-reborn-5.7.6.152:3::deepin  0 KiB
[ebuild  N    ~] dde-extra/deepin-shortcut-viewer-5.0.2::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-desktop-base-2020.04.12::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-menu-5.0.1::deepin  0 KiB
[ebuild  N    ~] dde-base/dpa-ext-gnomekeyring-5.0.4::deepin  0 KiB
[ebuild  N    ~] dde-base/deepin-desktop-schemas-5.8.0.20::deepin  0 KiB
[ebuild  N    ~] x11-wm/deepin-metacity-3.22.24::deepin  USE="-test -xinerama" 0 KiB
[ebuild  N     ] kde-frameworks/kauth-5.74.0:5/5.74::gentoo  USE="nls policykit -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.74.0:5/5.74::gentoo  USE="man -debug -designer -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kiconthemes-5.74.0:5/5.74::gentoo  USE="-debug -designer -doc -test" 0 KiB
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.19.5:5::gentoo  USE="-debug" 0 KiB
[ebuild  N     ] kde-frameworks/kxmlgui-5.74.0-r1:5/5.74::gentoo  USE="-debug -designer -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/ktextwidgets-5.74.0:5/5.74::gentoo  USE="-debug -designer -doc -speech -test" 0 KiB
[ebuild  N     ] kde-frameworks/kwallet-5.74.0:5/5.74::gentoo  USE="man -debug -doc -gpg -test" 0 KiB
[ebuild  N     ] kde-frameworks/kbookmarks-5.74.0:5/5.74::gentoo  USE="nls -debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kio-5.74.1-r1:5/5.74::gentoo  USE="X acl handbook kwallet -debug -designer -doc -kerberos -test" 0 KiB
[ebuild  N     ] kde-frameworks/kinit-5.74.0:5/5.74::gentoo  USE="X caps man -debug" 0 KiB
[ebuild  N     ] kde-frameworks/kded-5.74.0:5/5.74::gentoo  USE="man -debug" 0 KiB
[ebuild  N     ] kde-frameworks/kdeclarative-5.74.0-r1:5/5.74::gentoo  USE="-debug -doc" 0 KiB
[ebuild  N     ] kde-frameworks/knewstuff-5.74.0:5/5.74::gentoo  USE="-debug -doc" 0 KiB
[ebuild  N     ] kde-plasma/kactivitymanagerd-5.19.5:5::gentoo  USE="-debug" 0 KiB
[ebuild  N     ] kde-frameworks/kcmutils-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/kactivities-5.74.0:5/5.74::gentoo  USE="-debug -doc -test" 0 KiB
[ebuild  N     ] kde-frameworks/frameworkintegration-5.74.0:5/5.74::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] kde-frameworks/plasma-5.74.0-r1:5/5.74::gentoo  USE="X -debug -doc -gles2-only -test -wayland" 0 KiB
[ebuild  N     ] dev-perl/File-Which-1.220.0::gentoo  USE="pwhich -test" 0 KiB
[ebuild  N     ] dev-perl/App-pwhich-1.160.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-perl/Alien-Build-2.230.0::gentoo  USE="-examples -test -zip" 0 KiB
[ebuild  N     ] dev-perl/Alien-Libxml2-0.160.0::gentoo  USE="-test" 0 KiB
[ebuild  N     ] dev-perl/XML-LibXML-2.20.100::gentoo  USE="-examples -minimal -test" 0 KiB
[ebuild  N    ~] dde-base/deepin-gettext-tools-1.0.8::deepin  0 KiB
[ebuild  N     ] kde-plasma/kscreenlocker-5.19.5:5::gentoo  USE="pam -debug -test" 0 KiB
[ebuild  N     ] kde-plasma/breeze-5.19.5-r1:5::gentoo  USE="X -debug -wayland" 0 KiB
[ebuild  N     ] kde-plasma/kwin-5.19.5-r1:5::gentoo  USE="handbook -caps -debug -gles2-only -multimedia -test" 0 KiB
[ebuild  N     ] kde-plasma/libkworkspace-5.19.5:5::gentoo  USE="-debug -test" 0 KiB
[ebuild  N     ] kde-plasma/kde-cli-tools-5.19.5:5::gentoo  USE="X handbook -debug -kdesu -test" 0 KiB
[ebuild  N    ~] x11-wm/dde-kwin-5.1.0.27::deepin  USE="-debug" 0 KiB
[ebuild  N    ~] virtual/dde-wm-0::deepin  USE="kwin minimal -mutter" 0 KiB
[ebuild  N    ~] dde-base/dde-daemon-5.11.0.21::deepin  USE="bluetooth elogind grub -systemd" 0 KiB
[ebuild  N    ~] dde-base/startdde-5.5.0.10::deepin  0 KiB
[ebuild  N    ~] dde-base/dde-dock-5.2.0.24::deepin  0 KiB
[ebuild  N    ~] dde-base/dde-launcher-5.3.0.22::deepin  0 KiB
[ebuild  N    ~] dde-base/dde-clipboard-5.0.0100.1::deepin  0 KiB
[ebuild  N    ~] dde-base/dde-control-center-5.3.0.11::deepin  USE="-redshift -systemd" 0 KiB
[ebuild  N    ~] dde-base/dde-file-manager-5.1.1.25-r1::deepin  USE="screensaver -avfs -samba" 0 KiB
[ebuild  N    ~] dde-base/dde-session-shell-5.3.0.5::deepin  USE="elogind -systemd" 0 KiB
[ebuild  N    ~] dde-base/dde-session-ui-5.3.0.18::deepin  USE="elogind -systemd" 0 KiB
[ebuild  N    ~] dde-base/dde-meta-20::deepin  USE="elogind kwin policykit terminal -extra -grub -manual -multimedia -mutter -plymouth -screensaver -systemd -terminal-old -turbo" 0 KiB

Total: 195 packages (195 new), Size of downloads: 22 476 KiB

Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Running pre-merge checks for acct-group/plugdev-0

>>> Running pre-merge checks for dde-extra/deepin-grub2-themes-1.0.0
 * Your boot partition was detected as being mounted at /boot.
 * Files will be installed there for deepin-grub2-themes to function correctly.

>>> Running pre-merge checks for sys-power/acpid-2.0.32-r2
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     5.4.72-gentoo-testing
 * Checking for suitable kernel configuration options...                 [ ok ]

>>> Running pre-merge checks for app-misc/ddcutil-0.9.9
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     5.4.72-gentoo-testing
 * Checking for suitable kernel configuration options...                 [ ok ]

>>> Running pre-merge checks for net-misc/networkmanager-1.26.0-r1
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     5.4.72-gentoo-testing
 * Checking for SYSFS_DEPRECATED support ...                             [ ok ]

>>> Emerging (1 of 195) acct-group/plugdev-0::gentoo
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/acct-group/plugdev-0/work
>>> Preparing source in /var/tmp/portage/acct-group/plugdev-0/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/acct-group/plugdev-0/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/acct-group/plugdev-0/work ...
>>> Source compiled.
>>> Test phase [not enabled]: acct-group/plugdev-0

>>> Install acct-group/plugdev-0 into /var/tmp/portage/acct-group/plugdev-0/image
>>> Completed installing acct-group/plugdev-0 into /var/tmp/portage/acct-group/plugdev-0/image

 * Final size of build directory:  4 KiB
 * Final size of installed tree:  20 KiB


>>> Installing (1 of 195) acct-group/plugdev-0::gentoo
 * checking 1 files for package collisions
>>> Merging acct-group/plugdev-0 to /
gtk-update-icon-cache: The generated cache was invalid.
--- /usr/
--- /usr/lib/
--- /usr/lib/sysusers.d/
>>> /usr/lib/sysusers.d/acct-group-plugdev.conf
gtk-update-icon-cache: The generated cache was invalid.
>>> acct-group/plugdev-0 merged.
>>> Regenerating /etc/ld.so.cache...

>>> Emerging (2 of 195) net-wireless/wireless-regdb-20190603::gentoo
 * wireless-regdb-2019.06.03.tar.xz BLAKE2B SHA512 size ;-) ...          [ ok ]
>>> Unpacking source...
>>> Unpacking wireless-regdb-2019.06.03.tar.xz to /var/tmp/portage/net-wireless/wireless-regdb-20190603/work
>>> Source unpacked in /var/tmp/portage/net-wireless/wireless-regdb-20190603/work
>>> Preparing source in /var/tmp/portage/net-wireless/wireless-regdb-20190603/work/wireless-regdb-2019.06.03 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-wireless/wireless-regdb-20190603/work/wireless-regdb-2019.06.03 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-wireless/wireless-regdb-20190603/work/wireless-regdb-2019.06.03 ...
 * Recompiling regulatory.bin from db.txt would break CRDA verify. Installing unmodified binary version.
>>> Source compiled.
>>> Test phase [not enabled]: net-wireless/wireless-regdb-20190603

>>> Install net-wireless/wireless-regdb-20190603 into /var/tmp/portage/net-wireless/wireless-regdb-20190603/image/
>>> Completed installing net-wireless/wireless-regdb-20190603 into /var/tmp/portage/net-wireless/wireless-regdb-20190603/image/

 * Final size of build directory: 192 KiB
 * Final size of installed tree:  132 KiB


>>> Installing (2 of 195) net-wireless/wireless-regdb-20190603::gentoo
 * checking 7 files for package collisions
>>> Merging net-wireless/wireless-regdb-20190603 to /
gtk-update-icon-cache: The generated cache was invalid.
--- /usr/
--- /usr/share/
--- /usr/share/doc/
>>> /usr/share/doc/wireless-regdb-20190603/
>>> /usr/share/doc/wireless-regdb-20190603/db.txt.bz2
>>> /usr/share/doc/wireless-regdb-20190603/README.bz2
--- /usr/share/man/
--- /usr/share/man/man5/
>>> /usr/share/man/man5/regulatory.bin.5.bz2
--- /usr/lib/
>>> /usr/lib/crda/
>>> /usr/lib/crda/regulatory.bin
--- /lib/
--- /lib/firmware/
>>> /lib/firmware/regulatory.db
>>> /lib/firmware/regulatory.db.p7s
--- /etc/
>>> /etc/wireless-regdb/
>>> /etc/wireless-regdb/pubkeys/
>>> /etc/wireless-regdb/pubkeys/sforshee.key.pub.pem
gtk-update-icon-cache: The generated cache was invalid.
>>> net-wireless/wireless-regdb-20190603 merged.
>>> Regenerating /etc/ld.so.cache...

>>> Emerging (3 of 195) net-dialup/ppp-scripts-0::gentoo
 * ppp-scripts-0.tar.xz BLAKE2B SHA512 size ;-) ...                      [ ok ]
>>> Unpacking source...
>>> Unpacking ppp-scripts-0.tar.xz to /var/tmp/portage/net-dialup/ppp-scripts-0/work
>>> Source unpacked in /var/tmp/portage/net-dialup/ppp-scripts-0/work
>>> Preparing source in /var/tmp/portage/net-dialup/ppp-scripts-0/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-dialup/ppp-scripts-0/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-dialup/ppp-scripts-0/work ...
>>> Source compiled.
>>> Test phase [not enabled]: net-dialup/ppp-scripts-0

>>> Install net-dialup/ppp-scripts-0 into /var/tmp/portage/net-dialup/ppp-scripts-0/image/
>>> Completed installing net-dialup/ppp-scripts-0 into /var/tmp/portage/net-dialup/ppp-scripts-0/image/

 * Final size of build directory: 48 KiB
 * Final size of installed tree:  52 KiB


>>> Installing (3 of 195) net-dialup/ppp-scripts-0::gentoo
 * checking 10 files for package collisions
>>> Merging net-dialup/ppp-scripts-0 to /
gtk-update-icon-cache: The generated cache was invalid.
--- /etc/
>>> /etc/ppp/
>>> /etc/ppp/ip-up.d/
>>> /etc/ppp/ip-up.d/50-initd.sh
>>> /etc/ppp/ip-up.d/30-wins.sh
>>> /etc/ppp/ip-up.d/40-dns.sh
>>> /etc/ppp/ip-down
>>> /etc/ppp/ip-down.d/
>>> /etc/ppp/ip-down.d/50-initd.sh
>>> /etc/ppp/ip-down.d/30-wins.sh
>>> /etc/ppp/ip-down.d/40-dns.sh
>>> /etc/ppp/ip-up
>>> /etc/ppp/ipv6-up -> ip-up
>>> /etc/ppp/ipv6-down -> ip-down
gtk-update-icon-cache: The generated cache was invalid.
>>> net-dialup/ppp-scripts-0 merged.
>>> Regenerating /etc/ld.so.cache...

>>> Emerging (4 of 195) dde-extra/deepin-grub2-themes-1.0.0::deepin
 * deepin-grub2-themes-1.0.0.tar.gz SHA256 SHA512 size ;-) ...           [ ok ]
>>> Unpacking source...
>>> Unpacking deepin-grub2-themes-1.0.0.tar.gz to /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work
>>> Source unpacked in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work
>>> Preparing source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source compiled.
>>> Test phase [not enabled]: dde-extra/deepin-grub2-themes-1.0.0

>>> Install dde-extra/deepin-grub2-themes-1.0.0 into /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/
make -j9 DESTDIR=/var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/ install
install -dm755 /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image//boot/grub/themes
Fixing permission of files...
>>> Completed installing dde-extra/deepin-grub2-themes-1.0.0 into /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/

 * Final size of build directory: 3756 KiB (3.6 MiB)
 * Final size of installed tree:  3704 KiB (3.6 MiB)


>>> Installing (4 of 195) dde-extra/deepin-grub2-themes-1.0.0::deepin
 * checking 25 files for package collisions
>>> Merging dde-extra/deepin-grub2-themes-1.0.0 to /
 * Your boot partition was detected as being mounted at /boot.
 * Files will be installed there for deepin-grub2-themes to function correctly.
gtk-update-icon-cache: The generated cache was invalid.
--- /boot/
--- /boot/grub/
--- /boot/grub/themes/
>>> /boot/grub/themes/deepin/
>>> /boot/grub/themes/deepin/terminal_box_sw.png
>>> /boot/grub/themes/deepin/select_n.png
>>> /boot/grub/themes/deepin/unifont-regular-16.pf2
>>> /boot/grub/themes/deepin/select_se.png
>>> /boot/grub/themes/deepin/select_ne.png
>>> /boot/grub/themes/deepin/terminal_box_w.png
>>> /boot/grub/themes/deepin/background.png
>>> /boot/grub/themes/deepin/select_nw.png
>>> /boot/grub/themes/deepin/select_sw.png
>>> /boot/grub/themes/deepin/theme.txt
>>> /boot/grub/themes/deepin/terminal_box_e.png
>>> /boot/grub/themes/deepin/select_e.png
>>> /boot/grub/themes/deepin/theme_tpl.json
>>> /boot/grub/themes/deepin/terminal_box_ne.png
>>> /boot/grub/themes/deepin/terminal_box_se.png
>>> /boot/grub/themes/deepin/terminal_box_s.png
>>> /boot/grub/themes/deepin/terminal_box_c.png
>>> /boot/grub/themes/deepin/select_s.png
>>> /boot/grub/themes/deepin/background_origin_source
>>> /boot/grub/themes/deepin/terminal_box_nw.png
>>> /boot/grub/themes/deepin/select_c.png
>>> /boot/grub/themes/deepin/terminal_box_n.png
>>> /boot/grub/themes/deepin/theme.tpl
>>> /boot/grub/themes/deepin/select_w.png
!!! failed to properly create symlink:
!!! /boot/grub/themes/deepin/background_source -> background_origin_source
!!! [Errno 1] Operation not permitted: b'background_origin_source' -> b'/boot/grub/themes/deepin/background_source'
!!! Failed to move file.
!!! /boot/grub/themes/deepin/background_source -> background_origin_source

>>> Failed to install dde-extra/deepin-grub2-themes-1.0.0, Log file:

>>>  '/var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/temp/build.log'

 * GNU info directory index is up-to-date.
anard@gentoo-imack ~ $

_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8536
Location: ~Brussels - Belgique

PostPosted: Mon Oct 26, 2020 8:49 am    Post subject: Reply with quote

Est-ce que ta partition /boot est bien montée ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Mon Oct 26, 2020 8:53 am    Post subject: Reply with quote

Merci. Oui :

Code:
anard@gentoo-imack ~ $ sudo mount /dev/sda1
mount: /boot: /dev/sda1 déjà monté sur /boot.
anard@gentoo-imack ~ $ ls -l /boot/
total 157891
-rwxr-xr-x 1 root root   111415 12 oct.  02:19 config-5.4.66-gentoo
-rwxr-xr-x 1 root root   119802 19 oct.  12:03 config-5.4.66-gentoo-testing
-rwxr-xr-x 1 root root   116776 18 oct.  13:30 config-5.4.66-gentoo-x86_64
-rwxr-xr-x 1 root root   211149 19 oct.  13:41 config-5.4.72-gentoo-maximal
-rwxr-xr-x 1 root root   149689 26 oct.  08:11 config-5.4.72-gentoo-minimal
-rwxr-xr-x 1 root root   149689 26 oct.  07:56 config-5.4.72-gentoo-minimal.old
-rwxr-xr-x 1 root root   183001 25 oct.  17:25 config-5.4.72-gentoo-testing
-rwxr-xr-x 1 root root   182979 25 oct.  17:07 config-5.4.72-gentoo-testing.old
-rwxr-xr-x 1 root root   188522 25 oct.  09:16 config-5.4.72-gentoo-x86_64
drwxr-xr-x 3 root root      512 12 oct.  02:57 EFI
drwxr-xr-x 6 root root      512 26 oct.  07:57 grub
-rwxr-xr-x 1 root root  3645140 12 oct.  02:22 initramfs-5.4.66-gentoo.img
-rwxr-xr-x 1 root root  3643664 19 oct.  12:03 initramfs-5.4.66-gentoo-testing.img
-rwxr-xr-x 1 root root  3639716 18 oct.  13:30 initramfs-5.4.66-gentoo-x86_64.img
-rwxr-xr-x 1 root root 11218740 19 oct.  13:41 initramfs-5.4.72-gentoo-maximal
-rwxr-xr-x 1 root root  4378380 26 oct.  07:56 initramfs-5.4.72-gentoo-minimal.img
-rwxr-xr-x 1 root root  3642916 19 oct.  13:51 initramfs-5.4.72-gentoo-minimal.img.old
-rwxr-xr-x 1 root root  8099068 25 oct.  14:15 initramfs-5.4.72-gentoo-testing.img
-rwxr-xr-x 1 root root  8087012 25 oct.  09:16 initramfs-5.4.72-gentoo-x86_64.img
-rwxr-xr-x 1 root root  3924658 12 oct.  02:19 System.map-5.4.66-gentoo
-rwxr-xr-x 1 root root  4014105 19 oct.  12:03 System.map-5.4.66-gentoo-testing
-rwxr-xr-x 1 root root  3993008 18 oct.  13:30 System.map-5.4.66-gentoo-x86_64
-rwxr-xr-x 1 root root  3970577 19 oct.  13:41 System.map-5.4.72-gentoo-maximal
-rwxr-xr-x 1 root root  4051274 26 oct.  08:11 System.map-5.4.72-gentoo-minimal
-rwxr-xr-x 1 root root  4064919 26 oct.  07:56 System.map-5.4.72-gentoo-minimal.old
-rwxr-xr-x 1 root root  4118501 25 oct.  17:25 System.map-5.4.72-gentoo-testing
-rwxr-xr-x 1 root root  4121440 25 oct.  17:07 System.map-5.4.72-gentoo-testing.old
-rwxr-xr-x 1 root root  4108443 25 oct.  09:16 System.map-5.4.72-gentoo-x86_64
-rwxr-xr-x 1 root root  7971712 12 oct.  02:19 vmlinuz-5.4.66-gentoo
-rwxr-xr-x 1 root root  8115072 19 oct.  12:03 vmlinuz-5.4.66-gentoo-testing
-rwxr-xr-x 1 root root  8098688 18 oct.  13:30 vmlinuz-5.4.66-gentoo-x86_64
-rwxr-xr-x 1 root root  8509824 19 oct.  13:41 vmlinuz-5.4.72-gentoo-maximal
-rwxr-xr-x 1 root root  8897920 26 oct.  08:11 vmlinuz-5.4.72-gentoo-minimal
-rwxr-xr-x 1 root root  8918400 26 oct.  07:56 vmlinuz-5.4.72-gentoo-minimal.old
-rwxr-xr-x 1 root root  9013632 25 oct.  17:25 vmlinuz-5.4.72-gentoo-testing
-rwxr-xr-x 1 root root  9021824 25 oct.  17:07 vmlinuz-5.4.72-gentoo-testing.old
-rwxr-xr-x 1 root root  8989056 25 oct.  09:16 vmlinuz-5.4.72-gentoo-x86_64
anard@gentoo-imack ~ $

_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Mon Nov 02, 2020 11:51 am    Post subject: Reply with quote

Je ne comprends pas bien, en effet, root n'a pas l'autorisation de créer un lien symbolique dans /boot/grub/themes/* :
Code:
gentoo-imack /boot/grub/themes/deepin # ln -s background_origin_source background_source
ln: impossible de créer le lien symbolique 'background_source': Opération non permise
gentoo-imack ~ # ls -l /boot/grub/themes
total 6
drwxr-xr-x 2 root root 2560  1 nov.  08:21 deepin
drwxr-xr-x 2 root root 3072 12 oct.  02:57 starfield
gentoo-imack ~ #


:?
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 795
Location: S.O. France

PostPosted: Mon Nov 02, 2020 6:16 pm    Post subject: Reply with quote

Salut,

Peux tu poster la sortie de blkid et de ton fstab ?
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Mon Nov 02, 2020 7:13 pm    Post subject: Reply with quote

Oui merci.
blkid ne donne rien...

Code:
anard@gentoo-imack ~ $ blkid
anard@gentoo-imack ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# NOTE: Even though we list ext4 as the type here, it will work with ext2/ext3
#       filesystems.  This just tells the kernel to use the ext4 driver.
#
# NOTE: You can use full paths to devices like /dev/sda3, but it is often
#       more reliable to use filesystem labels or UUIDs. See your filesystem
#       documentation for details on setting a label. To obtain the UUID, use
#       the blkid(8) command.

#LABEL=boot      /boot      ext4      noauto,noatime   1 2
#UUID=58e72203-57d1-4497-81ad-97655bd56494      /      ext4      noatime      0 1
#LABEL=swap      none      swap      sw      0 0
#/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0

#/dev/sda1
UUID=C1AD-161B               /boot   vfat   defaults,noatime   0 2
#/dev/sdc4
UUID=16c97957-bedb-4d6d-a472-8370864b5a45   none   swap   sw         0 0
#/dev/sda2
UUID=aab24e48-691c-49b7-ae35-f03e51739473   /   ext4   defaults,noatime   0 1
#UUID=b2381810-91d4-47dd-9162-f57da95d241b   /   ext4   defaults,noatime   0 1
#/dev/sdc3
UUID=7d79cb2d-2147-4aa8-8bc4-440cb308a1e0   /home   ext4   defaults,noatime   0 1

#Medias (/dev/sdd2)
UUID=64f8c204-beeb-3cd4-8f76-302805c25dc9   /media/Medias   hfsplus   force,rw,auto   0 0
# NFS share
/media/Medias               /export/Medias   none   bind      0 0

anard@gentoo-imack ~ $

Medias est un disque HFS partagé. J'ai essayé d'en faire un partage NFS qui pour le moment ne fonctionne pas, mais ce n'est pas le sujet :)
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 795
Location: S.O. France

PostPosted: Mon Nov 02, 2020 7:50 pm    Post subject: Reply with quote

Quote:
UUID=C1AD-161B /boot vfat defaults,noatime 0 2

Ton problème vient de là. vfat ne gère pas les symlink. Une raison d'avoir ton boot en vfat et pas en ext4 ?
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Mon Nov 02, 2020 8:14 pm    Post subject: Reply with quote

Cool déjà d'avoir trouvé le souci.
La raison, c'est que lors de l'install, je n'ai pas voulu faire une partition /boot et une partition EFI séparées.
Et que je ne suis pas certain que l'EFI puisse être autre chose que (v)fat.
Je ne vois pas trop comment régler le problème après-coup... :(
Mon bootloader (Clover pour booter macOS) gère peut-être l'ext4, tu crois que si je fais une sauvegarde de la partition, que je la re-formatte en ext4 et que je recopie le tout, ça peut le faire ?
L'idée finale est que si mon SSD macOS avec Clover plantait, je veux être en mesure de booter Gentoo en "standalone" avec Grub...

Code:
anard@gentoo-imack ~ $ sudo fdisk -l
Mot de passe :
# Disque "Homes & swap"
Disque /dev/sdb : 465,78 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : WDC WD5000AAVS-0
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : D88F005B-DBFB-4690-953F-3DF0137CE3B6

Périphérique     Début       Fin  Secteurs Taille Type
/dev/sdb1           40    409639    409600   200M Système EFI
/dev/sdb2       409640 481908735 481499096 229,6G HFS ou HFS+ Apple
/dev/sdb3    482170880 962306047 480135168   229G Système de fichiers Linux
/dev/sdb4    962306048 976773119  14467072   6,9G Partition d'échange Linux

# Disque système Apple (avec Clover)
Disque /dev/sdc : 233,78 GiB, 251000193024 octets, 490234752 secteurs
Modèle de disque : APPLE SSD TS256A
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 5F8721C0-31E7-47B5-A613-8573A5CD4F5A

Périphérique  Début       Fin  Secteurs Taille Type
/dev/sdc1        40    409639    409600   200M Système EFI
/dev/sdc2    409640 490234711 489825072 233,6G APFS Apple

# Disque système Gentoo (avec Grub)
Disque /dev/sda : 111,81 GiB, 120033041920 octets, 234439535 secteurs
Modèle de disque : Samsung SSD 840
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : gpt
Identifiant de disque : 3503BDBD-C4F4-4F91-8B3B-58FED7F5F232

Périphérique  Début       Fin  Secteurs Taille Type
/dev/sda1      2048    411647    409600   200M Système EFI
/dev/sda2    411648 234439501 234027854 111,6G Système de fichiers Linux

# Disque partagé HFS (Medias)
Disque /dev/sdd : 1,84 TiB, 2000398934016 octets, 3907029168 secteurs
Modèle de disque : ST2000VM003-1ET1
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : BD57E92D-4BAE-4CDE-A6DB-53FA13455CED

Périphérique  Début        Fin   Secteurs Taille Type
/dev/sdd1        40     409639     409600   200M Système EFI
/dev/sdd2    409640 3906766983 3906357344   1,8T HFS ou HFS+ Apple

_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 795
Location: S.O. France

PostPosted: Mon Nov 02, 2020 9:43 pm    Post subject: Reply with quote

Ce que je ferrai si effectivement l'efi ne peut être qu'en vfat (plus précisement /boot/efi de ce que j'ai pu lire):

- Soit tu repartionne ton sda1 en deux avec une partition /boot en ext4 et une partition /boot/efi en vfat. Tu réinstalle ensuite grub, tes noyaux et ton efi.
- Soit tu changes ton point de montage de sda1 vers /boot/efi. Ton dossier boot va basculer sur /dev/sda2 quand tu vas réinstallere grub et tout le reste. A moins qu'il ne te faille un boot séparé?

Mais attends que quelqu'un qui s'y connaisse en efi te confirme ou pas. J'ai jamais eu à gérer de l'efi.
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Sun Nov 08, 2020 7:13 am    Post subject: Reply with quote

Bien. Je ne voudrais pas tout casser... J'ai lu un peu le post de sluggeek pour tenter de visualiser ce que je dois faire.
Je ne crois pas avoir de raison spécifique pour que mon /boot soit sur une partition séparée.

Donc concrètement.
Je remplace simplement ma ligne dans /etc/fstab :
Code:
#/dev/sda1
UUID=C1AD-161B               /boot   vfat   defaults,noatime   0 2

par
Code:
#/dev/sda1
UUID=C1AD-161B               /boot/efi   vfat   defaults,noatime   1 2


Puis je fais
Code:

# grub-install --target=x86_64-efi --efi-directory=/boot/efi
# grub-mkconfig -o /boot/grub/grub.cfg


Quand tu parles de réinstaller l'efi et mes noyaux, que veux-tu dire ? Je comprends copier les fichiers au bon endroit... qui est le même en fait... :? Donc dois-je faire qqch de plus ?

Merci beaucoup.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 795
Location: S.O. France

PostPosted: Sun Nov 08, 2020 9:12 am    Post subject: Reply with quote

Ou ça devrait suffire.
Je ne sais pas si tu va devoir créer un dossier /boot/efi afin que sda1 puisse se monter dessus.
Prépare un livecd pour chrooter dessus au cas ou.
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Sun Nov 08, 2020 10:48 am    Post subject: Reply with quote

J'ai commencé par ça mais ça n'a rien changé.
Je me suis dit qu'il fallait sûrement aller plus loin...

Code:
# cp -r /boot /home/anard/boot # sauvegarde de /boot
# umount /dev/sda1
# mkfs.fat -F 32 /dev/sda1 # formattage de l'EFI
# cp -r /home/anard/boot/*5.4.72* /boot/ # copie des fichiers dans /boot
# cp -r /home/anard/boot/grub /boot
# mkdir /boot/efi
# mount /dev/sda1 /boot/efi # montage de l'EFI puis réinstallation de grub
# grub-install --target=x86_64-efi --efi-directory=/boot/efi
# grub-update
# reboot


:cry:
Il démarre normalement, mais au moment de lancer lightdm, il bloque et je n'ai plus qu'une invite de commande
Code:
(none) login:

Il semble avoir monté /dev/sda2 sur / mais ni /dev/sda1 ni /dev/sdc3 (/home)...
J'ai réussi à me re-logguer en root et faire l'opération inverse que précédemment :
Code:

# mkfs.fat -F 32 /dev/sda1
# mount /dev/sda1 /boot
# cp -r /home/anard/boot/* /boot/
# grub-install --target=x86_64-efi --efi-directory=/boot/efi
# grub-update
# reboot


Mais sans résultat...
Peut-être que mes UUID ont changé (donc qu'il faudrait mettre à jour mon fstab) ???
Dans ce cas à priori seulement celui de /dev/sda1... pourquoi ne monte-t-il pas mon /home automatiquement ? Et qomment se fait-il qu'il ait pu booter jusque-là s'il n'avait pas accès à mon /dev/sda1 ?
:?
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 795
Location: S.O. France

PostPosted: Sun Nov 08, 2020 11:27 am    Post subject: Reply with quote

[quote] Il semble avoir monté /dev/sda2 sur / mais ni /dev/sda1 ni /dev/sdc3 (/home)... [/quote]
sda1 doit être monté sinon tu n'aurais pu démarrer.

Ca donne quoi ls-l /boot/efi et ls -l /home/Anard dans le cas ou tu as modifié ton fstab? T'as accés aux fichiers ?

Désactive lightdm du démarrage.

Quand tu es en invite de commande, en root poste blkid (tu vas voir si tes UUID ont changés mais y'a pas de raison) et mount.
Un petit coup de dmesg peut aussi être utile.
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Sun Nov 08, 2020 12:03 pm    Post subject: Reply with quote

Au démarrage, /boot et /home étaient vides, c'est pour ça que je disais qu'il ne semblait pas les avoir montés.
J'ai tenté de les monter manuellement et de faire
Code:
startx
# et
startxfce
mais il n'a pas réussi... peut-être aurait-il fallu que je sois loggué sous mon nom plutôt qu'en root (je viens d'y penser :lol: )

Actuellement sous macOS, je referais un essai plus tard et posterai blkid et dmesg. Merci.
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Sun Nov 08, 2020 12:58 pm    Post subject: Reply with quote

OK. Redémarré sous Gentoo après avoir modifié fstab, en effet, /dev/sda1 avait changé d'UUID puisqu'il a été effacé.
En revanche de nouveaux messages d'erreur sont apparus au boot (pas eu le temps de noter).

voici le résultat de blkid et dmesg

EDIT :
OK, j'ai refais la première étape pour passer mon boot sur /dev/sda2 et seulement l'efi sur /dev/sda1 (cette fois sans oublier de mettre à jour /etc/fstab en fonction de blkid) et ça semble rouler :) (plus d'erreur visible au boot)

EDIT 2 : et ... ... ...
Code:
$ sudo emerge dde-meta
[...]
>>> Emerging (4 of 188) dde-extra/deepin-grub2-themes-1.0.0::deepin
 * deepin-grub2-themes-1.0.0.tar.gz SHA256 SHA512 size ;-) ...           [ ok ]
>>> Unpacking source...
>>> Unpacking deepin-grub2-themes-1.0.0.tar.gz to /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work
>>> Source unpacked in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work
>>> Preparing source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/work/deepin-grub2-themes-1.0.0 ...
>>> Source compiled.
>>> Test phase [not enabled]: dde-extra/deepin-grub2-themes-1.0.0

>>> Install dde-extra/deepin-grub2-themes-1.0.0 into /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/
make -j9 DESTDIR=/var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/ install
install -dm755 /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image//boot/grub/themes
Fixing permission of files...
>>> Completed installing dde-extra/deepin-grub2-themes-1.0.0 into /var/tmp/portage/dde-extra/deepin-grub2-themes-1.0.0/image/

 * Final size of build directory: 3756 KiB (3.6 MiB)
 * Final size of installed tree:  3704 KiB (3.6 MiB)


>>> Installing (4 of 188) dde-extra/deepin-grub2-themes-1.0.0::deepin
 * Assuming you do not have a separate /boot partition.
gtk-update-icon-cache: The generated cache was invalid.
gtk-update-icon-cache: The generated cache was invalid.

>>> Emerging (5 of 188) dde-base/deepin-sound-theme-15.10.6::deepin


Ca semble mieux se passer, merci ;)
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum