Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error emerging dev-libs/libbytesize
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
sachetto
n00b
n00b


Joined: 22 Oct 2020
Posts: 2

PostPosted: Thu Oct 22, 2020 9:07 pm    Post subject: Error emerging dev-libs/libbytesize Reply with quote

When I try to emere dev-libs/libbytesize I got the following error:

Calculating dependencies -

Code:
!!! Problem resolving dependencies for dev-libs/libbytesize                                                                                                                                                                                 ... done!

!!! The ebuild selected to satisfy "dev-libs/libbytesize" has unmet requirements.
- dev-libs/libbytesize-2.4::gentoo USE="tools -doc -python -test" ABI_X86="(64)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8"

  The following REQUIRED_USE flag constraints are unsatisfied:
    tools? ( python )

  The above constraints are a subset of the following complete expression:
    python? ( any-of ( python_targets_python3_6 python_targets_python3_7 python_targets_python3_8 ) ) tools? ( python )


Code tags added by NeddySeagoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46687
Location: 56N 3W

PostPosted: Thu Oct 22, 2020 9:18 pm    Post subject: Reply with quote

sachetto,

Welcome to Gentoo.

Code:
  The following REQUIRED_USE flag constraints are unsatisfied:
    tools? ( python )


This says that as you have selected USE=tools you must also select USE=python.

Its your choice. Portage can tell that it won't work but not tell which USE flag you want to change.
Either adding python or removing tools will allow portage to resolve this.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sachetto
n00b
n00b


Joined: 22 Oct 2020
Posts: 2

PostPosted: Thu Oct 22, 2020 9:55 pm    Post subject: [Solved] Error emerging dev-libs/libbytesize Reply with quote

Thank you very much. It worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum