Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WARNING: One or more updates/rebuilds have been skipped due
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
domaingood
n00b
n00b


Joined: 12 Mar 2020
Posts: 8

PostPosted: Fri Oct 09, 2020 8:55 am    Post subject: WARNING: One or more updates/rebuilds have been skipped due Reply with quote

I m new on Gentoo when trying to update getting error
Code:

$ sudo emerge --sync && emerge -upD world

Action: sync for repo: gentoo, returned code = 0
Action: sync for repo: calculate, returned code = 0
Action: sync for repo: distros, returned code = 0



Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-boot/plymouth:0

  (sys-boot/plymouth-0.9.5-r1:0/0::gentoo, ebuild scheduled for merge) USE="gtk libkms pango (split-usr) udev -debug -static-libs" ABI_X86="(64)" conflicts with
    ~sys-boot/plymouth-0.9.4[gtk,libkms,pango,split-usr] required by (sys-boot/plymouth-calculate-plugin-0.9.4-r3:0/0::calculate, installed) USE="gtk libkms pango (split-usr) -debug -gdm -static-libs" ABI_X86="(64)"
    ^                  ^^^^^                           

dev-python/olefile:0

  (dev-python/olefile-0.46-r1:0/0::gentoo, binary scheduled for merge) USE="-doc" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 -python3_8 (-python3_9)" conflicts with
    dev-python/olefile[python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (dev-python/pillow-6.2.2-r1:2.7/2.7::calculate, installed) USE="jpeg jpeg2k tiff truetype webp zlib -doc -examples -imagequant -lcms -test -tk" ABI_X86="(64)" PYTHON_TARGETS="python2_7"
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3541

PostPosted: Fri Oct 09, 2020 9:05 am    Post subject: Reply with quote

Code:
required by (sys-boot/plymouth-calculate-plugin-0.9.4-r3:0/0::calculate, installed)
Code:
required by (dev-python/pillow-6.2.2-r1:2.7/2.7::calculate, installed)

Your packages installed from ::calculate depend on packages older than you are trying to install from ::gentoo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24792
Location: here

PostPosted: Fri Oct 09, 2020 9:06 am    Post subject: Reply with quote

The problem the mix packages from calculate and gentoo overlay.
Gentoo have a new sys-boot/plymouth version (0.9.5), but plymouth-calculate-plugin package from calculate overlay require an old version (0.9.4) so this cause conflict.
Secondo problem is that dev-python/olefile has no support for python2.7 but dev-python/pillow from calculate has only support for python2.7 target (in this case you can try to install pillow from gentoo overlay)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8535
Location: ~Brussels - Belgique

PostPosted: Fri Oct 09, 2020 9:08 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum