Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] wpa_supplicant can't authenticate on 5ghz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
statikregimen
Apprentice
Apprentice


Joined: 16 Jul 2011
Posts: 173
Location: USA/Michigan

PostPosted: Fri Oct 02, 2020 4:02 pm    Post subject: [SOLVED] wpa_supplicant can't authenticate on 5ghz Reply with quote

Good day,

Figured I'd post here while I gather more info in case anybody has heard of this before. So far haven't been able to dig up any related cases from the net. At this point, I suspect something is wrong w/ my wifi router and I should try factory resetting it. However, I've done that several times recently and I don't know how robust the flash memory is ($300 router I'd rather not brick).

So, after making some changes to the router (I elected to hide my SSID, turned off WPS, and setup a MAC whitelist), now one of my two Gentoo boxes will no longer authenticate on the 5ghz radio. The other Gentoo box connects fine using NetworkManager and all other devices are working normally. At first, after these changes, everything worked on the box in question, so thinking I must have changed something else later on that I'm forgetting or something, or I've run into some weird bug (probably on the router). I've tried reverting the changes that I do remember, but to no avail.

This is what wpa_cli says when trying to connect...I apparently don't have logging setup properly, so also trying to figure that out, or some other way to get more verbose detail.

Code:
<3>CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=US
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with 24:f5:a2:23:af:11 (SSID='Rooter5' freq=5180 MHz)
<3>Trying to associate with 24:f5:a2:23:af:11 (SSID='Rooter5' freq=5180 MHz)
<3>Associated with 24:f5:a2:23:af:11
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-DISCONNECTED bssid=24:f5:a2:23:af:11 reason=15
<3>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Rooter5" auth_failures=1 duration=10 reason=WRONG_KEY


I've poured over my wifi router's config probably a dozen more times, and I just don't see anything out of the ordinary.

Thank you for reading and for any advice!


Last edited by statikregimen on Mon Oct 05, 2020 10:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
finalturismo
Apprentice
Apprentice


Joined: 06 Jan 2020
Posts: 159

PostPosted: Mon Oct 05, 2020 5:58 pm    Post subject: Re: wpa_supplicant can't authenticate on 5ghz Reply with quote

statikregimen wrote:
Good day,

Figured I'd post here while I gather more info in case anybody has heard of this before. So far haven't been able to dig up any related cases from the net. At this point, I suspect something is wrong w/ my wifi router and I should try factory resetting it. However, I've done that several times recently and I don't know how robust the flash memory is ($300 router I'd rather not brick).

So, after making some changes to the router (I elected to hide my SSID, turned off WPS, and setup a MAC whitelist), now one of my two Gentoo boxes will no longer authenticate on the 5ghz radio. The other Gentoo box connects fine using NetworkManager and all other devices are working normally. At first, after these changes, everything worked on the box in question, so thinking I must have changed something else later on that I'm forgetting or something, or I've run into some weird bug (probably on the router). I've tried reverting the changes that I do remember, but to no avail.

This is what wpa_cli says when trying to connect...I apparently don't have logging setup properly, so also trying to figure that out, or some other way to get more verbose detail.

Code:
<3>CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=US
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with 24:f5:a2:23:af:11 (SSID='Rooter5' freq=5180 MHz)
<3>Trying to associate with 24:f5:a2:23:af:11 (SSID='Rooter5' freq=5180 MHz)
<3>Associated with 24:f5:a2:23:af:11
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>CTRL-EVENT-DISCONNECTED bssid=24:f5:a2:23:af:11 reason=15
<3>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Rooter5" auth_failures=1 duration=10 reason=WRONG_KEY


I've poured over my wifi router's config probably a dozen more times, and I just don't see anything out of the ordinary.

Thank you for reading and for any advice!



With all the network setups ive done i can say this is nothing new to me. Usually this is caused by hash or features compatibility.

You need to mess with TKIP, WPA1 WPA2-PSK etc....

Your wificard is having an issue with authentication, sometimes this is not the password but the hash type or a features issue the wifi card does not have.

You need to change a setting on your router that has better compatibility.

You have probably checked the password 100 times, its not that...

Certain Wifi / WPA features and or key / hash type can cause this.

Btw stay away from WPS, its trash and has been cracked already. Its not good for security....

Turning off WPS might of caused it, because it might have changed the key type.

My guess is that you need to change the authentication / hash type on router.

WPA2-AES, WPA2-TKIP or WPA2-TKIP-AES

I bet your wifi card is having an issue with 1 of the authenticating methods being used.

Simply change the WPA2 preshared key type to something else and try again.

I have seen this countless times.....
Back to top
View user's profile Send private message
statikregimen
Apprentice
Apprentice


Joined: 16 Jul 2011
Posts: 173
Location: USA/Michigan

PostPosted: Mon Oct 05, 2020 10:07 pm    Post subject: Reply with quote

Thank you very much for the reply. I just got home and popped into my router for a look-see, and I noticed the security mode was set to WPA/WPA2 Personal, however I'm pretty certain it used to be on WPA2 Personal only, so I switched it over and voilà!

I don't remember changing it myself, nor do I know why I would have, but it is entirely possible that I did...The only other explanation is a bug or some expected behavior from changing something else that I'm unaware of.

Cheers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum