Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qbittorrent errore di compilazione (risolto)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkfor.nic
n00b
n00b


Joined: 11 Sep 2020
Posts: 68

PostPosted: Tue Sep 22, 2020 7:51 pm    Post subject: qbittorrent errore di compilazione (risolto) Reply with quote

Salve, purtroppo ho un'altro problema. Io questa mattina ho deciso fare una nuova installazione di Gentoo per il fatto che ovviamente mi sono scritto una guida dei comandi per non dimenticarmeli ma non perdere tempo (quando farò nuove installazioni di Gentoo) di andarmeli a cercare sulla guida ufficiale, quindi mi sono scritto i comandi che mi interessano e volevo vedere se avevo scritto tutto correttamente, ma ho pure reinstallato Gentoo per installarli direttamente KDE. Ho reinstallato quasi tutti i software ma quando cerco di installarmi qbittorrent il pacchetto "net-libs/libtorrent-rasterbar" mi da un fallimento di compilazione e ovviamente interrompe la compilazione. Se non ricordo male anche la prima volta che ho cercato di compilare qbittorrent mi ha dato questo problema ma poi l'ho risolto subito ma non ricordo... sul pacchetto "net-libs/libtorrent-rasterbar" i flag attivi di default sul pacchetto sono "dht ssl" ma ho tentato pure di disattivare una, l'altro e entrambi ma mi da sempre errore. Proprio non ricordo come avevo fatto

Last edited by darkfor.nic on Wed Sep 23, 2020 7:44 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24670
Location: here

PostPosted: Wed Sep 23, 2020 5:45 am    Post subject: Reply with quote

Per poterti aiutare devi postare il build.log del pacchetto che fallisce con wgetpaste, inoltre e' sempre utile postare il tuo emerge --info e anche quello che ritorna il comando emerge -pv <pacchetto_che_fallisce>.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.nic
n00b
n00b


Joined: 11 Sep 2020
Posts: 68

PostPosted: Wed Sep 23, 2020 6:29 am    Post subject: Reply with quote

fedeliallalinea wrote:
Per poterti aiutare devi postare il build.log del pacchetto che fallisce con wgetpaste, inoltre e' sempre utile postare il tuo emerge --info e anche quello che ritorna il comando emerge -pv <pacchetto_che_fallisce>.


Ciao, hai ragione, pensavo che magari era un bug noto. Io purtroppo mi sono installato wgetpaste ma mi dava errore con build.log e ho creato il testo manualmente con il sito internet

build.log
https://pastebin.pl/view/a5847993

Errore dopo la compilazione
https://pastebin.pl/view/688e032c

emerge -pv net-libs/libtorrent-rasterbar
[ebuild N ] net-libs/libtorrent-rasterbar-1.2.6:0/10::gentoo USE="dht ssl -debug -doc -examples -libressl -python -static-libs -test" PYTHON_TARGETS="python3_7 -python3_6 -python3_8" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24670
Location: here

PostPosted: Wed Sep 23, 2020 7:00 am    Post subject: Reply with quote

Sembra esserci un bug nell'ebuild, come workaround puoi provare a disabilitare la use flag python se possibile.
Dovresti anche aprire un nuovo bug in bugs.gentoo.org
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.nic
n00b
n00b


Joined: 11 Sep 2020
Posts: 68

PostPosted: Wed Sep 23, 2020 7:44 am    Post subject: Reply with quote

fedeliallalinea wrote:
Sembra esserci un bug nell'ebuild, come workaround puoi provare a disabilitare la use flag python se possibile.
Dovresti anche aprire un nuovo bug in bugs.gentoo.org


Grazie, ho risolto con il tuo suggerimento. Ho cercato di togliere via i python ma mi deva messaggi di invalidità, mi dava comunque "yes" o "no" ma non mi sembrava il caso di darli un "yes". Ho provato a cambiarli la versioni python ma ancora messaggi di invalidità e li mi è venuto il dubbio... ho attivato la use "python" e mi si è reincopilato il pacchetto "dev-libs/boost" e pure si è compilato dopo "net-libs/libtorrent-rasterbar" senza più darmi errori e si è installato, grazie di nuovo!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24670
Location: here

PostPosted: Wed Sep 23, 2020 7:55 am    Post subject: Reply with quote

Si ho scritto disabilitare ma intendevo abilitare la use flag python.
Ho aperto un nuovo bug report
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.nic
n00b
n00b


Joined: 11 Sep 2020
Posts: 68

PostPosted: Wed Sep 23, 2020 8:10 am    Post subject: Reply with quote

fedeliallalinea wrote:
Si ho scritto disabilitare ma intendevo abilitare la use flag python.
Ho aperto un nuovo bug report


Ho capito male. Non avevo poi aperto il bug sul sito perché non mi sembrava un bug ma avevo aperto il sito e mi ero registrato, poi ho voluto fare quella prova di attivarmi la use python
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24670
Location: here

PostPosted: Wed Sep 23, 2020 11:58 am    Post subject: Reply with quote

Il problema era gia' stato risolto dopo un sync puoi compilare il pacchetto anche con la use flag python disabilitata.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum