Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X windows not starting[SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message

Joined: 19 Dec 2004
Posts: 251
Location: 32°9'50" N 94°50'54" W

PostPosted: Sun Sep 20, 2020 10:12 pm    Post subject: X windows not starting[SOLVED] Reply with quote


I have a raspberry pi4 with a recent install of gentoo.

After running for about 2 weeks, I rebooted it and the GUI did not start.


cat /var/log/Xorg.0.log
cat Xorg.0.log
[  1438.287]
X.Org X Server 1.20.8
X Protocol Version 11, Revision 0
[  1438.292] Build Operating System: Linux 4.15.0-72-generic aarch64 Gentoo
[  1438.294] Current Operating System: Linux pi64 5.4.58-v8-2711+ #1 SMP PREEMPT Sun Aug 16 21:46:54 CDT 2020 aarch64
[  1438.294] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_headphones=1 video=HDMI-A-1:1280x1024M@60 smsc95xx.macaddr=DC:A6:32:BE:61:A8 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 root=PARTUUID=7A0C8BB0-02 rootfstype=ext4 elevator=deadline usbhid.mousepoll=0 rootwait
[  1438.303] Build Date: 04 August 2020  11:48:55AM
[  1438.305] 
[  1438.307] Current version of pixman: 0.40.0
[  1438.311]    Before reporting problems, check
   to make sure that you have the latest version.
[  1438.311] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1438.319] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Sep 20 17:00:51 2020
[  1438.322] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1438.324] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1438.326] Parse error on line 6 of section Screen in file /etc/X11/xorg.conf.d/Module.conf
   "none"" is not a valid keyword in this section.
[  1438.328] (EE) Problem parsing the config file
[  1438.328] (EE) Error parsing the config file
[  1438.328] (EE)
Fatal server error:
[  1438.332] (EE) no screens found(EE)
[  1438.334] (EE)
Please consult the The X.Org Foundation support
 for help.
[  1438.342] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1438.344] (EE)
[  1438.346] (EE) Server terminated with error (1). Closing log file.


cat /etc/X11/xorg.conf.d/Module.conf
Section "Module"
   Load "vnc"

Section "Screen"
Option "SecurityTypes "none"

Evidently there is an error in Module.conf. I was trying to get vnc to work and modified Module.conf. I am not sure of the original configuration of Module.conf.

I found the error. Changed Module.conf to this:

cat Module.conf
 Section "Module"
   Load "vnc"

#Section "Screen"
#Option "SecurityTypes "none"

Now X windows boots up.


Back to top
View user's profile Send private message

Joined: 01 Jul 2004
Posts: 7693
Location: almost Mile High in the USA

PostPosted: Fri Oct 02, 2020 2:25 pm    Post subject: Re: X windows not starting[SOLVED] Reply with quote

Don't know if you saw:
donjames wrote:

Option "SecurityTypes "none"

That missing quote symbol might have been the ultimate cause.
Option "SecurityTypes" "none"
#                   ^^^ missing quotation mark

Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum