Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] java
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 377

PostPosted: Tue Sep 15, 2020 5:22 am    Post subject: [Risolto] java Reply with quote

Avrei bisogno di java 11

ho provato a installare openjdk-bin-11.0.8

ma quando vedo la versione ottengo qualcosa del genere:

Code:
java -version
openjdk version "1.8.0_252"
OpenJDK Runtime Environment (IcedTea 3.16.0) (Gentoo icedtea-3.16.0)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)


non dovrebbe essere piú qualcosa del genere (su Archlinux)?

Code:
java -version
openjdk version "14.0.2" 2020-07-14
OpenJDK Runtime Environment (build 14.0.2+12)
OpenJDK 64-Bit Server VM (build 14.0.2+12, mixed mode)


cioé openjdk version "11.0.8" data.....


Last edited by antonellocaroli on Tue Sep 15, 2020 5:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24668
Location: here

PostPosted: Tue Sep 15, 2020 5:55 am    Post subject: Reply with quote

Puoi postare l'output dei comandi emerge -pv dev-java/openjdk:11 e eselect java-vm list?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 377

PostPosted: Tue Sep 15, 2020 6:01 am    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare l'output dei comandi emerge -pv dev-java/openjdk:11 e eselect java-vm list?



Code:
emerge -pv dev-java/openjdk:11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] acct-group/lp-0::gentoo  0 KiB
[ebuild  N     ] acct-group/lpadmin-0::gentoo  0 KiB
[ebuild  N     ] app-text/poppler-data-0.4.9::gentoo  4,099 KiB
[ebuild  N     ] app-arch/cpio-2.12-r1::gentoo  USE="nls" 1,230 KiB
[ebuild  N     ] app-text/libpaper-1.1.28::gentoo  42 KiB
[ebuild  N     ] media-libs/tiff-4.1.0::gentoo  USE="cxx zlib -jbig -jpeg -lzma -static-libs -test -webp -zstd" 2,365 KiB
[ebuild  N     ] media-libs/jbig2dec-0.19:0/0.19::gentoo  USE="-png -static-libs -test" 146 KiB
[ebuild  N     ] net-dns/libidn-1.36:0/12::gentoo  USE="nls -doc -emacs -java (-mono) -static-libs" 4,451 KiB
[ebuild  N     ] app-arch/rpm2targz-9.0.0.5g-r2::gentoo  6 KiB
[ebuild  N     ] media-libs/openjpeg-2.3.1-r1:2/7::gentoo  USE="-doc -static-libs -test" 2,163 KiB
[ebuild  N     ] x11-libs/libXrandr-1.5.2::gentoo  USE="-doc -static-libs" 323 KiB
[ebuild  N     ] app-text/qpdf-10.0.1-r1:0/28::gentoo  USE="ssl -doc -examples -libressl -static-libs -test" 17,969 KiB
[ebuild  N     ] sys-devel/bc-1.07.1-r3::gentoo  USE="readline -libedit -static" 411 KiB
[ebuild  N     ] media-fonts/urw-fonts-2.4.9::gentoo  USE="-X" 3,124 KiB
[ebuild  N     ] app-text/poppler-20.09.0:0/102::gentoo  USE="cxx jpeg jpeg2k lcms utils -cairo -cjk -curl -debug -doc -introspection -nss -png -qt5 -tiff" 1,605 KiB
[ebuild  N     ] net-print/cups-2.3.3-r1::gentoo  USE="acl pam ssl threads -X -dbus -debug -kerberos -lprng-compat (-selinux) -static-libs -systemd -usb -xinetd -zeroconf" 7,950 KiB
[ebuild  N     ] app-text/ghostscript-gpl-9.53.0::gentoo  USE="cups unicode -X -dbus -gtk -static-libs" L10N="-de (-ja) -ko -zh-CN -zh-TW" 40,392 KiB
[ebuild  N     ] net-print/cups-filters-1.28.2::gentoo  USE="foomatic postscript -dbus -jpeg -ldap -pclm -pdf -perl -png -static-libs -test -tiff -zeroconf" 1,468 KiB
[ebuild  N     ] dev-java/openjdk-11.0.8_p10:11::gentoo  USE="alsa jbootstrap pch -cups -debug -doc -examples (-gentoo-vm) -headless-awt (-javafx) (-selinux) -source -systemtap" 89,006 KiB

Total: 19 packages (19 new), Size of downloads: 176,742 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-print/cups-filters-1.28.2::gentoo[postscript]
# required by net-print/cups-2.3.3-r1::gentoo
# required by dev-java/openjdk-11.0.8_p10::gentoo
# required by dev-java/openjdk:11 (argument)
>=app-text/ghostscript-gpl-9.53.0 cups

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

GentooPlayerRpi64 /opt/recursive # emerge -pv dev-java/openjdk-bin:11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-java/openjdk-bin-11.0.8_p10:11::gentoo  USE="alsa -cups -doc (-gentoo-vm) -headless-awt (-selinux) -source" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

GentooPlayerRpi64 /opt/recursive #



Code:
eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24668
Location: here

PostPosted: Tue Sep 15, 2020 6:49 am    Post subject: Reply with quote

Devi smascherare la use flag gentoo-vm
Code:
# echo "dev-java/openjdk-bin -gentoo-vm" >> /etc/portage/profile/package.use.mask
#emerge -1 dev-java/openjdk-bin:11

a questo punto con eselect puoi selezionare openjdk-11
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 377

PostPosted: Tue Sep 15, 2020 5:19 pm    Post subject: Reply with quote

fedeliallalinea wrote:

[code]# echo "dev-java/openjdk-bin -gentoo-vm" >> /etc/portage/profile/package.use.mask


questo percorso non esiste sul mio sistema....lo devo creare? o devo usare

/var/db/repos/gentoo/profiles/default/linux/amd64/package.use.mask
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24668
Location: here

PostPosted: Tue Sep 15, 2020 5:31 pm    Post subject: Reply with quote

antonellocaroli wrote:
questo percorso non esiste sul mio sistema....lo devo creare?

Si lo devi crearlo

antonellocaroli wrote:
o devo usare /var/db/repos/gentoo/profiles/default/linux/amd64/package.use.mask

No anche perche' questo verebbe sovrascritto ad ogni sync
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 377

PostPosted: Tue Sep 15, 2020 5:47 pm    Post subject: Reply with quote

fedeliallalinea wrote:


No anche perche' questo verebbe sovrascritto ad ogni sync


immaginavo....Grazie mille

Code:
java -version
openjdk version "11.0.8" 2020-07-14
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.8+10)
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 11.0.8+10, mixed mode)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum