Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia driver error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
axelbest
n00b
n00b


Joined: 30 Dec 2005
Posts: 34
Location: Toronto, Canada

PostPosted: Fri Sep 11, 2020 6:19 pm    Post subject: Nvidia driver error Reply with quote

Hi

Anybody can help me with this error? This is the latest version supported by my video card (Nvidia geforce 540m NOTEBOOK)

Code:

* Messages for package x11-drivers/nvidia-drivers-390.138-r100:

 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-5.8
 * <sys-kernel/vanilla-sources-5.8
 *
 * You are free to utilize eapply_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 *
 * Do not file a bug report about this.
 *
 * ERROR: x11-drivers/nvidia-drivers-390.138-r100::stefantalpalaru failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-390.138-r100::stefantalpalaru'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-390.138-r100::stefantalpalaru'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-390.138-r100/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-390.138-r100/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-390.138-r100/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-390.138-r100/work/'

 * GNU info directory index is up-to-date.


eselect kernel list
Code:
Available kernel symlink targets:
  [1]   linux-5.4.48-gentoo
  [2]   linux-5.8.8-gentoo *


lspci | grep VGA
Code:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)


emerge --info '=x11-drivers/nvidia-drivers-390.138-r100::stefantalpalaru'

Code:
Portage 3.0.6 (python 3.7.9-final-0, default/linux/amd64/17.0/hardened/selinux, gcc-9.3.0, glibc-2.32-r1, 5.8.8-gentoo-x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.8.8-gentoo-x86_64-x86_64-Intel-R-_Core-TM-_i7-2670QM_CPU_@_2.20GHz-with-gentoo-2.7
KiB Mem:    16286372 total,  12626368 free
KiB Swap:     524284 total,    524284 free
Timestamp of repository gentoo: Thu, 10 Sep 2020 01:00:01 +0000
Head commit of repository gentoo: 4ae9b079390586596e43455c7f4d80e3c59ef3b5
sh bash 5.0_p18
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
app-shells/bash:          5.0_p18::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18-r100::stefantalpalaru, 3.7.9::gentoo, 3.8.5::gentoo, 3.9.0_rc1::gentoo
dev-util/cmake:           3.18.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo, 2.34-r2::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo, 10.2.0-r1::gentoo
sys-devel/gcc-config:     2.3.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r1::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

stefantalpalaru
    location: /var/lib/layman/stefantalpalaru
    sync-type: laymansync
    sync-uri: https://github.com/stefantalpalaru/gentoo-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch preserve-libs protect-owned qa-unresolved-soname-deps sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ https://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://mirrors.rit.edu/gentoo/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/"
LANG="en_CA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl acpi alsa alsa-plugin amd64 asyncns bbswitch bluetooth browser-integration bzip2 caps compat crypt dbus dell display-manager dri dri3 driver equalizer fonts git glib grub gtk gtk3 hardened iconv ieee1394 ipv6 kwallet laptop lcdfilter libglvnd libtirpc lm-sensors multilib ncurses networkmanager nls nptl nvidia opengl openmp pam pcre pie policykit pulseaudio readline sddm seccomp selinux sna split-usr sse4_1 sse4_2 ssl ssp ssse3 sync-plugin-portage themes threads truetype udev unicode v4l v4l2 wallpapers xattr xtpax xvmc zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics mouse keyboard v4l" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1725
Location: San Jose, CA

PostPosted: Fri Sep 11, 2020 10:43 pm    Post subject: Reply with quote

I checked and you have the right driver version for your video card. The nvidia site says this:

LINUX X64 (AMD64/EM64T) DISPLAY DRIVER
Driver Version: 390.1380 - Release Date: Wed Jun 24, 2020

However, that driver may not support the 5.8 or even the 5.7 kernel.

So try a different version of the kernel:

Try 5.7.19 first.

Then try 5.4.62.

You can try other kernels, but you have to download them from the backup repos (a process I'm not familiar with)
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
axelbest
n00b
n00b


Joined: 30 Dec 2005
Posts: 34
Location: Toronto, Canada

PostPosted: Sat Sep 12, 2020 4:13 am    Post subject: Reply with quote

RayDude wrote:
I checked and you have the right driver version for your video card. The nvidia site says this:

LINUX X64 (AMD64/EM64T) DISPLAY DRIVER
Driver Version: 390.1380 - Release Date: Wed Jun 24, 2020

However, that driver may not support the 5.8 or even the 5.7 kernel.

So try a different version of the kernel:

Try 5.7.19 first.

Then try 5.4.62.

You can try other kernels, but you have to download them from the backup repos (a process I'm not familiar with)


Ok... but you know what, I just installed the latest nvidia driver, even isn't compatible, it's working. And there's a lot of dependencies in this driver version. Thanks for your help.
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1725
Location: San Jose, CA

PostPosted: Sat Sep 12, 2020 4:23 am    Post subject: Reply with quote

axelbest wrote:
RayDude wrote:
I checked and you have the right driver version for your video card. The nvidia site says this:

LINUX X64 (AMD64/EM64T) DISPLAY DRIVER
Driver Version: 390.1380 - Release Date: Wed Jun 24, 2020

However, that driver may not support the 5.8 or even the 5.7 kernel.

So try a different version of the kernel:

Try 5.7.19 first.

Then try 5.4.62.

You can try other kernels, but you have to download them from the backup repos (a process I'm not familiar with)


Ok... but you know what, I just installed the latest nvidia driver, even isn't compatible, it's working. And there's a lot of dependencies in this driver version. Thanks for your help.


When you say latest, do you mean 450.66?

Because that is not designed to work with your card and may cause problems for you.

As I understand it, old cards need to use old drivers.

If it works, great, but if you have problems, you'll know what to look at first.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum