Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202007-42 ] LHa
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Tue Jul 28, 2020 4:26 pm    Post subject: [ GLSA 202007-42 ] LHa Reply with quote

Gentoo Linux Security Advisory

Title: LHa: Buffer overflow (GLSA 202007-42)
Severity: normal
Exploitable: remote
Date: 2020-07-27
Bug(s): #572418
ID: 202007-42

Synopsis

LHa has a buffer overflow in its compression utility with
unspecified impact.


Background

LHa is a console-based program for packing and unpacking LHarc archives.

Affected Packages

Package: app-arch/lha
Vulnerable: < 114i_p20201004
Unaffected: >= 114i_p20201004
Architectures: All supported architectures


Description

A buffer overflow in LHa’s compression code was discovered which can
be triggered by a crafted input file.


Impact

A remote attacker could send a specially crafted file possibly resulting
in a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All LHa users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-arch/lha-114i_p20201004"
   


References

CVE-2016-1925
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum