Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202007-38 ] QtGui
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Tue Jul 28, 2020 12:26 pm    Post subject: [ GLSA 202007-38 ] QtGui Reply with quote

Gentoo Linux Security Advisory

Title: QtGui: Arbitrary code execution (GLSA 202007-38)
Severity: normal
Exploitable: remote
Date: 2020-07-27
Bug(s): #719732
ID: 202007-38

Synopsis

A use-after-free was discovered in QtGui's Markdown handling code
possibly allowing a remote attacker to execute arbitrary code.


Background

QtGui is a module for the Qt toolkit.

Affected Packages

Package: dev-qt/qtgui
Vulnerable: < 5.14.2
Unaffected: >= 5.14.2
Architectures: All supported architectures


Description

QtGui’s setMarkdown has a use-after-free related to
QTextMarkdownImporter::insertBlock.


Impact

A remote attacker could possibly execute arbitrary code with the
privileges of the process, or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All QtGui users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-qt/qtgui-5.14.2"
   
Note that the Qt suite is best kept in sync, so a world upgrade may be
advisable to keep your system in a good state.


References

CVE-2020-12267
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum