Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Libreoffice won't open his apps after update(solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
poe_1957
n00b
n00b


Joined: 26 Sep 2018
Posts: 72
Location: Mortsel

PostPosted: Thu Jul 02, 2020 12:24 pm    Post subject: Libreoffice won't open his apps after update(solved) Reply with quote

I upgraded with emerge --sync and emerge at world and the installed version (no errors) does not open the applications anymore it shows just the logo and dissapears.
Anyone a solution ?
I got rid of the .lock file, but it doesnot helps.

Code:
[ebuild   R    ] app-office/libreoffice-6.4.3.2::gentoo  USE="bluetooth branding cups dbus gstreamer kde ldap mariadb pdfimport -accessibility (-coinmp) -debug -eds (-firebird) -googledrive -gtk -java -odk -postgres -test" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_7 -python3_6 (-python3_8)"


It is a Ryzen 9 system fresh installed with 5.4.48 kernel waiting for 5.5.8 kernel. on ASROCk Phantom gaming X MB. the kernel problems are solved and BIOS is udated to 3.2.1.
I use KDE 5.70 Everything is updated. no errors In Journalctl -k i do not see any problem..
_________________
Linuxpioneer
ALUG


Last edited by poe_1957 on Wed Aug 12, 2020 11:42 am; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1181
Location: Italy

PostPosted: Thu Jul 02, 2020 12:33 pm    Post subject: Reply with quote

Did you try launching Libreoffice from command line in a terminal emulator?
Back to top
View user's profile Send private message
Banana
l33t
l33t


Joined: 21 May 2004
Posts: 618
Location: Germany

PostPosted: Thu Jul 02, 2020 1:42 pm    Post subject: Reply with quote

The command would be
Code:
libreoffice


Also check any logs in /var/log/
_________________
My personal space
Back to top
View user's profile Send private message
poe_1957
n00b
n00b


Joined: 26 Sep 2018
Posts: 72
Location: Mortsel

PostPosted: Thu Jul 02, 2020 11:02 pm    Post subject: Reply with quote

banana

same problem on commandline. I had myuser: users as owner and group. I changed it to myuser:root but no result
The directory of /usr/lib64/libreoffice is root:root
I use systemd and journalctl (just a beginner in systemd I used to use to RC-system before but since everything is changing too to systemd I wanted to install and learn it. But the systemd logs are still a mistery to me.
I use journalctl -k to show the last startup log but I do not see anything about libreoffice appearing.
Or maybe i need to activate some other log but I do not know how to do it.
_________________
Linuxpioneer
ALUG


Last edited by poe_1957 on Fri Jul 03, 2020 9:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
Banana
l33t
l33t


Joined: 21 May 2004
Posts: 618
Location: Germany

PostPosted: Fri Jul 03, 2020 7:04 am    Post subject: Reply with quote

so no error output if you run the command in the terminal? To run the command there is no need to change the user. emerge should config it that the non root user can run it.
_________________
My personal space
Back to top
View user's profile Send private message
poe_1957
n00b
n00b


Joined: 26 Sep 2018
Posts: 72
Location: Mortsel

PostPosted: Fri Jul 03, 2020 4:11 pm    Post subject: Reply with quote

Banana

i tried also to reinstall, but the result is the same.. I see only the logo of libreoffice . But now i have this on the command line :

Code:
LoadLib(libhsa-ext-image64.so.1) failed: libhsa-ext-image64.so.1: kan gedeeld objectbestand niet openen: Bestand of map bestaat niet
: CommandLine Error: Option 'help-list' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options


Never seen this before. But my LLVM is upgraded to version 10 and before (version 9) it worked.
I cannot downgrade because i need v10.
Do you know where 'libhsa-ext-image64.so.1' comes from ?
_________________
Linuxpioneer
ALUG


Last edited by poe_1957 on Fri Jul 03, 2020 9:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 4034
Location: Illinois, USA

PostPosted: Fri Jul 03, 2020 4:16 pm    Post subject: Reply with quote

poe_1957 wrote:
I changed it to myuser:root but no result

That is almost certainly wrong. try myuser:wheel instead. It may not solve this problem but it's a better choice.


Last edited by Tony0945 on Fri Jul 03, 2020 10:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1181
Location: Italy

PostPosted: Fri Jul 03, 2020 4:30 pm    Post subject: Reply with quote

poe_1957 wrote:
Do you know where 'libhsa-ext-image64.so.1' comes from ?

According to portagefilelist.de, /usr/lib64/libhsa-ext-image64.so.1 belongs to dev-libs/hsa-ext-rocr
Back to top
View user's profile Send private message
poe_1957
n00b
n00b


Joined: 26 Sep 2018
Posts: 72
Location: Mortsel

PostPosted: Fri Jul 03, 2020 9:45 pm    Post subject: Reply with quote

to fturco

That's indeed missing
Code:
POERYZEN /usr/lib64 # ls libhsa*
libhsakmt.so    libhsakmt.so.1.0.6   libhsa-runtime64.so.1
libhsakmt.so.1  libhsa-runtime64.so  libhsa-runtime64.so.1.1.9


PS. How did you find out (which command?) that it was from dev-libs/hsa-ext-rocr ?

dev-libs/hsa-ext-rocr is masked i unmasked it an installed it. LibreOffice started now with following errors :
Code:
LoadLib(libhsa-amd-aqlprofile64.so) failed: libhsa-amd-aqlprofile64.so: kan gedeeld objectbestand niet openen: Bestand of map bestaat niet
LoadLib(libhsa-amd-aqlprofile64.so) failed: libhsa-amd-aqlprofile64.so: cannot open shared object file: No such file or directory
JavaScript error: resource:///modules/sessionstore/SessionStore.jsm, line 5490: uncaught exception: 2147746065
JavaScript error: undefined, line 14: Error: An unexpected error occurred
JavaScript error: moz-extension://bc39ec6a-4192-40c5-8c32-e29f4bae83c6/lib/picture_in_picture_overrides.js, line 15: Error: Incorrect argument types for pictureInPictureParent.setOverrides.
Log warning: The log 'Services.Common.RESTRequest' is configured to use the preference 'services.common.log.logger.rest.request' - you must adjust the level by setting this preference, not by using the level setter
1593812584889   Sync.Engine.Extension-Storage   ERROR   Syncing plasma-browser-integration@kde.org: request failed: Error: HTTP 401 Unauthorized: Missing Authorization Token (Please authenticate yourself to use this endpoint.)(resource://services-common/kinto-http-client.js:2645:5) JS Stack trace: ServerResponse@kinto-http-client.js:2645:5
processResponse@kinto-http-client.js:2792:13
JavaScript error: https://mariadb.com/kb/en/configuring-pam-authentication-and-user-mapping-with-unix-authentication/, line 741: ReferenceError: MktoForms2 is not defined
JavaScript error: https://mariadb.com/kb/en/configuring-pam-authentication-and-user-mapping-with-unix-authentication/ line 4183 > scriptElement, line 1: ReferenceError: MktoForms2 is not defined
JavaScript error: https://mariadb.com/kb/en/configuring-pam-authentication-and-user-mapping-with-ldap-authentication/, line 1025: ReferenceError: MktoForms2 is not defined
JavaScript error: https://mariadb.com/kb/en/configuring-pam-authentication-and-user-mapping-with-ldap-authentication/ line 4183 > scriptElement, line 1: ReferenceError: MktoForms2 is not defined
JavaScript error: https://mariadb.com/kb/en/authentication-plugin-pam/, line 1063: ReferenceError: MktoForms2 is not defined
JavaScript error: https://mariadb.com/kb/en/authentication-plugin-pam/ line 4183 > scriptElement, line 1: ReferenceError: MktoForms2 is not defined

I think i need to reinstall with Java and reconfigure mariadb. MktoForms2 I do not know from where it comes. Anyway Libreoffice starts now and is visible.
I feel that with my combination of hardware I am really riding on the edge of stable and unstable ;-)
Already thanks for the good information!
_________________
Linuxpioneer
ALUG
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1181
Location: Italy

PostPosted: Sat Jul 04, 2020 3:20 am    Post subject: Reply with quote

poe_1957 wrote:
PS. How did you find out (which command?) that it was from dev-libs/hsa-ext-rocr ?

I used the following website: https://www.portagefilelist.de/
You can also use the command line version with the app-portage/pfl package.
See the following Gentoo wiki article for details: https://wiki.gentoo.org/wiki/Pfl
Back to top
View user's profile Send private message
poe_1957
n00b
n00b


Joined: 26 Sep 2018
Posts: 72
Location: Mortsel

PostPosted: Thu Jul 09, 2020 7:56 pm    Post subject: Solved ! Reply with quote

I found the resolution :

sys-devel/llvm and sys-devel/llvm-roc may not be installed at the same system. When I removed it Libreoffice came up without any problem.
_________________
Linuxpioneer
ALUG
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum