Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/etc/init.d/xdm no funciona
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1241
Location: La Plata, Argentina

PostPosted: Wed Jun 24, 2020 5:42 pm    Post subject: /etc/init.d/xdm no funciona Reply with quote

Buenas, tengo un problemita luego de un cambio de hardware.

pase de un intel a un ryzen, basicamente recompile el kernel desde un chroot, luego que levante el sistema recompile system luego world.

El sistema funciona perfectamente salvo el servicio xdm

cuando inicio con

Code:
/etc/init.d/xdm start

ni siquiera se genera un Xorg.0.log, basicamente es como si no iniciara xorg-server.

Pero si tengo log en sddm.log.


ahora, si inicio con el comando

Code:
startx exec=/usr/bin/startplasma-x11
Las x inician perfectamente...

Algun tip?


Muchas gracias
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 3022
Location: Hong Kong

PostPosted: Thu Jun 25, 2020 3:31 am    Post subject: Reply with quote

Yo tengo un problema similar y está relacioando con elogin. De momento tengo una solución temporal que tal vez te sirva. En mi caso, si añado elogind al inicio (rc-update add elogind boot) tal y como se recomienda en https://wiki.gentoo.org/wiki/Elogind entonces SDDM no inicia. Obtengo pantalla en negro y en /var/log/sddm.log solo muestra

Code:

(II) DAEMON: Initializing...
(II) DAEMON: Starting...
(II) DAEMON: Logind interface found


En cambio si elimino elogind del inicio (rc-update del elogind boot) entonces SDDM sí inicia aunque los botones de apagar/reiniciar se muestran desactivados. Lo curioso es que a pesar de desactivar elogind éste se inicia automáticamente (comprobado con `pidof elogind-daemon`). También es curioso que si mato elogind y reinicio XDM (killall -9 elogind-daemon;rc-service xdm restart) entonces los botones apagar/reiniciar vuelven a funcionar.
Back to top
View user's profile Send private message
expobi
n00b
n00b


Joined: 29 Dec 2014
Posts: 60
Location: Santander - España

PostPosted: Thu Jun 25, 2020 11:42 am    Post subject: Reply with quote

Quizá sea una pregunta tonta, pero si iniciáis con comandos ¿para qué necesitáis sddm?
Yo no lo tengo, inicio como usuario (cuando me pongo bago incluso ya me pide solo la contraseña del usuario que normalmente uso), no inicio xdm ni elogind, las X me funcionan perfectamente y los botones de apagar y reiniciar están presentes.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1241
Location: La Plata, Argentina

PostPosted: Thu Jun 25, 2020 12:54 pm    Post subject: Reply with quote

Stolz wrote:
Yo tengo un problema similar y está relacioando con elogin. De momento tengo una solución temporal que tal vez te sirva. En mi caso, si añado elogind al inicio (rc-update add elogind boot) tal y como se recomienda en https://wiki.gentoo.org/wiki/Elogind entonces SDDM no inicia. Obtengo pantalla en negro y en /var/log/sddm.log solo muestra

Code:

(II) DAEMON: Initializing...
(II) DAEMON: Starting...
(II) DAEMON: Logind interface found


En cambio si elimino elogind del inicio (rc-update del elogind boot) entonces SDDM sí inicia aunque los botones de apagar/reiniciar se muestran desactivados. Lo curioso es que a pesar de desactivar elogind éste se inicia automáticamente (comprobado con `pidof elogind-daemon`). También es curioso que si mato elogind y reinicio XDM (killall -9 elogind-daemon;rc-service xdm restart) entonces los botones apagar/reiniciar vuelven a funcionar.

Bueno, no soy el unico! eso me da chances de que se solucione.

En mi caso da igual de ninguna de las maneras inicia, ni con el servicio, ni sin el servicio elogind iniciado.

lo que estuve probando fue, iniciar llamando en vez de a plasma con login de user, loguearme como root en la tty y llamar al sddm como lo haria el servicio xdm, eso me da pantalla negra, sin cursor ni nada, solo responde del teclado el blocknum mayusc y demas, pero ni el ctrl+alt+f1 me vuelve al tty, asi que hard reset.

Lo que me llama la atencion es que el servicio parece no ejecutar ni siquiera eso
Tengo exactalemente la misma salida en el log de sddm.

consolekit no es una opcion ya que me bloquea teamviewer, si bien no es de vital importancia, lo uso por laburo, ya correr una vm para tirar un temviewer me seria mas que molesto....

expobi wrote:
Quizá sea una pregunta tonta, pero si iniciáis con comandos ¿para qué necesitáis sddm?
Yo no lo tengo, inicio como usuario (cuando me pongo bago incluso ya me pide solo la contraseña del usuario que normalmente uso), no inicio xdm ni elogind, las X me funcionan perfectamente y los botones de apagar y reiniciar están presentes.

Si fuera el unico que usa la pc fenomeno, pero como no soy el unico, explicarle al resto como se usa linux, mas alla de las X, la veo compliada....
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2181
Location: Barcelona

PostPosted: Sun Jun 28, 2020 7:07 pm    Post subject: Reply with quote

¿Has probado a recompilar XDM?
_________________
pcmaster
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1394

PostPosted: Sun Jun 28, 2020 9:23 pm    Post subject: Reply with quote

@pelelademadera:
consolekit, systemd y elogind son excluyentes. En un sistema solo una de esas uses debería estar definida a nivel global (y las otras desactivadas). Comprueba que no tienes paquetes con uses "mezcladas".
Back to top
View user's profile Send private message
elover
n00b
n00b


Joined: 20 Nov 2019
Posts: 46
Location: Spain

PostPosted: Thu Jul 02, 2020 11:41 am    Post subject: Reply with quote

Stolz wrote:
Yo tengo un problema similar y está relacioando con elogin. De momento tengo una solución temporal que tal vez te sirva. En mi caso, si añado elogind al inicio (rc-update add elogind boot) tal y como se recomienda en https://wiki.gentoo.org/wiki/Elogind entonces SDDM no inicia. Obtengo pantalla en negro y en /var/log/sddm.log solo muestra

Code:

(II) DAEMON: Initializing...
(II) DAEMON: Starting...
(II) DAEMON: Logind interface found


En cambio si elimino elogind del inicio (rc-update del elogind boot) entonces SDDM sí inicia aunque los botones de apagar/reiniciar se muestran desactivados. Lo curioso es que a pesar de desactivar elogind éste se inicia automáticamente (comprobado con `pidof elogind-daemon`). También es curioso que si mato elogind y reinicio XDM (killall -9 elogind-daemon;rc-service xdm restart) entonces los botones apagar/reiniciar vuelven a funcionar.


Hola, me paso esto que comentáis hace unas semanas creo que tres semana más o menos y lo solucione borrando y añadiendo grupo video


Code:
╭─ elover  ~ 
╰─ rc-update show                                                                                    1 ↵  1323  13:45:01
         avahi-daemon |      default                           
               binfmt | boot                                   
            bluetooth |      default                           
             bootmisc | boot                                   
              cgroups |                                 sysinit
               cronie |      default                           
                cupsd |      default                           
                devfs |                                 sysinit
                dmesg |                                 sysinit
              elogind | boot                                   
                 fsck | boot                                   
             hostname | boot                                   
              hwclock | boot                                   
              keymaps | boot                                   
            killprocs |                        shutdown       
    kmod-static-nodes |                                 sysinit
             libvirtd |      default                           
                local |      default nonetwork                 
           localmount | boot                                   
             loopback | boot                                   
              modules | boot                                   
             mount-ro |                        shutdown       
                 mtab | boot                                   
             netmount |      default                           
     opentmpfiles-dev |                                 sysinit
   opentmpfiles-setup | boot                                   
               procfs | boot                                   
                 root | boot                                   
         save-keymaps | boot                                   
    save-termencoding | boot                                   
            savecache |                        shutdown       
                 swap | boot                                   
               sysctl | boot                                   
                sysfs |                                 sysinit
             sysklogd |      default                           
         termencoding | boot                                   
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot                                   
               vmware |      default                           
                  xdm |      default                           

Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1241
Location: La Plata, Argentina

PostPosted: Wed Jul 08, 2020 12:24 am    Post subject: Reply with quote

quilosaq wrote:
@pelelademadera:
consolekit, systemd y elogind son excluyentes. En un sistema solo una de esas uses debería estar definida a nivel global (y las otras desactivadas). Comprueba que no tienes paquetes con uses "mezcladas".

si, solo uso elogind, hace rato que pase por teamviewer de consolekit a elogin,
pcmaster wrote:
¿Has probado a recompilar XDM?

si, xdm, xinit, y hacer un emerge -1e xorg-server, pero absolutamente nada cambia la situacion


@Stolz probe tambien, pero nada, exactamente lo mismo
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 481
Location: Tultitlan, México

PostPosted: Thu Jul 23, 2020 4:59 pm    Post subject: Reply with quote

Hola, me uno al hilo por un problema similar. Hace dos días hice una actualización, entonces xorg-server comenzó a pedir elogind. El error con consolekit era el siguiente:

Code:
[     8.043] (EE) modeset(0): drmSetMaster failed: Permission denied
[     8.044] (EE)
Fatal server error:
[     8.044] (EE) AddScreen/ScreenInit failed for driver 0
[     8.044] (EE)
[     8.044] (EE)


Traté de conservar consolekit pero no funcionó, además parece que ya no se actualiza. Instalé elogind y ya funciona startx de forma manual, pero no inicia automáticamente. Antes usaba esto en el .bash_profile

Code:
## Auto startx in tty3
# if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty3 ]]; then
#         exec /usr/bin/startx /etc/X11/Sessions/dwm -- :3 vt3 -nolisten tcp -br ;
# fi


Ahora debo teclearlo en el tty para iniciar un entorno gráfico con éxito. El error es:

Code:
[    71.866] (++) using VT number 7

[    71.866] (EE)
Fatal server error:
[    71.867] (EE) xf86OpenConsole: Cannot open virtual console 7 (Permission denied)
[    71.868] (EE)
[    71.869] (EE)


Me parece que elogind ha cambiado alguna(s) variables porque claramente trata de usar vt7 cuando señalo que debe usar vt3, Como ya dije si tecleo la instrucción todo va bien, así que de momento he creado un alias para startx y ya.

Quizás alguien sepa donde esta la documentación de las variables que maneja elogind relacionadas con el entorno gráfico y quizás para los que usen xdm se pueda actualizar /etc/X11/startDM.sh

Saludos.
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
Eleazar Anzola
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1306
Location: Caracas / Venezuela

PostPosted: Thu Jul 23, 2020 10:53 pm    Post subject: Reply with quote

El problema no es de xdm sino de los manejadores de loguin, ya me ha sucedido hace bastante con sddm y lightdm, el único que se ha mantenido sin problemas es lxdm.
_________________
Salu2
Eleazar Anzola
Linux User : # 216232
__________________________________________
Por un foro ordenado y un buscador más útil:
[TEMA] Descripción problema (estado)
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1394

PostPosted: Wed Jul 29, 2020 7:04 pm    Post subject: Re: /etc/init.d/xdm no funciona Reply with quote

pelelademadera wrote:
...
cuando inicio con

Code:
/etc/init.d/xdm start

ni siquiera se genera un Xorg.0.log, basicamente es como si no iniciara xorg-server.

Pero si tengo log en sddm.log.


ahora, si inicio con el comando

Code:
startx exec=/usr/bin/startplasma-x11
Las x inician perfectamente...
...

Para teclear esos comandos estarás en una tty. En ese momento ¿tienes una entrada registrada en elogind?
Code:
loginctl
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum