Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to emerge dev-vcs/subversion-1.14.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
firefoxthegreat
n00b
n00b


Joined: 26 Feb 2013
Posts: 4

PostPosted: Fri Jun 26, 2020 2:34 pm    Post subject: Failed to emerge dev-vcs/subversion-1.14.0 Reply with quote

Hi, I am having trouble upgrading to subversion-1.14.0. Emerge fails with
Code:

...
Transforming tools/dev/x509-parser
 * python3_7: running swig_py_compile
 * python_export() is part of private eclass API.
 * Please call python_get*() instead.
make -j5 swig-py swig_pydir=/usr/lib/python3.7/site-packages/libsvn swig_pydir_extra=/usr/lib/python3.7/site-packages/svn
/bin/sh "/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/libtool" --tag=CC --silent --mode=compile none  -P -I/usr/include/libutf8proc  -DLINUX -D_REENTRANT -D_GNU_SOURCE  -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/include -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/bindings/swig -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/bindings/swig/include -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/bindings/swig/proxy -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/bindings/swig/proxy -I/usr/include/apr-1  -I/usr/include/apr-1 -I/usr/include/db5.3 -I/usr/include/python3.7m  -I/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/subversion/bindings/swig/python/libsvn_swig_py -prefer-pic -c -o subversion/bindings/swig/python/svn_client.lo subversion/bindings/swig/python/svn_client.c
SWIG python disabled at configure time: no Python.h found
make: *** [build-outputs.mk:67: .swig_py_checked] Error 1
make: *** Waiting for unfinished jobs....
/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0/libtool: line 1770: none: command not found
make: *** [build-outputs.mk:2360: subversion/bindings/swig/python/svn_client.lo] Error 1
 * ERROR: dev-vcs/subversion-1.14.0::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-vcs/subversion-1.14.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-vcs/subversion-1.14.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-vcs/subversion-1.14.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-vcs/subversion-1.14.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0'
 * S: '/var/tmp/portage/dev-vcs/subversion-1.14.0/work/subversion-1.14.0'
...


Has anyone an idea what the issue with these Python bindings could be?
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2264
Location: Frankfurt, Germany

PostPosted: Fri Jun 26, 2020 2:38 pm    Post subject: Reply with quote

That's probably Bug 725850

Try to emerge subversion without USE flag 'python'.
Back to top
View user's profile Send private message
firefoxthegreat
n00b
n00b


Joined: 26 Feb 2013
Posts: 4

PostPosted: Tue Jun 30, 2020 7:07 pm    Post subject: Reply with quote

Thank you, that was indeed the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum