Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sound issue kernel 4.19.122-v8-2d6b57a6d622-p4-bis+
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
dony71
n00b
n00b


Joined: 19 May 2020
Posts: 5

PostPosted: Fri Jun 12, 2020 1:58 am    Post subject: sound issue kernel 4.19.122-v8-2d6b57a6d622-p4-bis+ Reply with quote

I have install 64-bit RPi4 Gentoo 1.5.4 image and
somehow in last couple days the kernel has been updated automatically
to 4.19.122-v8-2d6b57a6d622-p4-bis+
After update, I notice sound is no longer working
Executing "alsamixer" or "aplay -l" or "speaker-test" no response
But if execute as root via sudo, everything is fine
I check /etc/group, shows already
audio:x:18:pi

Anybody can help what's wrong?
Back to top
View user's profile Send private message
dony71
n00b
n00b


Joined: 19 May 2020
Posts: 5

PostPosted: Fri Jun 12, 2020 2:01 am    Post subject: Reply with quote

I notice has some Gdk-CRITICAL in .xsession-errors
Not sure what it means and whether this causing sound issue?


Code:
pi@pi64 ~ $ cat .xsession-errors
/usr/bin/iceauth:  creating new authority file /run/user/1001/ICEauthority
gpg-agent[3458]: WARNING: "--write-env-file" is an obsolete option - it has no effect
gpg-agent[3483]: gpg-agent (GnuPG) 2.2.20 started

(xfce4-session:3096): xfce4-session-WARNING **: 18:47:19.547: gpg-agent returned no PID in the variables

(process:3508): Gtk-WARNING **: 18:47:19.936: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3530): Gtk-WARNING **: 18:47:22.044: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3535): Gtk-WARNING **: 18:47:22.082: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3541): Gtk-WARNING **: 18:47:22.142: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3545): Gtk-WARNING **: 18:47:22.184: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3549): Gtk-WARNING **: 18:47:22.226: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3555): Gtk-WARNING **: 18:47:22.272: Locale not supported by C library.
        Using the fallback 'C' locale.

(process:3556): Gtk-WARNING **: 18:47:22.390: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3530): xfsettingsd-WARNING **: 18:47:22.756: Unknown mode '1920x1080 @ 60.0' for output HDMI-1, aborting.

(Thunar:3580): Gtk-WARNING **: 18:47:22.856: Locale not supported by C library.
        Using the fallback 'C' locale.
Internal error:   Could not resolve keysym XF86FullScreen

(xfdesktop:3618): Gtk-WARNING **: 18:47:23.278: Locale not supported by C library.
        Using the fallback 'C' locale.

(process:3628): Gtk-WARNING **: 18:47:23.894: Locale not supported by C library.
        Using the fallback 'C' locale.

(process:3627): Gtk-WARNING **: 18:47:23.915: Locale not supported by C library.
        Using the fallback 'C' locale.
Connection failure: Connection refused
(null): warning: could not set default locale

(process:3681): Gtk-WARNING **: 18:47:24.524: Locale not supported by C library.
        Using the fallback 'C' locale.

(process:3692): Gtk-WARNING **: 18:47:24.785: Locale not supported by C library.
        Using the fallback 'C' locale.

(process:3710): Gtk-WARNING **: 18:47:24.884: Locale not supported by C library.
        Using the fallback 'C' locale.

(xfsettingsd:3749): Gtk-WARNING **: 18:47:25.089: Locale not supported by C library.
        Using the fallback 'C' locale.

(wrapper-2.0:3628): Gtk-WARNING **: 18:47:25.694: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

(blueman-applet:3663): Gtk-WARNING **: 18:47:27.712: Locale not supported by C library.
        Using the fallback 'C' locale.
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/pyconfig_gen", line 10, in <module>
    main_dialog.main()
  File "/usr/lib64/python3.6/site-packages/pyconfig_gen/main_dialog.py", line 1155, in main
    is_autostart = parser.isSet(a_opt))
  File "/usr/lib64/python3.6/site-packages/pyconfig_gen/main_dialog.py", line 1114, in __init__
    self.setup_wifi_country_codes()
  File "/usr/lib64/python3.6/site-packages/pyconfig_gen/main_dialog.py", line 1088, in setup_wifi_country_codes
    self.country_list = get_wifi_country_list()
  File "/usr/lib64/python3.6/site-packages/pyconfig_gen/config_utils.py", line 358, in get_wifi_country_list
    for line in in_file1:
  File "/usr/lib64/python3.6/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1268: ordinal not in range(128)

(blueman-applet:3663): Gdk-CRITICAL **: 18:47:29.773: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

(xfdesktop:3907): Gtk-WARNING **: 18:47:36.245: Locale not supported by C library.
        Using the fallback 'C' locale.


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Sakaki
Guru
Guru


Joined: 21 May 2014
Posts: 403

PostPosted: Fri Jun 12, 2020 4:33 pm    Post subject: Reply with quote

dony71,

simply bumping the kernel should not be causing any issues with e.g. alsamixer. What do you get if you run:
Code:
demouser@pi64 ~ $ ls -ld /home/demouser/.config/pulse
demouser@pi64 ~ $ ls -l /home/demouser/.config/pulse

Specifically, is everything owned by demouser:demouser?
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum