Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[discord-bin] blank window
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Adrien
Advocate
Advocate


Joined: 13 Jul 2004
Posts: 2279
Location: Paris - France

PostPosted: Sat Apr 18, 2020 7:49 pm    Post subject: [discord-bin] blank window Reply with quote

Hello! :)

Code:
user@localhost ~ $ discord
Discord 0.0.10
Starting app.
Starting updater.
[Modules] Modules initializing
[Modules] Distribution: remote
[Modules] Host updates: enabled
[Modules] Module updates: enabled
[Modules] Module install path: /home/user/.config/discord/0.0.10/modules
[Modules] Module installed file path: /home/user/.config/discord/0.0.10/modules/installed.json
[Modules] Module download path: /home/user/.config/discord/0.0.10/modules/pending
[4213:0418/153036.029871:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]
GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[Modules] No updates to install
[Modules] Checking for host updates.
[Modules] Host is up to date.
[Modules] Checking for module updates at https://discordapp.com/api/modules/stable/versions.json
[Modules] No module updates available.
[4213:0418/153036.837564:ERROR:buffer_manager.cc(488)]
[.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command


Then, discord window opens correctly but is totally empty...

I am currently using:
xorg-server-1.20.7
mesa-19.3.5

And here is my make.conf:
Code:
INPUT_DEVICES="libinput joystick"
GRAPHIC_CARDS="i915 i965"


Anyone could tell me what I'm missing here? :)

Many thanks for your help.
Back to top
View user's profile Send private message
Adrien
Advocate
Advocate


Joined: 13 Jul 2004
Posts: 2279
Location: Paris - France

PostPosted: Sun Apr 19, 2020 11:52 am    Post subject: Reply with quote

Code:
[4213:0418/153036.837564:ERROR:buffer_manager.cc(488)]
[.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command


Passing the option --disable-gpu (which anyway my i915 chip doesn't seem to support) makes the error disappear but the window still displays nothing whereas it seems the app isl aunched properly.
Back to top
View user's profile Send private message
OldTango
l33t
l33t


Joined: 21 Feb 2004
Posts: 635

PostPosted: Tue May 19, 2020 10:29 pm    Post subject: Reply with quote

Adrien wrote:
Code:
[4213:0418/153036.837564:ERROR:buffer_manager.cc(488)]
[.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command


Passing the option --disable-gpu (which anyway my i915 chip doesn't seem to support) makes the error disappear but the window still displays nothing whereas it seems the app isl aunched properly.


A recent update has rendered discord-bin unusable to me at present even though it worked very recently.

The application fails to even start:
Code:
michael@SuperTux ~ $ discord
[1464:0519/160911.208575:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/discord/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap
A quick check revels "chrome-sandbox" is owned by root:root but permissions are 644 (100644) not 755

Found a BUG REPORT on this. There are a couple of fixes suggested, one is changing the permissions on "chrome-sandbox" or enabling CONFIG_USER_NS in the kernel. I will test the kernel fix when I have the time to recompile my kernel later this week.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum